Closed Bug 12293 Opened 21 years ago Closed 21 years ago

weird redraw problem and system crash

Categories

(SeaMonkey :: General, defect, P3, critical)

x86
Windows 95
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: bugs, Assigned: trudelle)

References

Details

August 21 and 22's builds have been having strange redraw problems, whereby
randomly portions of the screen go black (including parts over other
applications, when Mozilla is running minimized).

Sometimes this leads to a bluescreen and an automatic system shutdown.

Its hard to give "steps" to reproduce, the blackness just appears when you use
the browser for more than a short while, and interact with the UI to any great
degree.
Severity: normal → critical
Summary: weird redraw problem → weird redraw problem and system crash
This is at least critical. (I'm hesitating to mark this a blocker since
it blocks the testing work.)

One way to reproduce to grab the window in the corner and resize the window
continuously. (Assuming "Show window contents while dragging" is turned on.)
I got the problem come out in like 5 second.
I had to press reset to recover.
I happend on 8/23 Win32 Build.. also.. Another way to reproduce is Just go
throught all the XPmenus and mozilla will trun black <inverse> then other
windows application will trun inverse and window will Shut down by it self. I
can reproduce it over and over again.
*** Bug 12321 has been marked as a duplicate of this bug. ***
There was a big thread on mozilla-builds on Aug 23 entitled "Hook: Win98
Resource Leak" about this problem.  Is it fixed on Aug 24 builds?  Was the code
causing the problems backed out?  cc:ing leaf@mozilla.org.
the code that apparently was behind the original resource leaking was backed out
yesterday, yes.

However, it looks like there are other windows 9x resource leaks today, which
are not as severe, and therefore, not holding the tree closed.
Assignee: don → trudelle
Peter, any idea who should get this?  I'm stumped.  The only "step" here is
going through the XP menus.
I'm unable to reproduce this, using both of the scenarios, back to back, for a
couple of minutes each.  I'm using Win98 though, is this problem only observed
on Win95?  If I don't hear of a way to reliably reproduce this, I'm inclined t
mark it worksforme.
I think the issue here, from the sound of it, has been fixed.
However, if there are any other resource leaks, bugs should probably
be filed.  What's the best way to track resource leaks on Windows?
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
I don't know, sorry. resolving as worksforme
Status: RESOLVED → VERIFIED
I have not seem this on Win builds for some time.  Marking Verified
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.