[Email]The first word of default signing messages is cut off in "Mail account setup" page and account setting page.

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: huayu.li, Assigned: jrburke)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 disabled, b2g-v2.5 affected, b2g-master verified)

Details

(Whiteboard: LocRun2.5)

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8694104 [details]
Flamekk_v2.5.png

[1.Description]:
[Flame2.5&master][Email]The first word of default signing messages is cut off  in "Mail account setup" page. 
See attachment:Flamekk_v2.5.png

[2.Testing Steps]: 
Precondition:Switch system language to persian.
1. Tap on the "Email" icon. 
2. Login to Email using a valid email and password. 
3. Tap "Next" on the "Check new messages" page. 
4. Check all the strings on the "Mail account setup" page. 

[3.Expected Result]: 
4.All the text should be displayed completely.

[4.Actual Result]: 
4.You can see the first word of default signing messages is cut off.

[5.Reproduction build]: 
Device: Flamekk v2.5 512mb build [Affected]
Build ID               20151130173516
Gaia Revision          391bcad1b3b427f189f4c7f11858fc739574682e
Gaia Date              2015-11-30 15:51:31
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/1a022b4b67446b50f36c098aa425c65782af9066
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151130.164630
Firmware Date          Mon Nov 30 16:46:40 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flamekk master 512mb build [Affected]
Build ID               20151130173516
Gaia Revision          391bcad1b3b427f189f4c7f11858fc739574682e
Gaia Date              2015-11-30 15:51:31
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/1a022b4b67446b50f36c098aa425c65782af9066
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151130.164630
Firmware Date          Mon Nov 30 16:46:40 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
11982

[8.Note]:
1. There is no Persian language on v2.2 build
2. This issue also exists in  account setting page.
3. This issue only exists in Persian language.
(Reporter)

Updated

3 years ago
QA Whiteboard: [MGSEI-l10n-2F]
status-b2g-v2.2: --- → disabled
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
If this only affects Persian, this should be under the Mozilla Localizations section. Moving. Let's see if there is any workaround like shortening the string or abbreviation here. thanks
Component: Gaia::E-Mail → fa / Persian
Product: Firefox OS → Mozilla Localizations
Created attachment 8694425 [details]
b2g_persian_new_mail.png
This is happening because the text is italic and the beginning character is gone out of scope. As you see in my screenshot even a bigger screen (shorter sentence) won't fix this issue. I guess it's a font problem but might be able to fix it with editing the CSS.
(Assignee)

Comment 4

3 years ago
Switching it back to email: a similar fix was done in email for bug 1176832 by adding some padding in the email CSS. Bug 1176832 comment 13 points to the larger issue of the UI using italics, where it is generally not a great, generic choice due to these kinds of issues.

For now though, I think it will be enough to add some padding in the email app itself. I will take a quick look at it now.
Component: fa / Persian → Gaia::E-Mail
Product: Mozilla Localizations → Firefox OS
As Arash mention it, this is because of font and also using italic style for this part of string, maybe change the font or adjust word-spacing in CSS improve the gap between the words.
Created attachment 8694479 [details] [review]
[gaia] jrburke:bug1229315-email-ar-signature-padding > mozilla-b2g:master
(Assignee)

Comment 7

3 years ago
Comment on attachment 8694479 [details] [review]
[gaia] jrburke:bug1229315-email-ar-signature-padding > mozilla-b2g:master

Bug fix is similar to the one for bug 1176832, add some padding. Tested on flame device with ar localization in effect.
Attachment #8694479 - Flags: review?(bugmail)
(Assignee)

Updated

3 years ago
Assignee: nobody → jrburke
Status: NEW → ASSIGNED
Attachment #8694479 - Flags: review?(bugmail) → review+
(Assignee)

Comment 8

3 years ago
Merged in master:
https://github.com/mozilla-b2g/gaia/commit/1763ccdfe56fc02e3084b64d7000591005fa91db

from pull request:
https://github.com/mozilla-b2g/gaia/pull/33478
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
(Reporter)

Comment 9

3 years ago
This issue has been verified as pass on latest build of Flamekk_master.
Rate:0/10
Actual Result: All the text is displayed completely.

Device: FlameKK master 512mb build[pass]
Build ID               20151209150205
Gaia Revision          961528f4391668bc89ec0be14fa367cea099b588
Gaia Date              2015-12-08 18:11:20
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b40ba117fa757861c9caa660ae989122718b494b
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151209.182453
Firmware Date          Wed Dec  9 18:25:03 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
status-b2g-master: fixed → verified
(Reporter)

Comment 10

3 years ago
Created attachment 8697153 [details]
Verify_pass_flameKK_master.png
You need to log in before you can comment on or make changes to this bug.