[ko] tracking for Aurora 44 update

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jincreator, Assigned: hyeonseok)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1218172 +++

If I understand properly about l10n sign-off, translation for fx_aurora 44 must be done before upcoming merge day. If not, please let me know.
(Assignee)

Comment 1

3 years ago
Thanks Jinkyu,

I've done translation of shared strings on Pontoon. It looks fennec 44 is also done.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

3 years ago
When I checked l10n dashboard, translation for fennec 44 is already done. who did?
and... I also visited to pontoon, but I couldn't find Firefox for Android Aurora ko project.
Hyeonseok, Please make a project for fennec at pontoon.

From now on, do we move from mercurial cli to pontoon for products localization???

Comment 3

3 years ago
Is there anything left which I should follow up, please let me know
(Reporter)

Comment 4

3 years ago
(In reply to pillarlee16 from comment #2)
> When I checked l10n dashboard, translation for fennec 44 is already done.
> who did?
That makes me confused about this l10n release cycle and hesitate to open this bug. It seems there's no new string added in fennec_44.

$ hg up aurora
0 files updated, 0 files merged, 0 files removed, 0 files unresolved
$ hg log -l 1 mobile/locales/en-US/
changeset:   289341:40c6bcb88bc4
user:        Masatoshi Kimura <VYV03354@nifty.ne.jp>
date:        Sat Oct 17 09:38:31 2015 +0900
summary:     Bug 1207137 - Implement weak crypto override UI. r=ttaubert

As you see, there's no new strings after Oct 17 but I'm not sure why. I'm also wondering why I can't find l10n report for this cycle. Any announce I missed about it?

(In reply to pillarlee16 from comment #2)
> and... I also visited to pontoon, but I couldn't find Firefox for Android
> Aurora ko project.
> Hyeonseok, Please make a project for fennec at pontoon.
I'm not Hyeonseok...anyway I can find it. Also, I guess you should sign in to see and modify strings.

(In reply to pillarlee16 from comment #2)
> From now on, do we move from mercurial cli to pontoon for products
> localization???
Sorry, I should talk about it with other people after coming back from Tokyo. Let's discuss details in mailing list. If I understand properly, using both Pontoon and hg in same time can make consistency problem. But if we can track when other localizers use Pontoon, then I guess we can use hg after Pontoon synced changes. See https://groups.google.com/forum/#!topic/mozilla.dev.l10n/2CaGPdc2AmM

For example, here's latest translation in hg pushed by Pontoon:
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ko/rev/ce1bdc613a67
If anyone translate no more strings in Pontoon before changes in that commit was made, then I think push new translations by hg is safe. But if Myoung-Gwon or someone else is still translating at Pontoon right now, we should wait(max 1 hour?) to use hg until Pontoon pushed new changes to VCS.
(Reporter)

Comment 5

3 years ago
(In reply to Jinkyu Yi[:jincreator] from comment #4)
> (In reply to pillarlee16 from comment #2)
> > When I checked l10n dashboard, translation for fennec 44 is already done.
> > who did?
> That makes me confused about this l10n release cycle and hesitate to open
> this bug. It seems there's no new string added in fennec_44.
> 
> $ hg up aurora
> 0 files updated, 0 files merged, 0 files removed, 0 files unresolved
> $ hg log -l 1 mobile/locales/en-US/
> changeset:   289341:40c6bcb88bc4
> user:        Masatoshi Kimura <VYV03354@nifty.ne.jp>
> date:        Sat Oct 17 09:38:31 2015 +0900
> summary:     Bug 1207137 - Implement weak crypto override UI. r=ttaubert
> 
> As you see, there's no new strings after Oct 17 but I'm not sure why. I'm
> also wondering why I can't find l10n report for this cycle. Any announce I
> missed about it?

Sorry, Ignore my previous message. I think the reason is you did translation after merge day in previous release.
(Assignee)

Comment 6

3 years ago
Firefox for Android Aurora · Korean (ko) is available on Pontoon at https://pontoon.mozilla.org/ko/firefox-for-android-aurora/.

I think you (and we) can use both hg and Pontoon, if you prefer using hg. Before deciding this, I think it is good for all to use and test Pontoon. In my case, after translating over 700 strings from Gaia 2.5, I think I will mostly depend on Pontoon except there is a certain reason for using hg. "The end of manual copy and paste"

AFAIK, Pontoon is no more than text editing environment in the point of VCS. It works based on files, that means it pushes only files that you touched. We are normally working on different product and files, there is very little possibility to conflict. When it conflicts, I think we can handle conflict because we all have a push access.
(Assignee)

Comment 7

3 years ago
Merge day is over and Firefox and Thunderbird beta is still not translated. I'll translate them this weekend using Pontoon. Please let me know if you guys have other schedules on this.

Comment 8

3 years ago
Sorry for late.
I'll push TB to beta directly until this evening.
(Assignee)

Comment 9

3 years ago
Translated Firefox Beta. Signed-off Firefox Beta and Thunderbird Beta.

Thanks, guys!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.