Using beta with e10s turned on breaks NoScript bar

RESOLVED DUPLICATE of bug 1058542

Status

()

RESOLVED DUPLICATE of bug 1058542
3 years ago
3 years ago

People

(Reporter: u52928, Unassigned)

Tracking

43 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151126120800

Steps to reproduce:

1. Activate e10s in beta 43.0b7 (using about:config) / NoScript add-on 2.7 is installed
2. Surf to any site


Actual results:

The NoScript "notification" bar (at bottom of screen) never appears. 


Expected results:

(On many sites) the NoScript "notification" bar should appear at the bottom of the screen - and does when e10s is turned off.

Updated

3 years ago
Blocks: 905436, 1058542
tracking-e10s: --- → +

Comment 1

3 years ago
Why is this blocking bug 1058542 rather than being a duplicate of it?
Component: Untriaged → Extension Compatibility

Comment 2

3 years ago
I assume because it's currently working "fine" in Nightly. Or at least it appears that NoScript is currently much more functional in Nightly than it is in 43.0b7 for some reason.
(Reporter)

Comment 3

3 years ago
Yes, it appears to be working OK in Nightly (v45). 

As for bug 1058542, yes, it appears related. I simply filed this bug because I noticed the issue. I'm not a "computer person" - just a retired English teacher - and I have no idea of the technical issues involved. 

If I can help with "end-user" testing, I'll be happy to do so, but that's about the limit of my abilities.

Comment 4

3 years ago
(In reply to Gingerbread Man from comment #1)
> Why is this blocking bug 1058542 rather than being a duplicate of it?
I agree, I think this is a duplicate of bug 1058542.

JoeG,

Why do Gingerbread Man and I think this is a duplicate?

I'll give you two reasons:

1. bug 1058542 (e10s-noscript) [e10s] "NoScript" add-on does not work with e10s
was opened 2014-08-26.

Giorgio Maone, the author of NoScript, is well aware that NoScript does not
work properly when you enable e10s.
See https://bugzilla.mozilla.org/show_bug.cgi?id=1058542#c3
and other Comments by Giorgio Maone in bug 1058542.

2. Giorgio Maone has been helping Authors of other Extensions to get their
Extension working using e10s.

See https://wiki.mozilla.org/Electrolysis/Meetings/2015-04-02
and all the Electrolysis Meetings since April 2015, that are linked there.

He is keen to get e10s (Electrolysis - multi-process Firefox) enabled on Release.
However, he can't get NoScript working with e10s.

I am certain that if he had got *all aspects of* NoScript working *correctly*
with e10s he would have announced it and closed bug 1058542.

As I rely on NoScript and my 'normal browser' is Aurora / Developer Edition
I have (more than once) 'switched off e10s' because I know that NoScript 
does not work properly.

I 'switched off e10s' by 'un-ticking'
"Enable multi-process Firefox Developer Edition" in
about:preferences#general

I'll comment in the thread you started at mozillaZine
http://forums.mozillazine.org/viewtopic.php?f=23&t=2976659

The convention, in bugzilla, is that 'additional reports' of the same issue
are regarded as duplicates.

In this case the *main* issue is:
NoScript add-on (Extension) does not work with e10s.

JoeG, as you opened this bug, please can you close it as a duplicate of bug 1058542.

DJ-Leith
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1058542
You need to log in before you can comment on or make changes to this bug.