Hello fails on Linux as a system add-on due to platform.css missing

VERIFIED FIXED in Firefox 45

Status

Hello (Loop)
Client
P1
normal
Rank:
9
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

unspecified
mozilla45
Points:
---

Firefox Tracking Flags

(firefox45 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
On Linux, Hello is currently failing, Randell reported that it has the Hello button, but it fails to load anything.

Exception on the console:

1448984590850   addons.xpi WARN     Exception running bootstrap method startup on loop@mozilla.org: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIStyleSheetService.loadAndRegisterSheet]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm -> file:///home/jesup/src/mozilla/inbound/obj-x86_64-unknown-linux-gnu-debug/dist/bin/browser/features/loop@mozilla.org/bootstrap.js :: startup :: line 775"  data: no] Stack trace: startup()@resource://gre/modules/addons/XPIProvider.jsm -> file:///home/jesup/src/mozilla/inbound/obj-x86_64-unknown-linux-gnu-debug/dist/bin/browser/features/loop@mozilla.org/bootstrap.js:775 < this.XPIProvider.callBootstrapMethod()@resource://gre/modules/addons/XPIProvider.jsm:4587 < this.XPIProvider.startup()@resource://gre/modules/addons/XPIProvider.jsm:2723 < callProvider()@resource://gre/modules/AddonManager.jsm:227 < _startProvider()@resource://gre/modules/AddonManager.jsm:833 < AddonManagerInternal.startup()@resource://gre/modules/AddonManager.jsm:1016 < this.AddonManagerPrivate.startup()@resource://gre/modules/AddonManager.jsm:2781 < amManager.prototype.observe()@addonManager.js:58 

Not sure why this didn't show up on mochitests.
(Assignee)

Updated

3 years ago
Iteration: --- → 45.3 - Dec 14
Rank: 9
(Assignee)

Comment 1

3 years ago
Created attachment 8694393 [details] [diff] [review]
Hello fails on Linux as a system add-on due to trying to load platform.css that doesn't exist.

There's two routes we could have gone here, one was to add an empty platform.css, the second which I'm doing is to skip trying to load it for Linux.

I went for the second as it seemed slightly better performance wise overall.
Attachment #8694393 - Flags: review?(mdeboer)
Comment on attachment 8694393 [details] [diff] [review]
Hello fails on Linux as a system add-on due to trying to load platform.css that doesn't exist.

Review of attachment 8694393 [details] [diff] [review]:
-----------------------------------------------------------------

Ship it!
Attachment #8694393 - Flags: review?(mdeboer) → review+

Comment 4

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/51508d3c41d9
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
Flags: qe-verify+
QA Contact: bogdan.maris
Reproduced the exception from console using an old Nightly (2015-12-01) on Ubuntu 12.04 32-bit, and verified that using latest Nightly 45.0a1 I don't have the same behavior.
Status: RESOLVED → VERIFIED
status-firefox45: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.