Closed Bug 1229511 Opened 10 years ago Closed 10 years ago

upgrade to mysql-python 1.2.5

Categories

(Input :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: willkg, Unassigned)

References

Details

The version of mysql-python we're using (1.2.3) doesn't support utf8mb4 so you can't smile, can't cry and can't leave feedback with poop in it. This is an appalling state of affairs and I'm not going to take it anymore. This bug covers upgrading to mysql-python 1.2.5. We need to update the requirements file and make sure it works with all our tests and stuff. Then get the servers updated (that'll require another bug).
I'll grab this to work on after Mozlando some time.
Assignee: nobody → willkg
Ok! I upgraded the mysql python lib on my local machine to 1.2.5 and set charset and collation to their respective forms of "utf8mb4" and that works super. I had to fix some other things since it looks like datetimes have millisecond precision now. But, that's all good. This is the path we want to go down. I'll write up a bug with webops to get mysql python lib updated on all the computers everywhere. Then we can land this. In a PR: https://github.com/mozilla/fjord/pull/720 Note: Bug #1232406 has to get fixed first before we can merge this.
The thing that's blocking us is that Travis is failing the tests for PR 720. It's failing because it's using the mysql that comes with ubuntu 12.04. We need to fix that to know whether we're good tests-wise.
I had a long chat with Mike Kelly about this and we decided that since these changes create a bunch of new problems because awesome, it's better to just leave the situation be until we get to AWS. Thus I'm going to unassign myself.
Assignee: willkg → nobody
We're going to WONTFIX this.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.