Please change servo.org DNS to use CloudFlare nameservers

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
5 days ago

People

(Reporter: edunham, Assigned: bhourigan)

Tracking

Details

(Reporter)

Description

3 years ago
We're setting up CloudFlare for servo.org to distribute GitHub Pages-hosted sites over HTTPS. Please change the nameservers as specified below. 

Current Nameservers:    Change Nameservers To:
ns5-65.akam.net	        ian.ns.cloudflare.com
ns7-66.akam.net	        sharon.ns.cloudflare.com
ns4-64.akam.net	        Remove this nameserver
ns1-240.akam.net	Remove this nameserver

Thanks!
(Assignee)

Comment 1

3 years ago
> ns5-65.akam.net	        ian.ns.cloudflare.com
> ns7-66.akam.net	        sharon.ns.cloudflare.com
> ns4-64.akam.net	        Remove this nameserver
> ns1-240.akam.net	Remove this nameserver

The domain nameservers have been changed at the domain registrar.
Assignee: infra → bhourigan
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

3 years ago
Thanks for the quick resolution!
We'll need to remove it from Inventory DNS as well.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

3 years ago
Thanks :atoll, I went ahead and removed this from inventory. :edunham, this should clear up the issues you're having in about 30 minutes. please close this bug once you can confirm things are working properly.
(Reporter)

Comment 5

3 years ago
DNS looks right from a machine in the office. Thanks for fixing this!
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Reopening this bug because it seems that inventory still has records for this that still need to get squashed since the DNS now resides with CloudFlare:

./org/servo/servo.org.private:blog.servo.org.                           IN  CNAME servo.github.io.
./org/servo/servo.org.private:doc.servo.org.                            IN  CNAME servo.github.io.
./org/servo/servo.org.private:www.servo.org.                            IN  CNAME servo.github.io.
./org/servo/servo.org.public:blog.servo.org.                           IN  CNAME servo.github.io.
./org/servo/servo.org.public:doc.servo.org.                            IN  CNAME servo.github.io.
./org/servo/servo.org.public:www.servo.org.                            IN  CNAME servo.github.io.

See Bug #1268064 for context on why this is being unearthed.
Flags: needinfo?(bhourigan)
(Assignee)

Comment 7

2 years ago
Records for servo.org showing up in dnsconfig is a bit of a red herring. I confirmed that servo.org.(private|public) is not present in our BIND config. The zone files remain as an artifact of an inventory bug. It will never delete deleted zones from svn.

I confirmed that Mozilla DNS servers are not loading this zone.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Flags: needinfo?(bhourigan)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.