Fail the build if a packaged resource is unused during packaging

RESOLVED DUPLICATE of bug 1158018

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1158018
2 years ago
a year ago

People

(Reporter: Away for a while, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Every once in a while, people run into the issue of forgetting to add something like an xpt or manifest file to the package manifest.  This works on local builds because people don't usually package those builds, but once they push to try they see failures since the packaged build lacks the resource.

It would be nice if at the end of the packaging step, we would error out if there is something in a moz.build manifest that needs to be packaged, but it was excluded from the package.  That would turn mysterious runtime errors into build failures telling people what went wrong.
It would only be possible if we didn't purposefully put things in dist/bin that we don't package.
(Reporter)

Comment 2

2 years ago
I was talking about essentially diffing the contents of the package manifest and what we declare as "packageable" in moz.build files.
(In reply to :Ehsan Akhgari from comment #2)
> I was talking about essentially diffing the contents of the package manifest
> and what we declare as "packageable" in moz.build files.

Comment 1 still applies. Bug 1158018 is probably where we should go anyways.
(Reporter)

Comment 4

2 years ago
Bug 1158018 will be *much* better, I agree.  Maybe we should dupe this against that bug?
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1158018
You need to log in before you can comment on or make changes to this bug.