Exiting in fullscreen causes problems for next startup

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Ryan of Tinellb, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

* Open Firefox.
* Press fullscreen button.
* Press Alt-F4 to exit.
* Re-open Firefox.

This is on Windows 10 both on an HP laptop and an Asus Transformerbook.


Actual results:

* Firefox opens as if in full screen mode, but fullscreen is not activated.
* Address bar is not selected.
* "Restore Previous Session" is unavailable.
* Subsequent activation of fullscreen by use of fullscreen button only changes window state from maximised to windowed.
* In order to restore normal condition, the fullscreen button must be pressed, followed by exiting and restarting the program.


Expected results:

* Firefox should either open in the same fullscreen as before, or open up normally.
Component: Untriaged → General
Product: Firefox → Core
This works for me on User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.