Intermittent async-scrollbar-1-v.html,async-scrollbar-1-vh.html,async-scrollbar-1-v-ref.html | load failed: timed out while taking snapshot (bug in harness?), | load failed: timed out waiting for APZ flush to complete, | program error managing timeouts

RESOLVED FIXED in Firefox 46

Status

()

RESOLVED FIXED
3 years ago
15 days ago

People

(Reporter: philor, Assigned: kats)

Tracking

({intermittent-failure})

unspecified
mozilla47
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox45 unaffected, firefox46 fixed, firefox47 fixed, firefox-esr45 unaffected)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Comment 1

3 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=18113036&repo=mozilla-inbound
Summary: Intermittent async-scrollbar-1-v.html | load failed: timed out while taking snapshot (bug in harness?) → Intermittent async-scrollbar-1-v.html | load failed: timed out while taking snapshot (bug in harness?), | load failed: timed out waiting for APZ flush to complete, | program error managing timeouts
Duplicate of this bug: 1229576
Blocks: 1230182
(Reporter)

Updated

3 years ago
Summary: Intermittent async-scrollbar-1-v.html | load failed: timed out while taking snapshot (bug in harness?), | load failed: timed out waiting for APZ flush to complete, | program error managing timeouts → Intermittent async-scrollbar-1-v.html,async-scrollbar-1-vh.html | load failed: timed out while taking snapshot (bug in harness?), | load failed: timed out waiting for APZ flush to complete, | program error managing timeouts
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 3
* mozilla-central: 2

Platform breakdown:
* android-4-3-armv7-api11: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1229624&startday=2015-11-30&endday=2015-12-06&tree=all
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 4
* fx-team: 1
* b2g-inbound: 1

Platform breakdown:
* android-4-3-armv7-api11: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1229624&startday=2015-12-07&endday=2015-12-13&tree=all
7 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 3
* mozilla-central: 2
* fx-team: 2

Platform breakdown:
* android-4-3-armv7-api11: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1229624&startday=2015-12-14&endday=2015-12-20&tree=all
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 3
* mozilla-inbound: 2

Platform breakdown:
* android-4-3-armv7-api11: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1229624&startday=2015-12-21&endday=2015-12-27&tree=all
7 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 3
* mozilla-central: 2
* fx-team: 1
* b2g-inbound: 1

Platform breakdown:
* android-4-3-armv7-api11: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1229624&startday=2015-12-28&endday=2016-01-03&tree=all
7 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 3
* mozilla-inbound: 2
* mozilla-central: 1
* b2g-inbound: 1

Platform breakdown:
* android-4-3-armv7-api11: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1229624&startday=2016-01-04&endday=2016-01-10&tree=all
Blanket gfx-noted on APZ intermittent failures so they can be found more easily on https://brasstacks.mozilla.com/orangefactor/
Whiteboard: [gfx-noted]
11 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 4
* try: 2
* mozilla-inbound: 2
* b2g-inbound: 2
* mozilla-central: 1

Platform breakdown:
* android-4-3-armv7-api11: 11

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1229624&startday=2016-01-11&endday=2016-01-17&tree=all
9 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 4
* fx-team: 3
* b2g-inbound: 2

Platform breakdown:
* android-4-3-armv7-api11: 9

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1229624&startday=2016-01-18&endday=2016-01-24&tree=all
11 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 9
* mozilla-central: 1
* fx-team: 1

Platform breakdown:
* android-4-3-armv7-api11: 10
* android-4-3-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1229624&startday=2016-01-25&endday=2016-01-31&tree=all
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 6

Platform breakdown:
* android-4-3-armv7-api15: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1229624&startday=2016-02-01&endday=2016-02-07&tree=all
(Reporter)

Updated

3 years ago
Summary: Intermittent async-scrollbar-1-v.html,async-scrollbar-1-vh.html | load failed: timed out while taking snapshot (bug in harness?), | load failed: timed out waiting for APZ flush to complete, | program error managing timeouts → Intermittent async-scrollbar-1-v.html,async-scrollbar-1-vh.html,async-scrollbar-1-v-ref.html | load failed: timed out while taking snapshot (bug in harness?), | load failed: timed out waiting for APZ flush to complete, | program error managing timeouts
Created attachment 8718819 [details] [diff] [review]
Disable chaos mode

Edwin discovered in bug 1229250 that these failures were caused by the chaos-mode annotation, because it causes the reftest timeout to fire too early. That was not really the intent of the chaos-mode annotation, so it is broken. I'm removing it from these tests for now. Once Edwin gets his patch in bug 1229250 landed we can put this back.
Assignee: nobody → bugmail.mozilla
(Reporter)

Comment 16

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7bcdb398ff43
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
11 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 7
* fx-team: 2
* try: 1
* mozilla-aurora: 1

Platform breakdown:
* android-4-3-armv7-api15: 11

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1229624&startday=2016-02-08&endday=2016-02-14&tree=all
Comment hidden (obsolete)
Ironically we should back this out of nightly since bug 1229250 fixed it better. :) But maybe let's wait until things have settled down more.
Duplicate of this bug: 1244443
You need to log in before you can comment on or make changes to this bug.