[RTL][Gallery]Some listed items in the detail view of photo and video are not right-aligned in Persian language.

RESOLVED FIXED

Status

Firefox OS
Gaia::Gallery
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Lancy(Leave from Mozilla), Assigned: Arash)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 fixed, b2g-master verified)

Details

(Whiteboard: [2.5-rtl-test-run])

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8694580 [details]
Persian_detail view of photo and video.png

[1.Description]:
[RTL][FlameKK v2.5&master][AriesKK v2.5&master][Gallery]Some listed items in the detail view of photo and video are not right-aligned in Persian language.
See attachment:Persian_detail view of photo and video.png

[2.Testing Steps]: 
1.Set your phone language as Persian.
2.Launch Gallery.
3.Select a photo or a video.
4.Tap the detail button.

[3.Expected Result]: 
4.All the listed items in the detail view of photo and video should be right-aligned.

[4.Actual Result]: 
4.Some listed items in the detail view are not right-aligned.

[5.Reproduction build]: 
Device: FlameKK v2.5 512mb build (Affected)
Build ID               20151201163815
Gaia Revision          07462becf08f0c26ebd64daf89646e7403a336c5
Gaia Date              2015-12-01 15:06:08
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/33a575e711faf3344aa2e31ca2ea066b4cd8aafa
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151201.154956
Firmware Date          Tue Dec  1 15:50:05 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: FlameKK master 512mb build (Affected)
Build ID               20151201150223
Gaia Revision          59c8605876736b22acaaed25be00008e452149cb
Gaia Date              2015-12-01 02:58:37
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1003fca97839fdfbfefb89c48c9e05a940bc9fb9
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151201.183010
Firmware Date          Tue Dec  1 18:30:23 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device:AriesKK v2.5 build (Affected)
Build ID               20151201171338
Gaia Revision          e05621cbfd92b3fb4e5aef86621c57cd68fb0414
Gaia Date              2015-12-01 15:07:53
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/89b4f90d2865e62b9d898655cf082902cf2572a0
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151201.161919
Firmware Date          Tue Dec  1 16:19:27 UTC 2015
Bootloader             s1

Device:AriesKK master build (Affected)
Build ID               20151202015416
Gaia Revision          7847a3c1b28e039631509978518b36fd3c5f9585
Gaia Date              2015-12-01 18:47:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/470f4f8c2b2d6f82e56e161a4b05262c85f55b59
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151202.011126
Firmware Date          Wed Dec  2 01:11:35 UTC 2015
Bootloader             s1

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
(Reporter)

Updated

2 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
Yeah I see this issue also exists in Arabic language. Adding Ahmed and Arash to get their insight on this. thanks
Flags: needinfo?(nefzaoui)
Flags: needinfo?(mousavi.arash)
(Assignee)

Comment 2

2 years ago
Created attachment 8696358 [details] [review]
[gaia] arash-m:bug/gallary_info_label > mozilla-b2g:master

This is happening because on "shared/confirm.css" the role for "dl > dt" is defining "text-align: left". The obvious fix to me would be to overwrite it on RTL to "text-align: right". I submitted a PR on Github for this.
Flags: needinfo?(mousavi.arash)
(Assignee)

Updated

2 years ago
Assignee: nobody → mousavi.arash
Comment on attachment 8696358 [details] [review]
[gaia] arash-m:bug/gallary_info_label > mozilla-b2g:master

You'd need to set a reviewer in order for someone to look at your patch and have it reviewed and -- if r+'ed -- merged.
I think David is in charge of the Gallery app in this case.
Flags: needinfo?(nefzaoui)
Attachment #8696358 - Flags: review?(dflanagan)
Comment on attachment 8696358 [details] [review]
[gaia] arash-m:bug/gallary_info_label > mozilla-b2g:master

I'm not really a good reviewer for this file, but I don't know if anyone really is.  This is a very simple patch and it only affects RTL languages. I worry about unintended consequences, but it does fix an obvious bug, so I guess we should land it.
Attachment #8696358 - Flags: review?(dflanagan) → review+
Landed to master: https://github.com/mozilla-b2g/gaia/commit/37b9af00e007c9f13b7b047486a8f865bde5888a
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
Arash,

Thanks for this patch! Based on comment #3 I assume you do not have commit rights, so I landed it for you.

Note that when you commit a patch to github you should not include a r= in the commit message. We add that when we merge a pull request, when we know who the actual reviewer is. If you add r=somebody when you commit the patch you don't know if that person will actually be the reviewer.  Also, r= is for the reviewer who signs off on the patch, not for the author of the patch, so it is never appropriate to put yourself as the r=.
Flags: needinfo?(mousavi.arash)
Delphine: is this a fix that should be uplifted to 2.5?
Flags: needinfo?(lebedel.delphine)
(Assignee)

Comment 8

2 years ago
David,

Thanks for the merge! Awesome :)
About the r=, thanks for the information. I didn't know it. In wiki[1] it's mentioned:

> 'my commit message' needs to be substituted for a string containing the Bugzilla bug number and 
> title of the bug, plus more information describing what the patch does, and who committed it. "Bug 9999999 - Fix that annoying bug R=johndoe"

So I thought "R=johndoe" is about the "who committed it" part.

[1] https://developer.mozilla.org/en-US/Firefox_OS/Developing_Gaia/Submitting_a_Gaia_patch
Flags: needinfo?(mousavi.arash)
Since RTL was in scope of 2.5, if this is low risk I would say this can land. I'll let RelMan decide for approval or not though! thanks
Flags: needinfo?(lebedel.delphine) → needinfo?(mpotharaju)
Very minor fix. Not a must have on 2.5. Lets not uplift it to 2.5

Thanks
Flags: needinfo?(mpotharaju)
(Assignee)

Comment 11

2 years ago
Created attachment 8701221 [details]
Files deatils on video app

As it is obvious in the attachment, on 2.5 branch when going to details view of a file in Video app, the first character of title is not visible and makes it unreadable. This happens on both Arabic and Persian locale on Video app (not Gallery).

With this new info, doesn't the patch worth to be uplifted to 2.5?
Flags: needinfo?(mpotharaju)
Comment on attachment 8696358 [details] [review]
[gaia] arash-m:bug/gallary_info_label > mozilla-b2g:master

Thanks for the new image. Approving it for 2.5 uplift.

Thanks for your work Arash!
Flags: needinfo?(mpotharaju)
Attachment #8696358 - Flags: approval-gaia-v2.5+
(Reporter)

Comment 13

2 years ago
Created attachment 8701367 [details]
Verify1_Arabic&Persian_master.png

This issue is verified as pass on latest FlameKK&AriesKK master build in Arabic and Persian languages.
Actual result:All the listed items in the detail view of photo and video are right-aligned.
See attachment:Verify1_Arabic&Persian_master.png.
Reproducing rate:0/10

Device: AriesKK master(Pass)
Build ID               20151222115209
Gaia Revision          f3cf488a97ecaec43369f3e3d8a7dda52be019f9
Gaia Date              2015-12-22 02:20:26
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ad16863d1d45bd3fd7906c76fa1ac1e12d24a133
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151222.111221
Firmware Date          Tue Dec 22 11:12:28 UTC 2015
Bootloader             s1

Device: FlameKK master 512mb(Pass)
Build ID               20151222030233
Gaia Revision          f3cf488a97ecaec43369f3e3d8a7dda52be019f9
Gaia Date              2015-12-22 02:20:26
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ad16863d1d45bd3fd7906c76fa1ac1e12d24a133
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151222.071644
Firmware Date          Tue Dec 22 07:16:57 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
(Reporter)

Updated

2 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
status-b2g-master: fixed → verified
for 2.5 https://github.com/mozilla-b2g/gaia/commit/8db2cdd9eb9b42932c4dfc86d109b3e46c220809
status-b2g-v2.5: affected → fixed
You need to log in before you can comment on or make changes to this bug.