jumping submit button within non-scrollable frame

VERIFIED DUPLICATE of bug 119849

Status

()

Core
Layout: HTML Frames
VERIFIED DUPLICATE of bug 119849
17 years ago
16 years ago

People

(Reporter: Christopher Cobb, Assigned: Marc Attinasi)

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122106

Since I'm behind a firewall, I can't publish an URL, but here are the files. 
There are two files:  Frameset.html and JumpingButton.html.  Copy them into a
directory and load Frameset.html.  You will see a submit button centered at the
top of the page.  Click on the button.  It jumps to the left-hand side of the
page.  Nuff said.

--- Frameset.html ---
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN">
<html>
 <head>
  <title>Jumping Button Frameset</title>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
 </head>
 <frameset>
  <frame src="JumpingButtonFrame.html" scrolling="no">
 </frameset>
</html>
--- end Frameset.html ---

--- JumpingButton.html ---
<html>
 <head>
  <title>Jumping Button Frame</title>
 </head>
 <body>
  <div align="center">
  <form>
   <table><tr><td><input type="submit"></td></tr></table>
  </form>
  </div>
 </body>
</html>
-- end JumpingButton.html ---



Reproducible: Always
Steps to Reproduce:
1. Load file Frameset.html into browser
2. Press button
3. Viola!  Button jumps to the left

Actual Results:  Submit button which had been centered on page jumps to the left.

Expected Results:  Submit button should not move.

The first time the button is clicked, it jumps to the left but does not trigger
any submit mechanisms within the browser.  After the button has jumped left, it
can then be pressed to cause a submit.  Obviously, the jumping to the left
should not happen, and the submit should take effect the first time.
(Reporter)

Comment 1

17 years ago
Created attachment 67419 [details]
This has the two files needed to reproduce this bug.

This file has to two files needed to reproduce the bug.

Comment 2

17 years ago
Created attachment 67424 [details]
File 1 for testcase

Comment 3

17 years ago
Created attachment 67425 [details]
File 1

Comment 4

17 years ago
Created attachment 67428 [details]
testcase

Comment 5

17 years ago
Confirming issue. There are several reports about scrolling = no issue. Sending
to  HTML frames.
Assignee: attinasi → eric
Status: UNCONFIRMED → NEW
Component: Layout → HTMLFrames
Ever confirmed: true
QA Contact: petersen → amar

Comment 6

17 years ago
If I had 'action=javascript:void(0)' to the form tag, the button doesn't jump
anymore.

Comment 7

17 years ago
s/had/add in the previous comment. CCing myself

Comment 8

17 years ago
action=javascript:void(0) doesn't change anything. Sorry for the spam.

Time to go to bed.

Comment 9

17 years ago
*** Bug 122225 has been marked as a duplicate of this bug. ***
jkeiser, this is the bug I mentioned....scrolling="no" and all that.
OS: Windows 2000 → All
Hardware: PC → All
*** Bug 123305 has been marked as a duplicate of this bug. ***
to default owner
Assignee: eric → jkeiser
*** Bug 123978 has been marked as a duplicate of this bug. ***
*** Bug 124406 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
I'm not behind a firewall so I can publish my URL.  It's

   http://home.pacbell.net/spmorse/census

Click on either the faq button or the other-webpages button and you'll see the 
problem.

I reported it in bug 124406 and had my own simplified test case there.  Very 
similar to the one posted above, but I'll copy it here just for comparison sake.  
Both use centering.  In my case I observed that if I removed the centering the 
problem does not occur.

main.html
---------

<html>
  <frameset rows=200,*>
    <frame name="topFrame" src="button.html" frameborder="no" scrolling="no">
    <frame name="bottomFrame" src="about:blank" frameborder="no" scrolling="no">
  </frameset>
  <noframes>
    <body> <P> </body>
  </notframes>
</html>

button.html
-----------

<html>
  <body>
    <center>
      <form name="searchform">
        <input type="button" value="Mozilla"
               onclick="top.location='http://www.mozilla.org';">
      </form>
    </center>
  </body>
</html>

Comment 16

17 years ago
Is there any work-around for this other than removing the centering tags?
No longer blocks: 124431
Keywords: nsbeta1
Marking nsbeta1+. This problem seems to showing itself in a number of different
bugs. The initial reflow is doing something different than the incremental
reflow later.
Assignee: jkeiser → attinasi
Keywords: nsbeta1 → nsbeta1+
Target Milestone: --- → mozilla1.0

Comment 18

17 years ago
*** Bug 125275 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 119849 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 20

16 years ago
  Verified dupe of bug 119849
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.