[GUI] remove nightly/inbound distinction in the bisection wizard

RESOLVED FIXED

Status

Testing
mozregression
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: parkouss, Assigned: parkouss)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
We did the same for the CLI: from the command line, there is no distinction anymore for nightly/inbound.

We should do the same for the GUI - it will be a lot simpler for users, only choose an application, bits/repo/build type then choose a bisection range (using one of changesets/dates/release number/build id).
(Assignee)

Comment 1

2 years ago
Created attachment 8694669 [details] [review]
remove nghtly/inbound distinction in wizard

So there are two patches: one in mozregression "core" to avoid logic/code duplication as possible, and ofc one in the GUI component. That's why I ask you two guys for a review. :)

So basically, this change is awesome. :) Now the bisection wizard do not ask the user to choose between "nightlies" or "inbounds" (that was really user-unfriendly) - instead:

 - first page: ask for the application, bits, build type and optional repository.
 - second page: profile customization
 - third (last) page: bisection range selection (using dates/build ids/release numbers/changesets)

As you can see I moved the profile edition to the second page - it makes sense to me, I find it more logic to select the application, then customize it, then select the range. If you don't like it, please say so it will be an easy change.

As a side not, I intend to reuse some pages for the ability to launch a single build. Only the range selection do not make sense in that context, but the two other pages will be reused fully. (that can explain why I put some fields in the pages)

And this change also remove quite a lot of GUI code, so looks like a great cleanup!
Attachment #8694669 - Flags: review?(wlachance)
Attachment #8694669 - Flags: review?(sabergeass)
Comment on attachment 8694669 [details] [review]
remove nghtly/inbound distinction in wizard

This looks good to me! I love it when we can simplify things.
Attachment #8694669 - Flags: review?(wlachance) → review+

Comment 3

2 years ago
Comment on attachment 8694669 [details] [review]
remove nghtly/inbound distinction in wizard

Just like I said, this PR is awesome! :)
Attachment #8694669 - Flags: review?(sabergeass) → review+
(Assignee)

Comment 4

2 years ago
Thanks guys!

Fixed the nits, and merged in https://github.com/mozilla/mozregression/commit/1895eeb2754c49f9b922f7e6b70161ca5d33652b.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.