page takes 100% CPU and never finishes loading

RESOLVED DUPLICATE of bug 81993

Status

()

Core
Layout
P2
critical
RESOLVED DUPLICATE of bug 81993
16 years ago
10 years ago

People

(Reporter: Vinay Badami, Assigned: Kevin McCluskey (gone))

Tracking

({perf, regression, testcase})

Trunk
Future
perf, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
http://www.wkap.nl/prod/s/IFIP

takes 100% CPU and never finishes loading.
IE behaves well.

Under the debugger whenever i break, it seems to be doing a reflow.
I got to this bug since this was reported under bug 120012.

I do not believe that this has anything to do with networking but is reflow related.

Comment 1

16 years ago
Reporter:

- Please always specify which "Build ID" you're using.
- Use severity level "critical" when Mozilla hangs.
- Please also add the keyword "hang".

I can reproduce this, using 2001 01 30 03 with Windows 2000.
Mozilla sucks cpu, and eats memory at a rate of c:a 50 kB per second.
(Reporter)

Comment 2

16 years ago
Using a local build of the tip - maybe a couple of days old.
Severity: major → critical
Keywords: hang
Priority: -- → P1

Comment 3

16 years ago
I see this problem too - Linux 20020201. 100% cpu is chewed up and the page
looks like it will be displayed but then a reflow occurs and only scrolling down
shows up the rest of the page.

The page is displayed without problem in Konqueror.

As a side note, the page seems to contain an invalid utf-8 character in it and
the HTML is absoloutely dreadful...
(Assignee)

Comment 4

16 years ago
Don, please try loading the URL in the bug after you have fixed the image tiling
performance bug. 
Assignee: attinasi → dcone
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 5

16 years ago
*** Bug 123544 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

16 years ago
Page does not hang on WinXP using build 2002020512 and it completely loads. It
is slow to load, and it is slow scrolling after it loads.

Removing hang keyword. Added perf keyword. Moved to Moz1.1
Keywords: hang → perf
Priority: P1 → P3
Target Milestone: mozilla1.0 → mozilla1.1

Comment 7

16 years ago
this seems to be related to bug 124178 (there also win-xp hangs!)
Keywords: mozilla1.0

Comment 8

16 years ago
Once I get this loaded.. which is a pain.. it updates just fine.  I think the
background tile/scrolling part of this is fixed.  I am reassigning back to kevin
so he can dup or triage it to the loading person.. or a DHTML person.  I also
think this is related to or a dup of bug 124178.
Assignee: dcone → kmcclusk
(Assignee)

Comment 9

16 years ago
Bulk moving Mozilla1.1 bugs to future-P2. I will pull from this list when
scheduling post Mozilla1.0 work.
Priority: P3 → P2
Target Milestone: mozilla1.1 → Future

Comment 10

16 years ago
The page doesn't stop loading on build 2002030604 in win-xp

Updated

16 years ago
Keywords: regression

Comment 11

16 years ago
Using build 2002041903 on win-xp,1.1ghz,512ram this page really hogs the cpu.
Looks like it will be displayed but then a reflow occurs and only scrolling 
down shows up the rest of the page. Changed via Taskmanager to another 
application but never was able to get back. Had to kill via Taskmanager.

Comment 12

16 years ago
OS->All
OS: Windows 2000 → All

Updated

16 years ago
Hardware: PC → All

Comment 13

16 years ago
URL does not seem to be available anymore.

Comment 14

16 years ago
tested this today - same as in comment #11.
using trunk build 2002081612.
Keywords: mozilla1.2
I believe this is the same bug as can be observed at http://blog.mynx.com ...
it's currently moving to http://www.mynx.com as I write this, and that will be
the new address.

http://www.wkap.nl/prod/s/IFIP demonstrates a far more aggressive behavior.

http://www.mynx.com uses MovableType, PHP, CSS, and a mixture of XHTML (layout)
and HTML 3.2 (inserted blog content).  Changing the DOCTYPE does not appear to
have any effect.

The most suspicious thing besides the DOCTYPE is how the background is assembled.

html { background: url('images/bg.jpeg') top left repeat-y }
body { background: url('images/top.jpeg') top left no-repeat }

bg.jpeg is a 1x1600 jpeg, or there abouts.

Comment 16

16 years ago
Hmmm.  Checked the two sites in comment #15 under Mac OS 9.2.2 with Mozilla
trunk build 2002103008.   mynx.com loaded without problems. 
http://www.wkap.nl/prod/s/IFIP , billed as demonstrating 'far more aggessive
behavior' took several minutes to load, but did not, repeat not, hang Mozilla.

I could leave Mozilla for the finder without hassle.  Over a dial-up connection,
I could see where someone might think Mozilla was hanging, though.

Comment 17

15 years ago
Reproduced in 1/08/03 Trunk build for Linux. The page in the URl did take
several minutes to load, but never totally hangs and does finish loading
eventually. This is a combination of a slow server and a weird graphic.  I think
there is a very tiny graphic being tiled and that is what is causing the delay...
Keywords: testcase

Updated

15 years ago
Keywords: mozilla1.0, mozilla1.2

Comment 18

15 years ago
the page has 1 unclosed <font> tag for each "volume".  Closing each of the tags
cuts the page load time from 6 minutes to 22 seconds.  Removing the <font> tags
cuts it down to 14 seconds.

All times are on my P-II 450 MHz running Mozilla trunk 20030419 under Linux.

this would seem to be a dupe of bug 81993 or bug 61684

Comment 19

15 years ago
marking dupe of "Mozilla almost hangs on this page with <FONT> tags not closed"

*** This bug has been marked as a duplicate of 81993 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.