UNKNOWN encoding in FROM: mail header

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Giorgio Vecchiocattivi, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If I not use 'Apply default to all message' in Message Display/Language
setting/Character Coding setting. 
An incorrect 'From:' header like
> From: =?UNKNOWN?Q?Mamo=AE?= <xyz@abc.bbb.dd>
(Eudora!!!)

is displayed as chinese (?) (show http://www.imc.pi.cnr.it/~vecchioc/1.gif)

This with 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020131

0.9.7 has no problem

Comment 1

17 years ago
The from field probably has multi-byte character(s) that suggest to Mozilla that
it is Chinese.  0.9.6 might have displayed it as english because it was
"broken".    You might put the characters into an HTML file and see if it
displays it properly.

"Internationalization" is probably a more appropriate component.

Updated

16 years ago
Summary: UNKNOW encoding in FROM: mail header → UNKNOWN encoding in FROM: mail header
Reporter (Giorgio Vecchiocattivi): Can you reproduce this with a recent Mozilla
version (like 1.1beta)? If not, please mark this bug as "worksforme".
(Reporter)

Comment 3

16 years ago
Now an header like this

From: =?UNKNOWN?Q?Mamo=AE?= <m.m@iol.it>

appears as sender "?"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.