Closed Bug 1229905 Opened 4 years ago Closed 2 years ago

Unlocking device with lockscreen disabled will have the current time delay in the status bar

Categories

(Firefox OS Graveyard :: Gaia::System::Status bar, Utility tray, Notification, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 unaffected, b2g-v2.5 affected, b2g-master affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.2 --- unaffected
b2g-v2.5 --- affected
b2g-master --- affected

People

(Reporter: jthomas, Unassigned, NeedInfo)

References

()

Details

(Keywords: regression, Whiteboard: [2.6-Daily-Testing][Spark][systemsfe])

Attachments

(1 file)

Description: 
If the user has the lock screen disabled then unlocking the device will cause a brief delay (about a quarter second) of the time in the status bar icons. Other icons such as Wi-Fi and Service bar will load instantly when unlocking the device.

Repro Steps:

Prereq: Screen lock disabled

1) Update a Aries to 20151202153750
2) With device asleep press power button
3) Observe the time behaviour in status bar icons

Actual:
Brief delay in the time occurs in status bar icons

Expected:
It is expected that the time will be already loaded in the status bar icons

Environmental Variables:
Device: Aries 2.6 Kk
BuildID: 20151202153750
Gaia: 719d89803fd1809bb1132e564a6d0c255963d4b7
Gecko: a0897ec629f90951e685f42eefecea8437481ecb
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 5/5
See attached: Logcat & Video
Video: https://youtu.be/07h_HAmaO-4
This issue DOES occur on Flame Master and Flame 2.5.
Result: Time has a delay in appearing after pressing the power button when device is asleep. 

Environmental Variables:
Device: Flame 2.6 Kk Fullflash (512mb)
BuildID: 20151202030236
Gaia: 7847a3c1b28e039631509978518b36fd3c5f9585
Gecko: 470f4f8c2b2d6f82e56e161a4b05262c85f55b59
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Flame 2.5 Kk Fullflash (512mb)
BuildID: 20151201163815
Gaia: 07462becf08f0c26ebd64daf89646e7403a336c5
Gecko: 33a575e711faf3344aa2e31ca2ea066b4cd8aafa
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

------------------------

This issue does NOT occur on Flame 2.2.
Result: Time already appears in status bar after pressing power button.

Environmental Variables:
Device: Flame 2.2 Kk Fullflash (512mb)
BuildID: 20151202032506
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 4381c4b69b9c
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regression
Whiteboard: [2.6-Daily-Testing][Spark]
Summary: Unlocking device with lockscreen disabled will have the current time delay in the status bar. → Unlocking device with lockscreen disabled will have the current time delay in the status bar
Minor issue, not nominating to block.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Component: Gaia::System::Lockscreen → Gaia::System::Status bar, Utility tray, Notification
Flags: needinfo?(jmercado)
Whiteboard: [2.6-Daily-Testing][Spark] → [2.6-Daily-Testing][Spark][systemsfe]
Let's still get a regression window here though.
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
Turns out this doesn't happen in 2.2 because there was a v2.2-branch-only fix. (This issue has been occurring in master all the way back when master was 2.2 in beginning of January 2015)

b2g37 v2.2 reverse regression window:

Last Broken
Device: Flame
BuildID: 20150324172513
Gaia: 7024dd4c7a7c3616dc8f9f908759f00abc0deddd
Gecko: 3297c641e7e5
Version: 37.0 (2.2) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Working
Device: Flame
BuildID: 20150324191139
Gaia: d225db9622d6e308af02880f43628dcf2f3f9bbe
Gecko: 41b422df890b
Version: 37.0 (2.2) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Last Broken Gaia First Working Gecko - repro
Gaia: 7024dd4c7a7c3616dc8f9f908759f00abc0deddd
Gecko: 41b422df890b

Last Working Gecko First Broken Gaia - no repro
Gaia: d225db9622d6e308af02880f43628dcf2f3f9bbe
Gecko: 3297c641e7e5

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/7024dd4c7a7c3616dc8f9f908759f00abc0deddd...d225db9622d6e308af02880f43628dcf2f3f9bbe

This issue is fixed in v2.2 by changes made in Bug 1145760.
QA Whiteboard: [QAnalyst-Triage?]
Depends on: 1145760
Flags: needinfo?(jmercado)
^ 2nd swap wording is wrong. It should be "last broken gecko & first working gaia - no repro"
Alberto can you please take a look at this?  You fixed this issue in the 2.2 branch with the change in bug 1145760.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(apastor)
The fix might be different, as the method that was fixing this is removed in master (now is gecko the ones that renders depending on the space we have).

Keeping the ni for trying to take a look when I have a chance. Thanks!
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][Low_QA]
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.