Closed Bug 1229917 Opened 5 years ago Closed 5 years ago

Incredibly slow performance while simultaneously loading several tabs

Categories

(Core :: General, defect)

44 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: tmay, Unassigned)

Details

(Whiteboard: [betabreakers-fx44])

Attachments

(5 files)

Attached file Shadowsong DxDiag.txt
Actual Result:
When the user has multiple pages, around 10 or more, the performance is so slow it renders the computer unusable for five minutes at a time. Attempting to navigate to a new page or open a new tab creates adds addition time of the computer being in-operable. 

Expected Result:
It is expected that the browser should be able to handled multiple web pages without freezing the computer and rendering it useless for minutes at a time. 

Steps to Recreate:
1. Launch firefox and navigate to Alexa.com
2. Click on France of Oman. 
3. Ctrl click the top 10 sites, opening them in new tabs. 
4. Make sure to open each page instead of just the alexa details page for the sites. 
5. Observe that the computer is frozen for minutes at a time and refreezes every after any user interaction with the web browser.
Whiteboard: [betabreakers-fx44]
Could you provide an about:memory profile for this?
Summary: Incredibly Slow Performance → Incredibly slow performance while simultaneously loading several tabs
Thanks, while your system only has 2GB of memory it doesn't look like you're running low. I'm curious, how does performance fair on Internet Explorer, Chrome, and earlier versions of Firefox on the same system.

Note: moving out of Graphics since this is a general performance issue.
Component: Graphics → General
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #5)
> Thanks, while your system only has 2GB of memory it doesn't look like you're
> running low. I'm curious, how does performance fair on Internet Explorer,
> Chrome, and earlier versions of Firefox on the same system.
> 
> Note: moving out of Graphics since this is a general performance issue.

It seemed to only freeze up when using firefox, however I was not putting nearly as much stress on other browsers. I will retest with control browsers when done with this config.
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #5)
> Thanks, while your system only has 2GB of memory it doesn't look like you're
> running low. I'm curious, how does performance fair on Internet Explorer,
> Chrome, and earlier versions of Firefox on the same system.
> 
> Note: moving out of Graphics since this is a general performance issue.

It was slow in other browsers but it was still usable.
(In reply to Trammel May from comment #7)
> It was slow in other browsers but it was still usable.

I suspect multi-process in other browsers may have helped here. Can you try Firefox Nightly 45.0a1 with multi-process turned on to see if it makes a difference?
Attached file Horridon Memory.gz
Horridon also experienced this
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #8)
> (In reply to Trammel May from comment #7)
> > It was slow in other browsers but it was still usable.
> 
> I suspect multi-process in other browsers may have helped here. Can you try
> Firefox Nightly 45.0a1 with multi-process turned on to see if it makes a
> difference?

Just retested on Nightly 45.0a1. 
it is still really slow, but it is actually usable. I am going to go ahead and say its fixed in the nightly.
(In reply to Trammel May from comment #10)
> Just retested on Nightly 45.0a1 and it is still really slow, but it is actually usable.

How does performance in Nightly compare to performance in Chrome and Edge?
(In reply to Anthony Hughes (:ashughes) [GFX][QA][Mentor] from comment #11)
> (In reply to Trammel May from comment #10)
> > Just retested on Nightly 45.0a1 and it is still really slow, but it is actually usable.
> 
> How does performance in Nightly compare to performance in Chrome and Edge?

(e10s keeps getting better)
Flags: needinfo?(tmay)
Whiteboard: [betabreakers-fx44] → [closeme 2016-05-15][betabreakers-fx44]
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(tmay)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2016-05-15][betabreakers-fx44] → [betabreakers-fx44]
You need to log in before you can comment on or make changes to this bug.