Closed Bug 1229918 Opened 9 years ago Closed 9 years ago

[Skia-update branch] LateWriteObserver abort within SkiaGLGlue destructor

Categories

(Core :: Graphics, defect)

Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox45 --- affected

People

(Reporter: jruderman, Unassigned)

References

Details

(4 keywords, Whiteboard: [gfx-noted])

Attachments

(2 files)

Attached file testcase
Using https://treeherder.mozilla.org/#/jobs?repo=try&revision=91dc4f334fc5&selectedJob=14357526

1. Load the testcase
2. Quit

Result: 
Hit MOZ_CRASH() at xpcom/build/LateWriteChecks.cpp:120
...with skia on the stack

This does NOT reproduce on mozilla-central because bug 1082598 has not landed yet.
Attached file stack
I was not able to reproduce this using nightly and a my patches from bug 1082598, though that was on Linux. This might be OS X specific, and might need to be re-investigated once 1082598 lands.
OS: Unspecified → Mac OS X
Whiteboard: [gfx-noted]
WFM on mozilla-central on Mac.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: