Closed Bug 1229923 Opened 4 years ago Closed 4 years ago

Flash of 'paused' state on debugger startup

Categories

(DevTools :: Debugger, defect)

defect
Not set

Tracking

(firefox45 fixed)

RESOLVED FIXED
Firefox 45
Tracking Status
firefox45 --- fixed

People

(Reporter: bgrins, Assigned: jlong)

References

Details

Attachments

(2 files)

When I open the debugger panel I see a moment when the pause button turns into a blue play button (as if the debugger is paused).  After a second it goes back to normal.  See attached gif.

I'm assuming this is due to Bug 1200798.
Assignee: nobody → jlong
Attached patch 1229923.patchSplinter Review
Attachment #8695339 - Flags: review?(bgrinstead)
I was calling `onNavigate` on startup which is wrong, because all I wanted to do was load sources. In `onNavigate` the thread state is checked and the button is updated, and the JS engine is paused for a second on load, so it was reflecting that.
Comment on attachment 8695339 [details] [diff] [review]
1229923.patch

Review of attachment 8695339 [details] [diff] [review]:
-----------------------------------------------------------------

Fixes the problem for me.  Is there a reasonable way to add a regression test for this?
Attachment #8695339 - Flags: review?(bgrinstead) → review+
Status: NEW → ASSIGNED
(In reply to Brian Grinstead [:bgrins] from comment #4)
> 
> Fixes the problem for me.  Is there a reasonable way to add a regression
> test for this?

I don't think it needs a test. We would be testing that the ThreadState._update function is not called on startup which I think is too specific of a workflow to be in a test. Writing tests like that make it hard to refactor in the future (having just gone through updating a lot of tests...)

I'd be down for a test if we were looking for a specific action to happen. I don't think every single change needs a test though, especially as I clean up code from the refactoring.
https://hg.mozilla.org/mozilla-central/rev/a1440a731b1a
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45
QA Whiteboard: [good first verify]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.