[Skia-update branch] SkRRect.cpp:534: failed assertion "min <= max"

RESOLVED DUPLICATE of bug 1018527

Status

()

--
critical
RESOLVED DUPLICATE of bug 1018527
3 years ago
3 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
assertion, regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 affected)

Details

(Whiteboard: [gfx-noted])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8695023 [details]
testcase

Using the Mac build from https://treeherder.mozilla.org/#/jobs?repo=try&revision=91dc4f334fc5

(This does NOT reproduce on mozilla-central because bug 1082598 has not landed yet.)

gfx/skia/skia/src/core/SkRRect.cpp:534: failed assertion "min <= max"
(Reporter)

Comment 1

3 years ago
Created attachment 8695024 [details]
stack
This bug was recently fixed as a consequence of bug 1018527, which added checks for infs in ValidateRect, so that ClearRect no longer has to deal with them and they will never get to Skia via this path.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Whiteboard: [gfx-noted]
Duplicate of bug: 1018527
You need to log in before you can comment on or make changes to this bug.