Intermittent e10s browser_compartments.js | Sanity check (parent process: 0): totalUserTime of component is not impossibly larger than that of process: 31012550 <= 30265935 - false == true - JS frame :: chrome://mochitests/content/browser/toolkit/compone

RESOLVED FIXED

Status

()

defect
P5
normal
RESOLVED FIXED
4 years ago
Last year

People

(Reporter: philor, Unassigned)

Tracking

(Blocks 1 bug, {intermittent-failure})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox45 affected)

Details

(Whiteboard: [test disabled on Linux !debug e10s])

Summary: Intermittent browser_compartments.js | Sanity check (parent process: 0): totalUserTime of component is not impossibly larger than that of process: 31012550 <= 30265935 - false == true - JS frame :: chrome://mochitests/content/browser/toolkit/components/pe → Intermittent e10s browser_compartments.js | Sanity check (parent process: 0): totalUserTime of component is not impossibly larger than that of process: 31012550 <= 30265935 - false == true - JS frame :: chrome://mochitests/content/browser/toolkit/compone
Blocks: e10s-tests
tracking-e10s: --- → +
David, any thoughts here?  This is in the top 5 intermittents for today.
Flags: needinfo?(dteller)
Keywords: leave-open
Whiteboard: [test disabled on Linux !debug e10s]
Pushed by philringnalda@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/803e3e88b5c0
skip browser_compartments.js on Linux opt e10s for constant failures
Intermittent e10s test failure
Priority: -- → P5
So this was a MacOS-only intermittent that stopped for 5 months, then resurfaced on June 10th as a Linux-only intermittent. Pretty weird, especially since I haven't touched that code in ages.

Looking at the logs, I can't find anything meaningful on or around June 10th. Actually, I only a see a single patch on mozilla-central around that date (I guess everybody was in the plane), and it doesn't even get close to this code.

Mike, do you know if we changed anything big in e10s around these date? Or perhaps there was a change in infrastructure?
Flags: needinfo?(dteller) → needinfo?(mconley)
(In reply to David Rajchenbach-Teller [:Yoric] (please use "needinfo") from comment #26)
> So this was a MacOS-only intermittent that stopped for 5 months, then
> resurfaced on June 10th as a Linux-only intermittent. Pretty weird,
> especially since I haven't touched that code in ages.
> 
> Looking at the logs, I can't find anything meaningful on or around June
> 10th. Actually, I only a see a single patch on mozilla-central around that
> date (I guess everybody was in the plane), and it doesn't even get close to
> this code.
> 
> Mike, do you know if we changed anything big in e10s around these date? Or
> perhaps there was a change in infrastructure?

I'm afraid nothing sticks out in memory. Hey bhearsum, do you know if we changed any Linux infrastructure around that time?
Flags: needinfo?(mconley) → needinfo?(bhearsum)
(In reply to Mike Conley (:mconley) - (Needinfo me!) from comment #27)
> (In reply to David Rajchenbach-Teller [:Yoric] (please use "needinfo") from
> comment #26)
> > So this was a MacOS-only intermittent that stopped for 5 months, then
> > resurfaced on June 10th as a Linux-only intermittent. Pretty weird,
> > especially since I haven't touched that code in ages.
> > 
> > Looking at the logs, I can't find anything meaningful on or around June
> > 10th. Actually, I only a see a single patch on mozilla-central around that
> > date (I guess everybody was in the plane), and it doesn't even get close to
> > this code.
> > 
> > Mike, do you know if we changed anything big in e10s around these date? Or
> > perhaps there was a change in infrastructure?
> 
> I'm afraid nothing sticks out in memory. Hey bhearsum, do you know if we
> changed any Linux infrastructure around that time?

I know there's been a lot going on with Linux test machinery as we move things to Taskcluster. Buildduty folks - are you able to help answer this?
Flags: needinfo?(bhearsum)
Flags: needinfo?(aselagea)
Flags: needinfo?(aobreja)
June 10th is way too late, it started June 8th around 1pm Pacific on mozilla-inbound, and didn't appear elsewhere until after merges from mozilla-inbound happened.

I remember really liking aswan for it just because his bug summary included "sanity", but if I wanted something affecting Linux in https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&tochange=b598ce1977bc54968e485184a16d410b231f2843&fromchange=9eeb5a616d4a1357877d33748bfd95736cedefb8&filter-searchStr=9e4f6afe7ce6d9c8c2332e1d94acc0466d77c4d3 I'd probably pick bug 1197954.
no idea at all the validity of this answer, or specifically the "where did this come from" http://stackoverflow.com/questions/25513796/importerror-no-module-named-pygtk

but that *may* be a useful thing to try, if we can reproduce this at least sorta-reliably
The issue resurfaced on June 8, but on try. Several failures occurred on m-i after that: https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1230018&startday=2016-06-01&endday=2016-07-12&tree=all

The changes done in that try push don't seem to be related to this error. https://treeherder.mozilla.org/#/jobs?repo=try&revision=13cb2b201fac0857e9a1be61fe89ee7ac21096f1. I also looked at the patches landed on m-i and m-c during that time period, but nothing seems to suggest that a code change is responsible for this.

Moreover, this is not a Linux-only as OS X is also affected. The latest occurrence is dated back to almost a week ago though (July 6).
Flags: needinfo?(aselagea)
This problem is found mostly on OS X and the error logs are dating from 3 December 2015:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1230018&entireHistory=true&tree=all
For linux no occurrences were spotted lately.
Flags: needinfo?(aobreja)
No other occurrences were spotted after 21 July:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1230018&tree=all&startday=2015-12-02&endday=2016-08-25

I think we can close this bug.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.