Closed Bug 1230053 Opened 6 years ago Closed 5 years ago

Duplicate case labels in setup.js:onWizardBack

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1231728

People

(Reporter: jaws, Unassigned)

References

Details

onWizardBack: function () {
    switch (this.wizard.pageIndex) {
      case NEW_ACCOUNT_START_PAGE:
      case EXISTING_ACCOUNT_LOGIN_PAGE:
        this.wizard.pageIndex = INTRO_PAGE;
        return false;
      case EXISTING_ACCOUNT_CONNECT_PAGE:
        this.abortEasySetup();
        this.wizard.pageIndex = INTRO_PAGE;
        return false;
      case EXISTING_ACCOUNT_LOGIN_PAGE:
        // If we were already pairing on entry, we went straight to the manual
        // login page. If subsequently we go back, return to the page that lets
        // us choose whether we already have an account.
        if (this.wizardType == "pair") {
          this.wizard.pageIndex = INTRO_PAGE;
          return false;
        }

... (snip)

EXISTING_ACCOUNT_LOGIN_PAGE shows up twice in that snippet for two different cases, the second of which will never be hit.

Tim or Markh, is this old code and can it be deleted? Or should it be kept around and fixed?
Flags: needinfo?(tim)
Flags: needinfo?(markh)
It's effectively dead, but we haven't formally stopped supporting legacy sync for the sake of self-hosters. Within the next 12 months (and possibly even less) we'll kill all of this. So I guess we *should* fix it, yeah.
Flags: needinfo?(tim)
Flags: needinfo?(markh)
We will not fix this - the action here will be to remove that code entirely (if we haven't already)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
This was actually already fixed by bug 1231728 :)
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1231728
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.