Re-enable devtools eslint rules once eslint has been automated

RESOLVED DUPLICATE of bug 1231957

Status

RESOLVED DUPLICATE of bug 1231957
3 years ago
8 months ago

People

(Reporter: pbro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8695169 [details]
.eslintrc

Once bug 1229859 has been fixed, a lot of eslint rules will have been disabled for the sake of having eslint pass in automated tasks/builds.

We should then use this bug to re-enable the disabled rules one by one while fixing the code to make it pass.

Most probably, this will be a meta bug.

I'm attaching our ideal .eslintrc so we can find out which rules have been disabled in bug 1229859.
Component: Developer Tools → Developer Tools
Product: Developer Documentation → Firefox
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1231957

Updated

8 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.