SUGGESTION: Discontinue development of native SVG support, support Adobe in Mozillification of plug-in

RESOLVED INVALID

Status

()

Core
SVG
--
enhancement
RESOLVED INVALID
17 years ago
6 years ago

People

(Reporter: Karl Johan Kleist, Assigned: Alex Fritze)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
[Shields activated.]

Instead of persisting with the Sisyphus work of developing native SVG support
in Mozilla, and maintaining it as SVG evolves, I suggest that efforts are placed
in co-operation with Adobe as to make their excellent SVG plug-in Mozilla compliant.

Obviously, Adobe _are_ already working towards this goal
as indicated by several remarks about Netscape 6 in the chapter
"Known Problems with Adobe SVG Viewer / Netscape" of this document:

    Adobe® SVG Viewer for Windows, Release Notes, Version 3.0 (Build 76)

    < http://www.adobe.com/svg/indepth/pdfs/ReadMewin.pdf >

[I probably don't know which jar I've opened now ;-]
1)  Adobe SVG does not work on Unix (excepting Mac OSX, where it presumably uses
    Carbon)

2)  Are there any other SVG impls out there?  SVG can't even exit CR till there
    are two independent implementations....

3)  The people working on native svg and the people who would usefully contribute 
    to the adobe plugin working with mozilla are nearly nonintersecting sets.
Correction on #2.  There _are_ other SVG impls out there, and SVG _has_ exited
CR.  Partial correction on #1 -- there is a very beta version of the SVG plugin
for Linux only (Solaris users need not apply) that works with Netscape 6.1 only.
We still wouldn't be able to use the Adobe implementation for things like the 
SVG DOM or inline SVG (unless Adobe makes an implementation especially for 
mozilla)
(Assignee)

Comment 4

17 years ago
Yeah good idea. But why single out SVG?

"SUGGESTION: Discontinue development of {Mozilla, Linux, Gnome, KDE, Phython, 
Perl, JavaScript, Apache, SVG}

Instead of persisting with the Sisyphus work of developing {another web 
browser, another OS, another desktop, another web server, another vector 
graphics format}, I suggest that efforts are placed in co-operation with 
{Microsoft, Macromedia} to use their excellent {Internet Explorer, Windows OS, 
VBScript, IIS, Flash}."
;-)

Seriously though: 

There are some things that you can do in Mozilla SVG that you won't be able to 
do with a plug-in (like mixing svg/html/xul/xbl/etc in one doc). E.g. XBL in 
combination with XBL makes for a particularly powerful programming model. 
If all you want to use SVG for is as a Flash replacement (or even just an image-
format) then a plug-in is probably fine for your purposes (and if you meant 
your suggestion serious then that is probably the case). Native SVG support, 
however, opens new worlds of possibilities. E.g. the company I work for, 
Crocodile Clips, have developed a geometry simulator based on XBL/SVG/XUL. We 
couldn't have done that using an SVG plug-in. 

Having said that, there is no reason why native SVG and 3rd party plug-in SVG 
can't co-exist. I'd be interested how you envisage a co-operation with Adobe, 
given their viewer is not open-source. Have Adobe actually expressed a wish in 
that regard towards you?

Comment 5

17 years ago
Adobe's SVG plugin does not work on Win2000 either with r.9.8 (2002-0204). 

Comment 6

17 years ago
Marking as invalid, since it won't work for most platforms.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.