Closed Bug 1230228 Opened 5 years ago Closed 3 years ago

Page for immutable.js has a parallax effect that's jittery with APZ

Categories

(Core :: Panning and Zooming, defect, P2)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: kats, Unassigned)

References

()

Details

(Keywords: polish, Whiteboard: [gfx-noted])

(Filing this so we don't forget about it)

The parallax effect at https://facebook.github.io/immutable-js/ is jittery with APZ. Markus has a different implementation at http://tests.themasta.com/immutablejs-scroll-effect.html in pure CSS although he's not sure how valid it is.
Blocks: apz-desktop
No longer blocks: all-aboard-apz
I am not able to reproduce this issue.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
This is still jittery on OS X with the trackpad scrolling.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Keywords: polish
Whiteboard: [gfx-noted][apz-evangelism]
Depends on: 1246290
It looks like the site has been updated to follow Markus' advice: the header no longer jitters. The only remaining problem is that the logo in the header sometimes overflows the grey header div, but that's due to a bug in Gecko, bug 1214146, which is being actively worked on.
Depends on: 1214146
No longer depends on: apz-parallax, 1246290
Whiteboard: [gfx-noted][apz-evangelism] → [gfx-noted]
(In reply to Botond Ballo [:botond] from comment #3)
> The only remaining problem is that the logo in the header
> sometimes overflows the grey header div, but that's due to a bug in Gecko,
> bug 1214146, which is being actively worked on.

Confirmed that this no longer happens now that bug 1214146 is fixed.
Status: REOPENED → RESOLVED
Closed: 5 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.