Closed Bug 1230278 Opened 5 years ago Closed 5 years ago

Freeze on change tab using Ctrl + Tab when 'Opening file' (download) dialog is open

Categories

(Firefox :: Untriaged, defect)

42 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1227340

People

(Reporter: faelpinho, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

1) Download any file;
2) Will open "Opening *file*" ("What should Firefox do with this file?");
3) Press Ctrl + Tab or Ctrl + Shift + Tab;

Not tested:
Step 1 >> Step 2 >> 3: change tab using mouse



Actual results:

Freeze


Expected results:

Change tab
Tab switching works fine on both my latest developer edition and release version.
Tried both your tested and non-tested method. 
Doesn't seem to have a problem.

You can try starting firefox in safe mode https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Also start firefox with a fresh profile https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Let us know if you find a solution,
Thanks
QA Whiteboard: [bugday-20151130]
User Agent: Mozilla/5.0 (X11; Linux i686; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151206030448

I can't reproduce the bug on latest Nightly 45.0a1(2015-12-06) on safe mode. 
Can you tell me in which Operating System does the bug happen? Can you reproduce this bug on latest nightly?

[bugday-20151207]
Flags: needinfo?(faelpinho)
Windows 7 Ultimate 64 bits
Firefox 42.0
Flags: needinfo?(faelpinho)
Hi guys,

I have managed to reproduce this issue on latest Firefox release (42.0) but only when using the "Ctrl + Shift + Tab" combination of keys. Managed to reproduce it on Win 7, Win 8.1 and Win 10, but I think it reproduces on all Windows versions. You can try with the key combination after the download window is displayed on this site for example "https://mirillis.com/en/downloads/downloading_splashlite.html".

However, I have tested this on latest Nightly builds (45.0a1-20151209142514) and could not reproduce it anymore. The navigation between tabs is not performed while the download window is in focus but In my opinion this is a normal behavior. If the window is out of focus the tab navigation is correctly made.

Performed regression testing and found out that it was fixed in Nightly build from 2015-12-04. Here is the pushlog link for the exact fix (https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=85cf2e720a8405c43eabc9b34cce381b66d25ef9&tochange=33d954cc69ff8e0bd22410e3641533e4fac500cf).

@ Hal Wine, do you know any information about when will be this fix uplifted ? In latest Firefox 43.0b9 the issue is still reproducible so I don't think it will be uplifted in next release.


Thanks,
Paul
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(hwine)
Resolution: --- → DUPLICATE
Duplicate of bug: 1227340
(In reply to Paul Oiegas from comment #4)
> (https://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=85cf2e720a8405c43eabc9b34cce381b66d25ef9&tochange=33d9
> 54cc69ff8e0bd22410e3641533e4fac500cf).
> 
> @ Hal Wine, do you know any information about when will be this fix uplifted
> ? In latest Firefox 43.0b9 the issue is still reproducible so I don't think
> it will be uplifted in next release.

The change you cite was a "bookkeeping" (NPOTB means "not part of the build") commit for a script only run when new b2g gecko branches are created. Once that work is done (it is, in this case), all further uplifts should be handled as described for that branch:
 https://wiki.mozilla.org/Release_Management/B2G_Landing
however, it appears that b2g-ota does not appear there.

ni: nhirata - should the b2g-ota branch uplift guidelines be added to the wiki?
Flags: needinfo?(hwine) → needinfo?(nhirata.bugzilla)
Yes.  I believe it should.  Mahe would be the person encharge of various uplifting, I believe he should update the wiki.
Flags: needinfo?(nhirata.bugzilla) → needinfo?(mpotharaju)
Flags: needinfo?(mpotharaju)
You need to log in before you can comment on or make changes to this bug.