[Flame] [2.6] [Browser] Tapping some links in a site doesn't open the required site

NEW
Unassigned

Status

Firefox OS
Gaia::Browser
2 years ago
2 years ago

People

(Reporter: gaby2300, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

2 years ago
Build 20151203030224

SRT

1. Open browser
2. Go to lanacion.com.ar
3. Tap the 3 lines to the top left of the window to show other headlines.
4. Tap "Deportes"
5. Notice site without content despite the URL is correct: canchallena.lanacion...

Actual: Tapping "Deportes" shows a site without content despite the URL is correct: canchallena.lanacion...

Expected: The site load and show its content

Note: This happens using the browser app or the pinned La Nacion site

Updated

2 years ago
Component: Gaia::Camera → Gaia::Browser
Is this a regression?
Keywords: qawanted
Whiteboard: [systemsfe]
(Reporter)

Updated

2 years ago
Keywords: foxfood

Comment 2

2 years ago
The following test was done using the Browser app.

I am NOT seeing this issue occur on Aries Master, Flame Master and Flame 2.2.
Result: After following the STR the user is able to navigate to canchallena.lanacion successfully. The website is slow to load but seems fairly stable

Environmental Variables:
Device: Aries 2.6 Kk
BuildID: 20151203121905
Gaia: 97266c579c544f5ba57a701f39893cc86d46774a
Gecko: 85cf2e720a8405c43eabc9b34cce381b66d25ef9
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Flame 2.6 Kk Fullflash (512mb)
BuildID: 20151204030224 Kk Fullflash (512mb)
Gaia: e9419046f360dd05b2717c4994990608519b93e4
Gecko: e02b17a2b5b8df7bb84f325fc08eedd2f3cab755
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Flame 2.2 Kk Fullflash (512mb)
BuildID: 20151204032501
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 4381c4b69b9c
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

-----------------------

However, I AM seeing that URL crash out specifically on the Flame 2.5. I have uploaded a video. Although in the video the screen will time out (due to the slowness of the site) the page does crash out and can be seen doing so if the user touches the screen in time while it is loading.

Video: https://youtu.be/KusJr1XK9F8

Environmental Variables:
Device: Flame 2.5 Kk Fullflash (512mb)
BuildID: 20151203091655
Gaia: 2d54c29f429bed790b5d8284633812dc2b782518
Gecko: 241f079cd53c932561c6aa32b9b93c44cd0846d0
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
status-b2g-v2.5: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Keywords: qawanted
Let's get some more checks here.  John, please write the crash you are seeing separately.
status-b2g-v2.2: affected → ---
status-b2g-v2.5: unaffected → ---
status-b2g-master: affected → ---
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
I can't reproduce this on a 12/3 Flame 2.6 build. The website 'canchallena.lanacion...' opened successfully. Reporter, could you try this again? It's possible the site was down when you encountered this.

No repro on:
Device: Flame 2.6 Master
BuildID: 20151203053521
Gaia: 97266c579c544f5ba57a701f39893cc86d46774a
Gecko: 85cf2e720a8405c43eabc9b34cce381b66d25ef9
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
Flags: needinfo?(gmontagu)
(Reporter)

Comment 5

2 years ago
(In reply to Pi Wei Cheng [:piwei] from comment #4)
> I can't reproduce this on a 12/3 Flame 2.6 build. The website
> 'canchallena.lanacion...' opened successfully. Reporter, could you try this
> again? It's possible the site was down when you encountered this.
> 
> No repro on:
> Device: Flame 2.6 Master
> BuildID: 20151203053521
> Gaia: 97266c579c544f5ba57a701f39893cc86d46774a
> Gecko: 85cf2e720a8405c43eabc9b34cce381b66d25ef9
> Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
> Version: 45.0a1 (2.6) 
> Firmware Version: v18Dv4
> User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

I don't think the site was down because I tried several times on different days before I actually filed the bug.
Flags: needinfo?(gmontagu)
Can't repro. See comment 4.
Flags: needinfo?(jmercado)
I can't reproduce this on Aries 2.6 or Flame 2.6. I was able to open canchallena.lanacion.com.ar/m1 select links and reload the page. It appears to be working fine. 

Environmental Variables: (no repro)
Device: Aries 2.6
BuildID: 20151207143802
Gaia: 24ed003a53a81f63367e265fa7117cbe7d23d4c8
Gecko: 59bc3c7a83de7ffb611203912a7da6ad84535a5a
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf

Environmental Variables: (no repro)
Device: Flame 2.6
BuildID: 20151207030216
Gaia: 24ed003a53a81f63367e265fa7117cbe7d23d4c8
Gecko: 528ea05671e9bd9ccb33d1558a20691a72c85f98
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
QA Whiteboard: [QAnalyst-Triage?]
Gabriela are you still seeing this issue?  Three testers have tried to reproduce unsuccessfully.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+][non-reproducible]
Flags: needinfo?(jmercado) → needinfo?(gmontagu)
Keywords: qawanted
(Reporter)

Comment 9

2 years ago
(In reply to Jayme Mercado [:JMercado] from comment #8)
> Gabriela are you still seeing this issue?  Three testers have tried to
> reproduce unsuccessfully.

Yes, even with today's update I'm still seeing the issue: a site without content despite the URL is correct: canchallena.lanacion...
Flags: needinfo?(gmontagu)

Comment 10

2 years ago
(In reply to Jayme Mercado [:JMercado] from comment #8)
> Gabriela are you still seeing this issue?  Three testers have tried to
> reproduce unsuccessfully.

I also tried to reproduce the issue and I was not able. After pressing on Deportes I see content, as expected.

Note: I tried using:

Device details: OS version: 2.6.0.0 prerelease
                Build identifier: 20151130130150
                Platform version: 45.0a1
                Build number: eng.worker.20151019.100643
                dogfood
                Sony Z3C 

and also: nightly-latest , flame device, build identifier: 20151210030222
You need to log in before you can comment on or make changes to this bug.