The "Pin" option should not appear when long-pressing on a hyperlink

VERIFIED FIXED

Status

Firefox OS
Gaia::Browser
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Johnt, Assigned: albertopq)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-v2.2 unaffected, b2g-v2.5 wontfix, b2g-master verified)

Details

(Whiteboard: [2.6-Daily-Testing][Spark][Systemsfe], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8695611 [details]
logcat_20151203_1709.txt

Description:
If the user attempts to pin a page from Market Place (such as an Open website button or an App Icon) they will be unable to open this link found on the New Home Screen page. 

Additionally, the user is unable to add more than one link from Marketplace here. Only one will appear regardless of how many pages are attempted to pin. Please let me know if this should be written as a separate issue later.

Repro Steps:
1) Update a Aries to 20151203121905
2) Select Marketplace
3) Pin anything found in Marketplace (Note that only the first choice will show in New Home Screen)
4) Navigate back to New Home Screen
5) Attempt to open the page that was just added

Actual:
User is unable to open up the link that was added to the New Home Screen.
Only one page can be added to New Home Screen from Marketplace.

Expected:
It is expected that the pinned link from Marketplace will take the user to that particular link that was saved [OR] that the ability to pin a page from Marketplace will be removed entirely.

Environmental Variables:
Device: Aries 2.6 Kk
BuildID: 20151203121905
Gaia: 97266c579c544f5ba57a701f39893cc86d46774a
Gecko: 85cf2e720a8405c43eabc9b34cce381b66d25ef9
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

User Impact:
The user will not be able to add the pages as desired as found within the Marketplace.

Repro frequency: 5/5
See attached: Logcat & Video

Video: https://youtu.be/vh6FRdWQQbs
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Flame Master and Flame 2.5.
Result: Unable to open the link that was added to the New Home Screen.

Environmental Variables:
Device: Flame 2.6 Kk Fullflash (512mb)
BuildID: 20151203053521
Gaia: 97266c579c544f5ba57a701f39893cc86d46774a
Gecko: 85cf2e720a8405c43eabc9b34cce381b66d25ef9
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20151203091655
Gaia: 2d54c29f429bed790b5d8284633812dc2b782518
Gecko: 241f079cd53c932561c6aa32b9b93c44cd0846d0
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

------------------------------

This issue does NOT occur on Flame 2.2 as this feature was not implemented on this version. This makes this not a regression.

Environmental Variables:
Device: Flame 2.2 Kk Fullflash (512mb)
BuildID: 20151203032504
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 4381c4b69b9c
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Whiteboard: [2.6-Daily-Testing][Spark][Systemsfe]
(Reporter)

Updated

3 years ago
Summary: Unable to open Homescreen links pinned pages from Marketplace → Unable to open Homescreen pinned pages from Marketplace
Alison can I get your thoughts here?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(ashiue)

Comment 3

3 years ago
[Blocking Requested - why for this release]:

Besides, select pin from long press hyperlink would pin current page/site not the hyperlink page/site.
The pin status on pin dialog also incorrect.
https://youtu.be/UWv8MY59hSk 

Should we support pin from long press?

Bad user experience, suggest to fix this issue in 2.5


Hi Gregor,

Could you please help to dispatch this issue to suitable person to check? Thank you.
blocking-b2g: --- → 2.5?
Flags: needinfo?(ashiue) → needinfo?(anygregor)
Flags: needinfo?(anygregor)
Is this something we should block on?
Flags: needinfo?(bfrancis)
The "Pin" option should not appear when you long-press on a hyperlink, that is a bug which should block 2.5.

It should not currently be possible to pin pages from the pre-installed Marketplace app because it doesn't have full browser chrome. If you pin pages from Marketplace by navigating to marketplace.firefox.com in the browser then pinning pages works fine, whether or not that site is pinned.
Flags: needinfo?(bfrancis)
Changing the bug title to reflect the real bug.

We could equally make this a working feature by making it pin the href of the anchor rather than the current URL, but that is a new feature we don't have tests for. The simplest solution is likely to disable this un-intended feature.
blocking-b2g: 2.5? → 2.5+
Summary: Unable to open Homescreen pinned pages from Marketplace → The "Pin" option should not appear when long-pressing on a hyperlink
Bringing on Michaels radar so he can assign (probably after the holidays).
Flags: needinfo?(mhenretty)
Alberto, can you take a look at this one?
Flags: needinfo?(mhenretty) → needinfo?(apastor)
(Assignee)

Updated

3 years ago
Assignee: nobody → apastor
Flags: needinfo?(apastor)
Created attachment 8703696 [details] [review]
[gaia] albertopq:1230390-pin-hiperlink > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8703696 - Flags: review?(mhenretty)
Comment on attachment 8703696 [details] [review]
[gaia] albertopq:1230390-pin-hiperlink > mozilla-b2g:master

Looks good to me!
Attachment #8703696 - Flags: review?(mhenretty) → review+
As of Wed, we are only doing uplifts to 2.5 for TV related things. So marking the appropriate flag.
blocking-b2g: 2.5+ → 2.6+
status-b2g-v2.5: affected → wontfix
(Assignee)

Comment 12

3 years ago
master: https://github.com/mozilla-b2g/gaia/commit/b010d8d8273255398c3620ca90c538b5dca6da03
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=Pin the Web]
This issue is verified fixed in Flame 2.6 and Aries 2.6.

Environmental Variables:
Device: Aries 2.6 [Full Flash]
BuildID: 20160224110426
Gaia: 4f0e2a1a42a2d049b6fe8f4f095cdcdf0fd5465c
Gecko: d848a5628d801a460a7244cbcdea22d328d8b310
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 47.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:47.0) Gecko/47.0 Firefox/47.0

Device: FlameKK 2.6 [Full Flash][512mb]
BuildID: 20160225030411
Gaia: 4f0e2a1a42a2d049b6fe8f4f095cdcdf0fd5465c
Gecko: c1e0d1890cfee9d86c8d566b0490053f21e0afc6
Gonk: 8a066f7fa7410e32b58def35f322aa33f03db283
Version: 47.0a1 (2.6) 
Firmware Version: v18D v5
User Agent: Mozilla/5.0 (Mobile; rv:47.0) Gecko/47.0 Firefox/47.0

Result:
The pin option is not present when long pressing a link in marketplace.
Status: RESOLVED → VERIFIED
status-b2g-master: affected → verified
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.