Closed Bug 1230453 Opened 4 years ago Closed 3 months ago

Add a hidden preference to change the number of folders in the recent list of the "bookmark this page" popup

Categories

(Firefox :: Bookmarks & History, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Firefox 72
Tracking Status
firefox72 --- fixed

People

(Reporter: johanrainhill, Assigned: fluks.github)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

Click "bookmark this page" icon on the toolbar. Click second time to open popup window. Click Folder-field / the left side drop down menu (it defaults to "Unsorted bookmarks"). The list of most recent folders at bottom has only 5 entries. We need more.



Expected results:

See
https://support.mozilla.org/en-US/questions/1080380
for the origin of this issue.

Now as quick solution, here is what should be modified. Later, all this should not be hardcoded to the source but added to about:config.

File:
browser\components\places\content\editBookmarkOverlay.js

Line 10:
const MAX_FOLDER_ITEM_IN_MENU_LIST = 5;

Modify from "= 5" to "= 10" as plausible solution. Five is too less as indicated in the original discussion.
I don't think a fixed number is fine for this. another user may require 15 on the list.
So, there can be a button "See all" to access all folders.

Lets see what developers say about this.
Status: UNCONFIRMED → NEW
QA Whiteboard: [bugday-20151130]
Component: Untriaged → Bookmarks & History
Ever confirmed: true
Summary: More folders to Edit This Bookmark window → Add More folders to Edit This Bookmark window, or provide a button
The fixed number is ok, but the count 5 is too low for us who took time to report. The show-all option is already available: the right side button in the Folder field. But show-all is not the solution to this problem!

For me, this is about how many different projects I have at the same time. The working set of projects changes within time; some projects are permanent, some change daily.

Has anyone researched how these lists are used? How often people have to open the full list because the folder is not among the 5? How would the situation change if the list is 10? What would be the ideal value? For me, it seems to be 8 at this moment.

So, please change 5 to 10. Better keep the fix as simple as possible, for now. If the value can be put to about:config easily, that would be perfect. I have not yet examined the source codes that deep.
this would need telemetry data.
Priority: -- → P5
When you start taking telemetry data? Simpler would be just to switch the hard coded 5 to the user modifiable option. That would be good solution to the problem.

Telemetry is always interesting but what will you do if 99% of users are happy with 5? The right question is "does 10 make harm to anyone?" E.g., has someone so small screen that 10th entry would pop out of the screen.

Meanwhile, while waiting 5 to go 10, say, I have done the following: I now use less bookmark folders. I also avoid going to rarely used projects and new projects when all 5 entries are in daily use. I also use keywords which is slightly more convenient than selecting a bookmark folder from the full list. I have not created new bookmark folders since I asked help to the problem. I now use both IE and Firefox; Firefox for the projects.

For example, to the "games" bookmark folder I add all the game playing pages and the game development pages. I used to have different folders for the game rendering algorithms, for the game engine and 3D editor guides, for the GNU/Linux game development, for the game playing guides, for the game tool and installation, for the game modding per game basis (oblivion, skyrim etc). All goes now to the "games" folder.

Can Firefox be installed multiple times? One Firefox per project.
you can have how many profiles you want on a single Firefox install.
Duplicate of this bug: 668947
Duplicate of this bug: 1518980

Considered this annoyance exists from a while, and we didn't find the time to improve the situation, I'd be ok with adding a pref (browser.bookmarks.maxRecentFolders) and set the default value to 7.
The ideal situation would be to run a study changing this value and see at which points folders become pointless... But that's expensive in the end, and this dropdown today is likely used by a minority of users, so the cost would not have an on-par benefit. It would basically never happen.

If someone wants to contribute a patch through Phabricator, we'd look into it.

even better browser.bookmarks.editDialog.maxRecentFolders

"browser.bookmarks.editDialog.maxRecentFolders" sounds great. I look what I can do for the patch, but I'm not a qualified coder and I don't have any dev environment up.

Since I didn't find this bug, I did the DUP dance, sorry. Since I thought I might have come up with some idea that might go somewhere, I'll repost here?

https://searchfox.org/mozilla-central/source/browser/components/places/content/editBookmark.js#7

The MAX_FOLDER_ITEM_IN_MENU_LIST constant "5" is hardwired into the code to manage the popup for the left button in the "Folder:" area in the individual-bookmark-editor popped-down by the star icon. If the new editor decides to display a thumbnail of the page, then this 5 becomes a 4.

I have maybe 8-12 "recent" folders, so important folders are always falling off the list with the 4-5 limit, rendering that cache fairly useless, forcing me to choose the appropriate folder from the full list of dozens, which is more tedious and errorprone.

Letting a user modify that hardwired limit of 5 would be very useful for some people.

I'm looking for a discussion of the right way to do it.

(1) The kludge is to change the 5 to maybe a 12 in a fork.

(2) Better than that would be adding a CSS value to specify it.

(2) Better than even that would be adding a about:config value to specify it.

(3) Interesting, but finicky, would be to modify a threshold of how recent is "recent", and display "all" of them (modulo some maximum number to prevent hundreds being declared recent, and going off the screen).

(4) Some sort of slider somewhere to let you grow or shrink the popup height by dragging the mouse. This seems to me to possibly be overkill unless the sam mechanic were also used elsewhere?

(5) Something else that I didn't think of.

I'm not completely happy with any of of the above, hence this Request For Comments.

Thanks!

Telemetry data does not show you want people want to do, just what you've forced them to do instead. And this cascades via the when people don't even try to do something because 6 things make it so miserable.

Sorry, I've been made extremely allergic to people blocking progress and innovation with telemetry-based-reasoning, which cannot produce new features or recover from races-to-the-bottom. I don't know how to fight it.

Maybe I'm agreeing with the below?

(In reply to johanrainhill@gmail.com from comment #4)

When you start taking telemetry data? Simpler would be just to switch the
hard coded 5 to the user modifiable option. That would be good solution to
the problem.

Telemetry is always interesting but what will you do if 99% of users are
happy with 5? The right question is "does 10 make harm to anyone?" E.g., has
someone so small screen that 10th entry would pop out of the screen.

Meanwhile, while waiting 5 to go 10, say, I have done the following: I now
use less bookmark folders. I also avoid going to rarely used projects and
new projects when all 5 entries are in daily use. I also use keywords which
is slightly more convenient than selecting a bookmark folder from the full
list. I have not created new bookmark folders since I asked help to the
problem. I now use both IE and Firefox; Firefox for the projects.

For example, to the "games" bookmark folder I add all the game playing pages
and the game development pages. I used to have different folders for the
game rendering algorithms, for the game engine and 3D editor guides, for the
GNU/Linux game development, for the game playing guides, for the game tool
and installation, for the game modding per game basis (oblivion, skyrim
etc). All goes now to the "games" folder.

Can Firefox be installed multiple times? One Firefox per project.

Comment 8 already clarifies our current thinking about what would be acceptable to implement, and the point of a study (and the fact we've accepted it isn't likely to happen here). This is ready for implementation but will need a patch from the community as it isn't a priority for us.

Summary: Add More folders to Edit This Bookmark window, or provide a button → Add a hidden preference to change the number of folders in the recent list of the "bookmark this page" popup

Well, I've been repeatedly told that bugzilla is the place for the public to discuss things. If this is open source, what is this "we decided, and so please be quiet" stuff? If its not, why do people claim otherwise?

Its not like this bug is assigned and in progress.

But no, I didn't think any of my ideas were brilliant, I just thought I could possibly spark something interesting.

about:config option would be easy enough to implement. Considering this is up to the community (including me).

(Next problems waits ahead: (1) We need separate bookmarks folders and project folders. (2) A page may have multiple bookmarks but only one can now be edited.)

(In reply to Perry Wagle from comment #14)

Well, I've been repeatedly told that bugzilla is the place for the public to discuss things. If this is open source, what is this "we decided, and so please be quiet" stuff? If its not, why do people claim otherwise?

Yes we can discuss, but your comment 10 pretty much overlapped with the previous comments. Only points 3 and 4 were actually new (the file and constant name were given in comment 0, point 1 and 2b had already been discussed, 2a and 5 would be no-goes). For your point 4, that's not really possible with menus. Your point 3 is possibly viable, but that's probably too much complexity for this dialog considering we expect that very few users use the menu.

Maybe refining the comment rather than just copy and pasting it would have helped?

The additional comment 12 was unnecessary (especially the full quote of comment 4, which you could have just referenced) as the telemetry/study requirement had already been rescinded in comment 8.

Anyway, this is getting off-topic now for this bug.

I wrote my first response in another bug. You DUP'd that bug in favor of this bug. Made sense. No idea why I couldn't find this bug. Thinking that I had brainstormed some possibly interesting ideas in the DUP that hadn't come up here, I dropped them here on the wild off-chance they'd inspire someone to do something interesting. I had already put the effort into my original note that it deserved, so I saw no point to editing other than to quote the response that I was responding to the most. It was a take it or leave it. [I'm just trying to continue living, and trust firefox not-at-all any more to do anything but disintegrate while I have to cling to it. I'll cut myself short and stop there. Note that there IS no on-topic place for this final meta-discussion.]

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/b168ce61ca67
Add a hidden preference to change the number of folders in the recent list of the "bookmark this page" popup. r=mak
Assignee: nobody → fluks.github
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
You need to log in before you can comment on or make changes to this bug.