"Share This Page" functionality broken for Google+ in Firefox Nightly Win64

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: judahrichardson, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8695926 [details]
GooglePlusFail.png

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151204030208

Steps to reproduce:

Use the "Share This Page" button to try to share a page to Google+


Actual results:

Error message saying "Nightly is unable to connect with Google+ right now." Screenshot of error is attached.


Expected results:

The Google+ sharing dialog should have appeared.

Comment 1

3 years ago
Just now got the same result on x86 pgo'd inbound from this morning.

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:45.0) Gecko/20100101 Firefox/45.0

Build ID: 20151204043006
I don't have any problems on my end but here are a few things you could try:

1) Make sure you have no network connectivity or configuration issues, particularly to Google+.
2) Try removing and re-adding the Google+ service to your profile
3) Try using a new Firefox profile without any modification (firefox.exe -P -no-remote)
4) Try rolling back to an older Nightly version to see if this is a regression
Component: General → SocialAPI
(Reporter)

Comment 3

3 years ago
1) Full connectivity. This happens at both work and home.
2) Already tried. Doesn't work.
3) Will try later.
4) It is. It's worked perfectly since the feature was added until shortly before Nov 28.
(In reply to Judah Richardson from comment #3)
> 4) It is. It's worked perfectly since the feature was added until shortly before Nov 28.

In that case, please use mozregression to find the regression window.
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 5

3 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #4)
> (In reply to Judah Richardson from comment #3)
> > 4) It is. It's worked perfectly since the feature was added until shortly before Nov 28.
> 
> In that case, please use mozregression to find the regression window.

Thanks, could you provide a link to how to do that? I've never used it before.
(Reporter)

Comment 7

3 years ago
Fixed by refreshing Nightly.
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID

Comment 8

3 years ago
Please don't close a bug which isn't fixed at other than you.
If we close this by providing that workaround (refreshing Firefox), we should write that on RelNote or so.

I have two profiles which reproduces this issue and one of my friend experiences this issue now.
I tried narrowing regressing range, but trying some 44.0 betas vanished problem on one of my profiles.
(Reporter)

Updated

3 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 9

3 years ago
(In reply to KENZ (Kenji Irie) from comment #8)
> Please don't close a bug which isn't fixed at other than you.
> If we close this by providing that workaround (refreshing Firefox), we
> should write that on RelNote or so.
> 
> I have two profiles which reproduces this issue and one of my friend
> experiences this issue now.
> I tried narrowing regressing range, but trying some 44.0 betas vanished
> problem on one of my profiles.

Reopened.

Comment 10

3 years ago
(In reply to Judah Richardson from comment #9)
> 
> Reopened.

Thank you.
If you wouldn't like to receive bug updates, you can use (never email me about this bug) check mark.

Comment 11

3 years ago
Environments I've exprienced this issue.

my friend(guessing):
 * Windows, he experience this problem after 44->45 update on Release channel

I've checked some of my Firefox profiles (at office and home) from the friend's report.
and some of them have the issue.

mine:
 * Mac OS X 10.10.5, Nightly
 * archlinux, Nightly
 * Windows 8.1, Nightly (problem already vanished on this profile)
Are there any interesting errors in the Browser Console when this occurs?
(Reporter)

Comment 13

3 years ago
(In reply to Ryan VanderMeulen [:RyanVM] from comment #12)
> Are there any interesting errors in the Browser Console when this occurs?

I checked the browser and web consoles and saw nothing :/
(Reporter)

Comment 14

3 years ago
Also, I was wrong: refreshing Nightly does NOT fix the problem. It reappeared soon after.

Comment 15

3 years ago
Created attachment 8715332 [details]
ConsoleOutputWithSaneProfile.txt

browser console with all but css output w/ almost clean profile

Comment 16

3 years ago
Created attachment 8715334 [details]
ConsoleOutputWithBadProfile.txt

browser console with all but css output w/ bad profile reproduces problem

Comment 17

3 years ago
I've noticed it gets [0ms] output without HTTP return code for GET request for Google+.

w/ sane profile:
GET 
https://plus.google.com/share [HTTP/2.0 302 Found 758ms]

w/ bad profile:
GET 
https://plus.google.com/share [0ms]

Comment 18

3 years ago
also I've noticed problematic profile Firefox accesses activations CDN with ja language.

w/ sane profile:
https://activations.cdn.mozilla.net/sharePanel.html [HTTP/1.1 200 OK 0ms]
https://activations.cdn.mozilla.net/en-US/sharePanel.html [HTTP/1.1 200 OK 0ms]

w/ bad profile:
https://activations.cdn.mozilla.net/sharePanel.html [HTTP/1.1 200 OK 0ms]
https://activations.cdn.mozilla.net/ja/sharePanel.html [HTTP/1.1 200 OK 0ms]

but, it looks just a localization difference... hmm...

Updated

3 years ago
Duplicate of this bug: 1250535
I'm unable to reproduce on either win10 or osx 64bit dev edition.

I'm wondering what prefs may have been customized, or addons installed, in profiles that are having this issue.  Especially anything to do with any kind of content blocking (ublock, adblock, firefox tracking protection, etc).

Comment 21

3 years ago
ublock origin, blocking malicious domains (and not ads).
I'll clean the profile then.
(Reporter)

Comment 22

3 years ago
Seems fixed in the 2016-03-21 build, at least on Win 7 x64. Can anyone else confirm?

I'll check my Windows 10 x64 machines later at home. I'm excited to have this fixed TBH ... I rely on the functionality for quick sharing of stuff I'm reading.

Comment 23

3 years ago
I have a similar problem in 2016-03-24 Nightly on Win 7 x64. In my case,

1. Click the button "Share this page".
2. Click any button (e.g. Twitter).
3. Nothing happened.
4. Browser Console said, "cannot use social providers in private windows".

The code which emit the error is:
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/content.js#630

But my window isn't a private window. However, I use Tracking Protection "Always", and I make Nightly "never remember history". Could these config be related to this issue...?

Comment 24

3 years ago
I'm sorry... I had unknowingly enabled "Always use private browsing mode" ;(

Comment 25

3 years ago
(In reply to Judah Richardson from comment #22)
> Seems fixed in the 2016-03-21 build, at least on Win 7 x64. Can anyone else
> confirm?

This seems to be fixed with win64 nightly on my Windows 10 x64 machine too.
RESOLVED/WORKESFOWME?
Based on comment 22 and comment 25 and the fact that I could not reproduce the issue on the latest Nightly (48.0a1, Build ID 20160403030243) I will mark this issue as Resolved-WORKSFORME. If anyone can still reproduce it, feel free to reopen the issue and provide more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WORKSFORME

Updated

3 years ago
Keywords: regression, regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.