bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Problem Quitting Firefox Profile (MacBook Pro El Capitan 10.11.1




Widget: Cocoa
2 years ago
2 years ago


(Reporter: Chris, Unassigned)


42 Branch

Firefox Tracking Flags

(Not tracked)



(3 attachments)



2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_1) AppleWebKit/601.2.7 (KHTML, like Gecko) Version/9.0.1 Safari/601.2.7

Steps to reproduce:

I tried to quite one of my multiple firefox profiles - I have MacBook Pro (MacBook Pro (Retina, 13-inch, Early 2015) and I'm on El Capitan 10.11.1

Actual results:

I can quite from firefox, i need to use the terminal command - There are 2 firefox icons on the dock and one will refuse to quite (even if i press 'Force Quit')

Expected results:

I should have been be able to have only 1 icon and quit without using the terminal

Comment 1

2 years ago
what actually is the problem chris ?
why do you need to quit from terminal. don't you find any close button on your firefox ? or the close button does not work, 

please describe more about the actual problem

Comment 2

2 years ago
Created attachment 8696224 [details]

Comment 3

2 years ago
Dear Ahmed,

Many thanks for your reply.

The problem is the following: I have multiple Firefox profiles. Once i open one profile and try to quite Firefox normally in order to open another one, the firefox won't quit so i have to use the terminal
(even the 'Force quite button' won't work) - Then, the only way for me to use Firefox is though the

I have attached a screenshot so it may help you understand the situation better.

Basically i have to use the Firefox icon that is on the right and always through the terminal, because the one on the left is not responding (like i said not even 'Force Quit' works)

Many thanks in advance.

Comment 4

2 years ago
I assume this happens because of the profiles, I may be wrong though, lets wait chris, and see what developers say.
QA Whiteboard: [bugday-20151130]
Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit

Comment 5

2 years ago
Hello Ahmed,

Yes, exactly that is the problem, but i really need to fix it since i need to navigate through those different Firefox profiles.

Lets see what the developers say.

Many thanks,


2 years ago
Component: Startup and Profile System → Untriaged
Product: Toolkit → Firefox

Comment 6

2 years ago
why did you undo what I did?  you could either move to more appropriate or do nothing, or mark it invalid if its not a problem to you.
Flags: needinfo?(vseerror)

Comment 7

2 years ago
because I don't believe it belongs in startup and profile.
And I cc someone who may know
Flags: needinfo?(vseerror)
Ahmed: Is this a new issue that appeared with a new Firefox version or do you had this issue always ?
Flags: needinfo?(cproitsis)

Comment 9

2 years ago
Hi Matthias,

The issue appeared 2 weeks after i moved to El Capitan for Mac (version 10.11.1) and only for that version of Firefox (42.0) never for any of my previous ones.

Many thanks,
Flags: needinfo?(cproitsis)

Comment 10

2 years ago
Just an update - Today i downloaded the latest version of El Capitan (10.11.2) but that did not solve the issue.

Once i try to quit one of my Firefox profiles normally the Firefox refused to quite and then i need to use the terminal to navigate through the profiles, having 2 Firefox icons (or just reboot the machine and use the terminal from the beginning which is the healthier options)

Please let me know if you can think of a solution.

I do not have access to my OSX box box until 12/30/15 so I can't test this myself at the moment.

Your problem could be caused by a OSX change or by a new Firefox version or by something else.
The current Firefox 42 got released at 2015-11-03 . 
Do you know if you have the problem already a few weeks ?

How do you launch Firefox with 2 different profiles ?
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
I've updated to El Capitan two days ago and started to have the same issue. The issue is so bad that it prevents my mac to reboot and even force quit won't work. The only way to get rid of the "broken" Firefox it's to power off the computer by holding the power button.
Created attachment 8709000 [details]
Screen Shot 2016-01-18 at 10.40.38 AM.png

This is what happens when Firefox starts after an update.
Created attachment 8709001 [details]

If I close the browser I'm no longer able to open it.
I've just tried with nightly (46) and also with 41, 40 and 30. All with same problems. I've tried to create a new profile and problem still happening. It doesn't seem version neither profile related.

Maybe other metadata related?
I've tried to remove all Firefox versions and related files using App Cleaner but after reinstalling Firefox the bug continues to happen.

More people with same problem: https://discussions.apple.com/thread/7307276?start=0&tstart=0

I also opened bug at Apple with ID 24230488 (looks like it's not public).
I've updated to El Capitan 10.11.3 but the problem persists.

Comment 18

2 years ago
the problem stopped for about 1 month - today i restarted the computer and it came back -  i upgraded to El Capitan 10.11.3 but still persists, same with Sergio's case above.

PLEASE help us - It is EXTREMELY annoying and inconvenient.

Hi guys,

I can't reproduce this issue on my end using the latest Firefox builds. However, after reading the discussions from the Apple support forum, it seams that more people are encountering this behavior and it may be related to an Apple software. 
Maybe someone could investigate it a bit, and see if it's truly a browser issue or indeed a Mac OS related issue. Considering this, I'm marking it as NEW.

Ever confirmed: true
Thanks Paul!

I'll keep my buggy OS X to be able to provide further information. 
I'm available for online debugging sessions if you need so.
New fact:

If close the Firefox using "Apple Menu -> Force Quit... -> Firefox -> Force Quit" the quit just works without problems. 

If I close using cmd+Q the problem happens and the force quit does not help.

In the mean while, every time I close Firefox I have to run the following commands to clean the dock:

sudo killall Dock
sudo killall launchservicesd
Hey guys, we've found more reports of this happening to other people so you're not alone. We got more info in a newer filed bug about this so if you don't mind, we're going to mark this bug as a duplicate. This does not mean the issue is closed. Please follow along using the bug link below.
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1258515
Good! I was about to format my laptop :)
Thanks for the update.
You need to log in before you can comment on or make changes to this bug.