2-4% Linux 64/Win* tp5o_scroll regression on Mozilla-Inbound (v.45) on December 03, 2015 from push 462a51797af1

RESOLVED DUPLICATE of bug 1230448

Status

()

Core
DOM: Animation
RESOLVED DUPLICATE of bug 1230448
3 years ago
3 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

({perf, regression})

Trunk
perf, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 affected)

Details

(Whiteboard: [talos_regression])

(Reporter)

Description

3 years ago
Talos has detected a Firefox performance regression from your commit 462a51797af1901934d422606a6a090cdb96bab0 in bug 1226118.  We need you to address this regression.

This is a list of all known regressions and improvements related to your bug:
http://alertmanager.allizom.org:8080/alerts.html?rev=462a51797af1901934d422606a6a090cdb96bab0&showAll=1

On the page above you can see Talos alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test, please see: https://wiki.mozilla.org/Buildbot/Talos/Tests#tp5o_scroll

Reproducing and debugging the regression:
If you would like to re-run this Talos test on a potential fix, use try with the following syntax:
try: -b o -p linux64,win64,win32 -u none -t g1,g1-e10s  # add "mozharness: --spsProfile" to generate profile data

To run the test locally and do a more in-depth investigation, first set up a local Talos environment:
https://wiki.mozilla.org/Buildbot/Talos/Running#Running_locally_-_Source_Code

Then run the following command from the directory where you set up Talos:
talos --develop -e <path>/firefox -a tp5o_scroll

Making a decision:
As the patch author we need your feedback to help us handle this regression.
*** Please let us know your plans by Monday, or the offending patch will be backed out! ***

Our wiki page outlines the common responses and expectations:
https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
(Reporter)

Comment 2

3 years ago
I have done a lot of retriggers on all the jobs to boost confidence in the regressions. It looks like :birtles is aware of this already (https://bugzilla.mozilla.org/show_bug.cgi?id=1226118#c50) :)

:birtles, can you help us understand what is going on here and don't be shy to ask questions :)  There are a lot of patches, I can bisect them on try if each is atomic.
Flags: needinfo?(bbirtles)
I'm looking into this in bug 1230448.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bbirtles)
Resolution: --- → DUPLICATE
Duplicate of bug: 1230448
You need to log in before you can comment on or make changes to this bug.