Closed Bug 1230645 Opened 4 years ago Closed 4 years ago

Can't play youtube videos on fennec any more, it just spins forever

Categories

(Firefox for Android :: Audio/Video, defect)

45 Branch
All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 47
Tracking Status
firefox45 --- affected
firefox47 --- fixed
fennec 45+ ---

People

(Reporter: kats, Assigned: snorp)

References

Details

Attachments

(2 files)

Attached image Youtube spinners
Nightly on a Nexus 4, Android 4.2.2 with no flashplayer. In about:addons I see the OpenH264 Video Codec from Cisco. When I go to a URL like https://youtu.be/v0u-elClgP0 I get what appears to be the HTML5 video, but it just spins the loading icon forever. There's actually two loading icons, see screenshot.

It used to be that clicking on a youtube link would take me to the youtube app in android, but that doesn't happen any more. I don't remember when this started happening but it's not a very recent regression, I don't think.
fwiw, we've done some work to remove Youtube-specific handling so we can play HTML5 videos in the browser but I can't remember the details.

Workaround: the Android icon in the url bar should still open the Youtube app.
tracking-fennec: --- → ?
Kats, if you go to youtube.com/html5 is the MSE stuff enabled? Can you play H264 videos at http://people.mozilla.org/~atrain/mobile/tests/media.html or other youtube videos?
comment #2
Flags: needinfo?(bugmail.mozilla)
This works for me on a Nexus 4. Can you still reproduce?
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #2)
> Kats, if you go to youtube.com/html5 is the MSE stuff enabled?

The MSE & WebM VP9 box says it's not supported. All the other boxes are supported (HTMLVideoElement, H.264, WebM VP8, Media Source Extensions, and MSE & H.264)

> Can you play
> H264 videos at http://people.mozilla.org/~atrain/mobile/tests/media.html

I can play both the High Profile and Baseline Profile H264 videos on that page.

> or
> other youtube videos?

Got a specific one you want me to try?

(In reply to Mark Finkle (:mfinkle) from comment #4)
> This works for me on a Nexus 4. Can you still reproduce?

Using the youtu.be link in comment 0, yes, I can still reproduce.
Flags: needinfo?(bugmail.mozilla)
The lack of MSE is probably the cause here. Did you turn media.mediasource.enabled (or related sub-prefs) off at some point? Anthony, we should always have MSE on Android 4.1+ unless prefed off, correct?
Flags: needinfo?(bugmail.mozilla)
Flags: needinfo?(ajones)
The only media.mediasource.* pref that's false for me is media.mediasource.webm.enabled, presumably because that's the default value at https://dxr.mozilla.org/mozilla-central/source/modules/libpref/init/all.js#499

I don't remember ever touching these prefs.
Flags: needinfo?(bugmail.mozilla)
And flipping that pref to true does indeed make the video play. \o/
Anthony, what is the timeline for flipping MSE+WebM on Android?
Is this the same as bug 1233429?
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #9)
> Anthony, what is the timeline for flipping MSE+WebM on Android?

You just have to turn it on when you're convinced that a software decoder is good enough, or the alternative is bad enough.
Flags: needinfo?(ajones)
Let's test what happens when we turn this on for users.
Assignee: nobody → snorp
tracking-fennec: ? → 45+
Attachment #8718854 - Flags: review?(ajones) → review+
https://hg.mozilla.org/mozilla-central/rev/4e56796fa59b
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Should we uplift this?
Flags: needinfo?(snorp)
I think we should just let it ride unless we have tons of reports of stuff not working. Most (the vast majority) of YT videos will fall back to H264.
Flags: needinfo?(snorp)
You need to log in before you can comment on or make changes to this bug.