Fennec menu (spawned from device's hardware menu-button) has completely transparent background

VERIFIED FIXED

Status

()

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: dholbert, Assigned: mcomella)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8696007 [details]
screenshot of bug (transparent menu, with Wikipedia & keyboard displayed behind it)

STR:
 1. Start Firefox Nightly on Android.
 2. Open menu. (For me, I'm doing this with my phone's lower-left "soft button", which is its menu button.)

ACTUAL RESULTS: Menu is transparent, so its contents intermix with page content. See attached screenshot.

EXPECTED RESULTS: Menu should not be transparent.

mcomella suspects this is a regression from bug 1229958 (though he didn't see anything like this when working on that bug).
(Reporter)

Comment 1

3 years ago
I'm using a OnePlus One device, with Cyanogenmod 12.1 (which is based on Android 5.1.1).
If I had to guess, I'd say this is probably a Cyanogenmod bug. I removed the panelBackground attribute because it didn't seem to make a difference on my device and since we use custom menus, I thought it was unnecessary and we override it. Perhaps Cyanogenmod uses this attributes, ignoring our @color overrides.

I did bug 1229958 to 1) simplify our styles and 2) reduce APK size (I removed some pngs) so I propose we first try to use a color for panelBackground, and if that fails, backout bug 1229958.
Assignee: nobody → michael.l.comella
(Reporter)

Comment 3

3 years ago
(I can reproduce in "New Guest Session" mode, too, which rules out anything addon/profile-related, I think.)

I'm using Firefox Nightly 2015-12-04 (the latest available right now).
(Reporter)

Comment 4

3 years ago
(In reply to Daniel Holbert [:dholbert] from comment #0)
> STR:
>  1. Start Firefox Nightly on Android.
>  2. Open menu. (For me, I'm doing this with my phone's lower-left "soft
> button", which is its menu button.)

This is actually a hardware button, and this is a *key* piece of the bug.

If I disable my hardware buttons in the Settings app and restart Firefox, it creates its own Menu button (at upper-right) and the menu spawned by *that* does not have this problem.
(Reporter)

Comment 5

3 years ago
To be clear:
 * When my hardware buttons are enabled (as is normally the case), Firefox does not show its own menu icon. Tapping my hardware menu-button will spawn a lower-left menu, which reproduces this bug.
 * When I *disable* my hardware buttons (and restart the browser), Firefox adds a menu icon at its upper-right corner. This menu icon spawns an upper-right menu which does not suffer from this bug.
 * Even if I add a menu button to the row of "soft buttons" that appear when hardware buttons are disabled, Firefox still shows this upper-right menu icon, and that's still where the menu appears from (and doesn't reproduce this bug).

So: tl;dr, this bug only reproduces on devices with a hardware menu button, when that hardware menu-button is used.
(Reporter)

Updated

3 years ago
Summary: Fennec main menu has completely transparent background (so menu entries are intermixed with whatever's displayed - page content, keyboard, etc) → Fennec menu (spawned from hardware button) has completely transparent background
(Reporter)

Updated

3 years ago
Summary: Fennec menu (spawned from hardware button) has completely transparent background → Fennec menu (spawned from device's hardware menu-button) has completely transparent background
Alternative solution – always show overflow menu button (bug 1209967) may fix this as it moves to the menu in the upper-right corner of the screen which (I'm guessing) is more custom than the one we put at the bottom of the screen for hardware buttons.

Comment 7

3 years ago
I can also reproduce this on my Samsung Galaxy S3 Mini (which has a hardware menu button, too) with the default Android 4.1.2.
Also, mozregression confirms bug 1229958 as the cause for this.
(Reporter)

Comment 8

3 years ago
(In reply to Michael Comella (:mcomella) from comment #6)
> Alternative solution – always show overflow menu button
> (bug 1209967) may fix this

I suspect you're right about this, based on my testing in comment 5.
Setting a color to android:panelBackground fixes the issue, but it removes the shadow that is on the menu.

As such, I'm going to backout bug 1229958, which we can revisit after bug 1209967.
Fixed by backout: https://bugzilla.mozilla.org/show_bug.cgi?id=1229958#c6
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

3 years ago
Verified fixed in latest nightly (2015-12-09).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.