bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Small scrolling gestures no longer trigger scrolling

RESOLVED DUPLICATE of bug 1230077

Status

()

Firefox for Android
Toolbar
RESOLVED DUPLICATE of bug 1230077
3 years ago
3 years ago

People

(Reporter: JanH, Unassigned)

Tracking

Trunk
Unspecified
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
This is probably related to bug 1230077 - I've noticed that in the APZ nightlies, small scrolling gestures are no longer recognised as such, instead they get interpreted as a single tap (I've accidentally triggered a few links that way).

Experimenting with apz.touch_start_tolerance has helped, although personally I think that the suggested value of 0.1 might still be a bit too high - currently I've set it to 0.06, which feels like a reasonable approximation of the old behaviour.
Thanks for testing the different values! We'll be talking with the Fennec UX team next Tuesday and I'll suggest 0.06 as the new value to match the old behaviour.
See Also: → bug 1230077
Whiteboard: [pref-tweak]
The current Nightly is using .10, but I tried .06 and like that even better. I would like to see a patch that can log (or telemetry) what the distance is when we process a tap, though, because we really want this value to be as low as we can get away with.
Duplicate of this bug: 1232377
I'm going to dupe this over to bug 1230077 since it's basically the same bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
See Also: bug 1230077
Whiteboard: [pref-tweak]
Duplicate of bug: 1230077
You need to log in before you can comment on or make changes to this bug.