Mute Tab can be overridden by changing the sound output device in Windows

RESOLVED DUPLICATE of bug 1219508

Status

()

Core
Audio/Video: MediaStreamGraph
RESOLVED DUPLICATE of bug 1219508
2 years ago
2 years ago

People

(Reporter: nocomment84, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

Play any sound in a tab (only with HTML5 player, e.g. on Youtube, it seems Flash is not affected), mute the tab (mute icon appears in tab) and change the audio output device in Windows.


Actual results:

The audio of the muted can be heard again with the new device but the mute icon is still visible. If tab is reloaded or another video is started (e.g. on Facebook), the mute state is applied correctly.


Expected results:

The tab should still be muted after the device switch.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → Audio/Video: MediaStreamGraph
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1219508
You need to log in before you can comment on or make changes to this bug.