Option to share a page with other Firefoxes (shareplane) disappeared

NEW
Unassigned

Status

()

Firefox for Android
General
3 years ago
3 years ago

People

(Reporter: krzysztof.krason, Unassigned)

Tracking

(Depends on: 1 bug)

45 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox45 affected)

Details

(Whiteboard: [bugday-20151207])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151204004006

Steps to reproduce:

Go to a page with links, and long press a link, click "Send link".


Actual results:

There is no option to send tha link to other Firefoxes that exist in Sync.


Expected results:

There should be an option to send the link to othe Firefoxes that I have in Sync.
(Reporter)

Comment 1

3 years ago
This happens for both Nightly 45 and for Aurora 44, and the option disappeared in one of the 44 Aurora releases.
Also there is no option to share the current page with Firefox Sync.
(Reporter)

Updated

3 years ago
OS: Unspecified → Android
Hardware: Unspecified → ARM
(Reporter)

Comment 2

3 years ago
Not sure if it is related, but I'm on Moto X (XT1092), Android 5.1, Firefox Nightly updated today.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Whiteboard: [bugday-20151207]
Duplicate of bug: 1140048
Status: RESOLVED → REOPENED
Depends on: 1217174
Ever confirmed: true
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
You need to be signed into your Mozilla account in order to see that option.  If you're signed into your Mozilla account, you should be able to long press and then share link -> send to other devices.  Try restarting the app after logging in if it doesn't work right away.
Status: NEW → RESOLVED
Last Resolved: 3 years ago3 years ago
No longer depends on: 1217174
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

3 years ago
I am signed int to the application (sync is working), but I still don't see the option to share the page. Over the last few weeks when it stopped working I did application and phone restarts, nothing helped.
What version of Android are you using?  And could you attach a screenshot of the share list and your sync settings page?
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: WORKSFORME → ---
Yeah, I see the issue now.  We'll wait for bug 1217174 to land before we fix this.  Thanks!  :)
Status: UNCONFIRMED → NEW
Depends on: 1217174
Ever confirmed: true
status-firefox45: --- → affected
I don't see this issue on the latest nightly. However, the option will hide itself if you have no devices to share to and devices will remove themselves if you have not synced with them after about three weeks (see bug 1219755 for more).

Have you recently used the devices you are trying to share to? What if you force a sync on both devices? (Settings -> Firefox account settings -> sync account on mobile devices) You'll likely need to sync the device you're trying to share to, then the device you're trying to share from.

CC margaret because it annoys me that we have this problem and I want more visibility.
(Reporter)

Comment 9

3 years ago
I didn't change anything in my devices besides installing new aurora versions from time to time and suddenly the option disappeared. But sync is working (e.g. I can see what tabs are opened on the desktop firefox).
Then after some time I decided to try out the nightly and the problem is the same - no option to send a page to desktop.

I tried what you suggested, synced first on desktop and then on mobile, but there is still no option to send the page to other devices in sync (which maybe is important, I have 4 firefoxes in sync, two desktop ones and two mobile).
I recently had my home laptop disappear from the share list even though I used it fairly regularly. Yesterday, several tabs, which I had sent weeks ago, appeared on my laptop and now it appears in the share list again. Perhaps this is related to the hiccup from bug 1232162 comment 4.

Richard, any ideas on where to go next or is this a dupe to bug 1219755 or bug 1168690?
Flags: needinfo?(rnewman)
The only behavior that's consistent with that observation is that your local device _queued_ the tabs to send while your desktop's record wasn't present. Eventually your desktop uploaded its record again, and the locally queued tabs were finally sent.

Your desktop's sync logs will tell a story. If you had logOnSuccess flipped, it'll tell the whole story. If you didn't, I'd still like to see your last four weeks of error logs.
Flags: needinfo?(rnewman)
To reframe Comment 10: there are two possibilities:

* The Android client wasn't able to download the desktop client record for long enough that the client expired from our list.
* The desktop wasn't able to upload its client record for a while, long enough for the same to happen.

My bet is on the latter.
You need to log in before you can comment on or make changes to this bug.