Closed Bug 1230780 Opened 7 years ago Closed 7 years ago

ThreeJS css3d cube demo no longer works

Categories

(Core :: Graphics, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla46
Tracking Status
firefox43 --- unaffected
firefox44 --- unaffected
firefox45 + unaffected
firefox46 + verified

People

(Reporter: RyanVM, Assigned: mattwoodrow)

References

()

Details

(Keywords: regression, Whiteboard: [gfx-noted])

Attachments

(2 files, 1 obsolete file)

All you get now is a grey viewport and no cube. mozregression says this was caused by bug 1168263.
Flags: needinfo?(matt.woodrow)
Blocks: 1224433
The regression range is in 45, so if we get the fix, let's make sure we fix it there as well.
Whiteboard: [gfx-noted]
Duplicate of this bug: 1231242
Attached patch ReftestSplinter Review
This happens when the perspective isn't being applied to the root of the preserve-3d chain. It's a bit weird that the spec allows this, but it does, and apparently websites are relying on it.

This adds a reftest that reproduces the issue.
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
Attachment #8699304 - Flags: review?(tlee)
Comment on attachment 8699305 [details] [diff] [review]
Propagate preserve-3d handling through nsDisplayPerspective

Hi Mat, bug 1226904 has changed something.  Could you rebase to it?
Attachment #8699305 - Flags: review?(tlee)
Duplicate of this bug: 1230072
Attachment #8699304 - Flags: review?(tlee) → review+
Blocks: 1222990
Depends on: 1226904
Regression, tracking.
Attachment #8699305 - Attachment is obsolete: true
Attachment #8706188 - Flags: review?(tlee)
Attachment #8706188 - Flags: review?(tlee) → review+
https://hg.mozilla.org/mozilla-central/rev/c63771a9d4d2
https://hg.mozilla.org/mozilla-central/rev/00afe8c23782
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
Working great again, thanks! Please nominate this for Aurora uplift whenever you're comfortable doing so.
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
This patch is needed to fix bug 1222990 which is now a wontfix for Fx44 but if nominated for uplift (also mentioned by RyanVM in the previous comment) to Aurora, we can fix it in Fx45.
Flags: needinfo?(tlee)
I agree! This patch is worth to be uplifted.
Flags: needinfo?(tlee)
(In reply to Thinker Li [:sinker] from comment #13)
> I agree! This patch is worth to be uplifted.

Thanks! Can you nominate for uplift to Aurora in that case?
Flags: needinfo?(tlee)
Comment on attachment 8706188 [details] [diff] [review]
Propagate preserve-3d handling through nsDisplayPerspective

Approval Request Comment
[Feature/regressing bug #]: Bug 1168263.
[User impact if declined]: Missing content on some 3d demos
[Describe test coverage new/current, TreeHerder]: Tested manually, verified, reftest added.
[Risks and why]: Low risk.
[String/UUID change made/needed]: None
Attachment #8706188 - Flags: approval-mozilla-aurora?
Flags: needinfo?(tlee)
Duplicate of this bug: 1237952
The change that caused this regression was backed out from Firefox 45.

https://hg.mozilla.org/releases/mozilla-aurora/rev/64ec448f156d
Attachment #8706188 - Flags: approval-mozilla-aurora?
Depends on: 1242158
Depends on: 1245450
You need to log in before you can comment on or make changes to this bug.