HTML5 video on YouTube and Facebook is unplayable, with high CPU usage and black rectangles

RESOLVED INVALID

Status

()

defect
P2
major
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: condacum, Unassigned)

Tracking

42 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

http://postimg.org/image/462er03xr/

2014:
H264 was blue

2015: red.
Can you RE-enable H264 for Firefox?
since the GPU is capable up to 4K 30p 100Mbps via dxva2 native or copyback.
(Reporter)

Updated

3 years ago
Severity: normal → major
OS: Unspecified → Windows Vista
Hardware: Unspecified → x86

Comment 1

3 years ago
Do you have the Platform Update Supplement installed? Without it, H.264 playback on Vista requires Firefox 45 (32-bit) and Adobe's CDM: bug 1210231.
https://support.microsoft.com/en-us/kb/2117917

If it's installed, can you reproduce the issue in a brand new profile?
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles

If yes, in the brand new profile can you play the MP4 video below?
http://www.quirksmode.org/html5/tests/video.html

Note that 4K videos aren't going to work on Vista regardless.
Bug 1154536
Component: Untriaged → Audio/Video: Playback
Flags: needinfo?(condacum)
Product: Firefox → Core
(Reporter)

Comment 2

3 years ago
1.
Yes, I have it installed. 
http://postimg.org/image/5vbollfnp/
http://postimg.org/image/74ur4vn41/

until 2014 all was ok. FF introduced changes in this behaviour during 2015, I guess. 
2014: icon blue and zero issues; 2015: icon red and unable to watch via html5.
(For youtube I fully resolved the issue installing an addon that forces flash player with acceleration on, but on facebook no).

2. Yes, in a new clean profile too.

Not only 4K, I have issue even at 480p with html5.
All is very fine with flash player (!).

3. yes. 24% FF CPU in full screen mode.

for 4K videos, due to the line speed limits, I download them and watch them in MPC-HC.
but this video https://www.youtube.com/watch?v=mmCp7VJnSAk
runs well, see please here the CPU required by FF process at 4K in full screen mode (via Flash player obviously!):
http://postimg.org/image/9ock6hhal/full/
interesting.

I cannot watch any FB videos since flash player is "banned" starting a few months ago.
Its strange.
Flags: needinfo?(condacum)
(Reporter)

Comment 3

3 years ago
3.
but your video mp4 becomes unplayable now...
i.e. when:
https://bugzilla.mozilla.org/show_bug.cgi?id=1222272

Comment 4

3 years ago
Bug 1222272, comment 7 shows that your graphics driver is outdated. Please update it.
http://www.geforce.com/drivers

Considering the aforementioned bug report, it would also be a good idea to check for bad RAM:
http://www.pcworld.com/article/2048282/how-to-find-out-if-your-ram-is-defective.html

(In reply to Yorgos from comment #2)
> 3. yes. 24% FF CPU in full screen mode.
(In reply to Yorgos from comment #3)
> 3.
> but your video mp4 becomes unplayable now...

Does that mean you were able to play the video at first, but not a second time? Or does that mean the video only plays when opened directly (like the link below), not from the containing web page?
http://www.quirksmode.org/html5/videos/big_buck_bunny.mp4

The way things are shaping up, it looks like both issues in this report and bug 1222272 have the same root cause (faulty hardware, faulty drivers, or a Firefox regression).
See Also: → 1222272
(Reporter)

Comment 5

3 years ago
347.88 are the latest stable, released februar 2015: zero issues with those "old" driver.

(newer driver  = nvddl.sys stoppend working and has been restored, on geforce forum there are a lot of compliants since 6 months from GT400 until GTX980Ti, from Vista until w10).

>> Does that mean you were able to play the video at first, but not a second time?
yes, I was able. But after 1 hour I was unable, I had to restart FF, otherwise I watchefd a grey window instead of the video.


hmmmm very strange: faulty hardware, flaulty driver...only woth firefox?
I am able to watch for hours 4K videos 30p 100Mbps (but NOT 120Mbps = stuttering) without any problem, I am wondering if FF 2015 requires a very powerfull workstation to work. 
Why in past I never noticed this behaviour?

Firefox regression: maybe: Therefore is Mozilla at fault for this issue? or the minimum system requirements is Seven?
(Reporter)

Comment 6

3 years ago
in other words, did Mozilla give up supporting hw acceleration for Vista?
(Reporter)

Comment 7

3 years ago
in other words, why with flash player (1080p, full screen, for hours...) my hw/driver is not faulty? 
were the memory report json.rar attachments (bug 1222272) useful?
(Reporter)

Comment 8

3 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=1222272#c37

(without any knowledge in advance, I was right in choosing that title for this thread)  ;)

since you (Mozilla) done that, "at least" please tell me a workaround so that I could to playback FB videos via Flash Player, as I am already doing with YT.
Thanks a lot.
(Reporter)

Comment 9

3 years ago
here the explanation:
https://bugzilla.mozilla.org/show_bug.cgi?id=1222272#c37
(In reply to Yorgos from comment #2)
> 2. Yes, in a new clean profile too.
> 
> Not only 4K, I have issue even at 480p with html5.

@ Jean-Yves: is there any reason why YouTube support for WebM VP8 would be disabled in a clean Firefox profile on Windows Vista? Or why YouTube support for H.264 would be disabled (red icon) but "MSE & H.264" would appear supported (blue icon)? These are both surprising results.

A screenshot of the bug reporter's youtube.com/html5 settings (from comment 0):

http://postimg.org/image/462er03xr/

@ Yorgos: do you still see these problem if you change the about:config pref "media.hardware-video-decoding.enabled" to false (and restart Firefox)?
Flags: needinfo?(jyavenard)
(In reply to Chris Peterson [:cpeterson] from comment #10)
> (In reply to Yorgos from comment #2)
> > 2. Yes, in a new clean profile too.
> > 
> > Not only 4K, I have issue even at 480p with html5.
> 
> @ Jean-Yves: is there any reason why YouTube support for WebM VP8 would be
> disabled in a clean Firefox profile on Windows Vista? Or why YouTube support
> for H.264 would be disabled (red icon) but "MSE & H.264" would appear
> supported (blue icon)? These are both surprising results.

can't be explained other than a plugin has been installed or the prefs were changed.

VP8/WEBM is always enabled.

I can't see how MSE/H264 is enabled but mpa4/h264 isn't.

I couldn't do that without playing with the code.
Flags: needinfo?(jyavenard)
(Reporter)

Comment 12

3 years ago
Hi, thanks for your reply.

Yes I still see
http://postimg.org/image/462er03xr/
after changing "media.hardware-video-decoding.enabled" to false (and restart Firefox).

In the past I always saw H264 icon blue on FF.
I dont remember the FF version number, but I can say for sure that this problem (i.e. H264 icon "red" and therefore issues in playback FB videos that requires, since a few months, the internal html5 player) arised exactly after a new FF update added in my about:support > Graphics this new string: "Hardware support for decoding H264" (curiously set to "false"); now (today) I have FF43 and it says "No; Unsupported layers backend").
(Reporter)

Comment 13

3 years ago
Now I am again in my "old" profile, and I see these plugins:
http://postimg.org/image/jnb94rqwz/
Something very strange is going on. I have no idea why WebM VP8 would be disabled in a clean browser profile. And Jean-Yves says there is no way the "MSE & H.264" box should be enabled when the "H.264" box is disabled, even by tweaking about:config prefs.
(Reporter)

Comment 15

3 years ago
For example this kind of video is terrible for me, because it is unpossible to force it to run via flash player:
https://www.facebook.com/teatrodisancarlo/videos/vb.269288422341/10153800585207342/?type=2&theater&notif_t=like

a very big hang, but not crash:
http://postimg.org/image/7rl0xovtt/
(Reporter)

Comment 16

3 years ago
If this could help:
http://postimg.org/image/4ubo5r4ix/
(Reporter)

Comment 17

3 years ago
This tipic confirms and clarify
http://forum.mozillaitalia.org/index.php?topic=65635.0

the same GPU, but with Seven OK: h264 enabled, with Vista disabled.
If this is a wanted behaviuour it were interesting to understand the purpose of this choice for FF on Vista.
(Reporter)

Comment 18

3 years ago
I was sure that this problem arised this year (all was fine in 2014!) for Vista *only* ; 

instead....as you can see here 
http://forum.mozillaitalia.org/index.php?topic=65664.msg453156#msg453156

(user "6iulia", post#40, the second photo!) the same problem is now affecting Seven too! with a new profile (see the their third post with "Done!").


Therefore the user is complaining about FB videos, like me, 
http://forum.mozillaitalia.org/index.php?topic=65664.msg453158#msg453158
and therefore today she switched to the addon that forces flash for youtube (only), like me; the future moderator "Ronnie91" written: "I dread you have issues with html5").

A very very interesting thread, because the OS is Seven, not my Vista!
(sche tried UNchecking "Use hw aceleration if available" in FF).

(Other than the OS, the difference are: 
I have CIS Comodo, not Avast as the user has; 
from the last photo, it seems that this user with Seven has a pc from the brand HP, like me!).
Yorgos, can you please post your browser's about:support information? Here are instructions:

https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox
(Reporter)

Comment 20

3 years ago
Hi Chris, thanks for you reply.

(NB: I changed layers.offmainthreadcomposition.enabled to *false* just for testing, to see if this help, but it doesnt help, I will switch it to True again.)

Here the requested infos:

[code]
Informazioni di base
--------------------

Nome: Firefox
Versione: 43.0.1
ID build: 20151216175450
Canale di aggiornamento: release
User agent: Mozilla/5.0 (Windows NT 6.0; rv:43.0) Gecko/20100101 Firefox/43.0
Finestre multiprocesso: 0/1 (predefinito: false)
Modalità provvisoria: false

Segnalazioni di arresto anomalo degli ultimi 3 giorni
-----------------------------------------------------

Tutte le segnalazioni

Estensioni
----------

Nome: Adblock Plus
Versione: 2.7
Attiva: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Nome: NoScript
Versione: 2.7
Attiva: true
ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Nome: WOT
Versione: 20151208
Attiva: true
ID: {a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}

Nome: YouTube Flash Video Player
Versione: 43.9.1
Attiva: true
ID: {f3bd3dd2-2888-44c5-91a2-2caeb33fb898}

Grafica
-------

Data aggiornamento driver: 3-13-2015
Descrizione scheda grafica: NVIDIA GeForce GTX 650
Direct2D attivo: true
DirectWrite attivo: true (7.0.6002.23845)
Driver scheda grafica: nvd3dum,nvwgf2um,nvwgf2um
Finestre con accelerazione GPU: 0/1 Basic
GPU #2 attiva: false
ID dispositivo: 0x0fc6
ID produttore: 0x10de
ID sottosistema: 00000000
Panoramica/zoom asincroni (APZ): nessuno
RAM scheda grafica: 2048
Rendering WebGL: Google Inc. -- ANGLE (NVIDIA GeForce GTX 650 Direct3D9Ex vs_3_0 ps_3_0)
Supporto hardware per decodifica H264: No; Unsupported layers backend
Versione driver: 9.18.13.4788
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Preferenze importanti modificate
--------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 1
browser.display.focus_ring_on_anything: true
browser.download.folderList: 0
browser.download.importedFromSqlite: true
browser.download.manager.alertOnEXEOpen: true
browser.download.manager.closeWhenDone: true
browser.download.manager.quitBehavior: 2
browser.download.manager.retention: 0
browser.download.manager.scanWhenDone: false
browser.history_expire_days.mirror: 180
browser.link.open_newwindow: 2
browser.places.importBookmarksHTML: false
browser.places.importDefaults: false
browser.places.leftPaneFolderId: -1
browser.places.migratePostDataAnnotations: false
browser.places.smartBookmarksVersion: 7
browser.places.updateRecentTagsUri: false
browser.search.suggest.enabled: false
browser.search.update: false
browser.sessionstore.max_tabs_undo: 45
browser.sessionstore.restore_on_demand: false
browser.sessionstore.upgradeBackup.latestBuildID: 20151216175450
browser.startup.homepage: https://startpage.com/
browser.startup.homepage_override.buildID: 20151216175450
browser.startup.homepage_override.mstone: 43.0.1
browser.tabs.drawInTitlebar: false
browser.tabs.onTop: false
browser.urlbar.formatting.enabled: false
browser.urlbar.trimURLs: false
dom.apps.reset-permissions: true
dom.disable_window_move_resize: true
dom.event.clipboardevents.enabled: false
dom.ipc.plugins.timeoutSecs: -1
dom.mozApps.used: true
dom.w3c_touch_events.expose: false
extensions.lastAppVersion: 43.0.1
font.internaluseonly.changed: true
gfx.crash-guard.d3d11layers.appVersion: 43.0.1
gfx.crash-guard.d3d11layers.deviceID: 0x0fc6
gfx.crash-guard.d3d11layers.driverVersion: 9.18.13.4788
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.glcontext.gfx.driver-init.direct3d11-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-d3d11: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-warp: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-try-d3d11: true
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.glcontext: 2
gfx.direct3d.checkDX10: true
gfx.direct3d.last_used_feature_level_idx: 0
gfx.direct3d.prefer_10_1: true
gfx.driver-init.appVersion: 42.0
gfx.driver-init.deviceID: 0x0fc6
gfx.driver-init.driverVersion: 9.18.13.4788
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
layers.offmainthreadcomposition.enabled: false
media.gmp-eme-adobe.abi: x86-msvc
media.gmp-eme-adobe.enabled: false
media.gmp-eme-adobe.lastUpdate: 1446575607
media.gmp-eme-adobe.version: 15
media.gmp-gmpopenh264.abi: x86-msvc
media.gmp-gmpopenh264.lastUpdate: 1447879722
media.gmp-gmpopenh264.version: 1.5.1
media.gmp-manager.buildID: 20151216175450
media.gmp-manager.lastCheck: 1450696258
media.hardware-video-decoding.failed: false
network.cookie.cookieBehavior: 1
network.cookie.lifetimePolicy: 2
network.cookie.prefsMigrated: true
network.dns.disableIPv6: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1450207245
places.history.expiration.transient_current_max_pages: 80489
places.history.expiration.transient_optimal_database_size: 139518934
places.last_vacuum: 1316434065
plugin.disable_full_page_plugin_for_types: audio/mpeg,audio/x-mpeg,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,
plugin.importedState: true
plugin.state.java: 0
plugin.state.np-mswmp: 2
plugin.state.npctrl: 2
plugins.click_to_play: false
print.print_printer: HP Color LaserJet 2840 series PCL 6
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_bgcolor: false
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_bgimages: false
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_command:
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_downloadfonts: false
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_edge_bottom: 0
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_edge_left: 0
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_edge_right: 0
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_edge_top: 0
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_evenpages: true
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_footercenter:
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_footerleft: &PT
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_footerright: &D
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_headercenter:
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_headerleft: &T
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_headerright: &U
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_in_color: true
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_margin_bottom: 0.5
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_margin_left: 0.5
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_margin_right: 0.5
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_margin_top: 0.5
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_oddpages: true
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_orientation: 0
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_pagedelay: 500
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_paper_data: 9
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_paper_height: 11,00
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_paper_size_type: 0
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_paper_size_unit: 1
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_paper_width: 8,50
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_reversed: false
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_scaling: 1,00
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_shrink_to_fit: true
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_to_file: false
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_unwriteable_margin_bottom: 0
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_unwriteable_margin_left: 0
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_unwriteable_margin_right: 0
print.printer_HP_Color_LaserJet_2840_series_PCL_6.print_unwriteable_margin_top: 0
print.printer_HP_Officejet_J6400_series.print_bgcolor: false
print.printer_HP_Officejet_J6400_series.print_bgimages: false
print.printer_HP_Officejet_J6400_series.print_colorspace:
print.printer_HP_Officejet_J6400_series.print_command:
print.printer_HP_Officejet_J6400_series.print_downloadfonts: false
print.printer_HP_Officejet_J6400_series.print_duplex: 0
print.printer_HP_Officejet_J6400_series.print_edge_bottom: 0
print.printer_HP_Officejet_J6400_series.print_edge_left: 0
print.printer_HP_Officejet_J6400_series.print_edge_right: 0
print.printer_HP_Officejet_J6400_series.print_edge_top: 0
print.printer_HP_Officejet_J6400_series.print_evenpages: true
print.printer_HP_Officejet_J6400_series.print_footercenter:
print.printer_HP_Officejet_J6400_series.print_footerleft: &PT
print.printer_HP_Officejet_J6400_series.print_footerright: &D
print.printer_HP_Officejet_J6400_series.print_headercenter:
print.printer_HP_Officejet_J6400_series.print_headerleft: &T
print.printer_HP_Officejet_J6400_series.print_headerright: &U
print.printer_HP_Officejet_J6400_series.print_in_color: true
print.printer_HP_Officejet_J6400_series.print_margin_bottom: 0.5
print.printer_HP_Officejet_J6400_series.print_margin_left: 0.5
print.printer_HP_Officejet_J6400_series.print_margin_right: 0.5
print.printer_HP_Officejet_J6400_series.print_margin_top: 0.5
print.printer_HP_Officejet_J6400_series.print_oddpages: true
print.printer_HP_Officejet_J6400_series.print_orientation: 0
print.printer_HP_Officejet_J6400_series.print_page_delay: 50
print.printer_HP_Officejet_J6400_series.print_pagedelay: 500
print.printer_HP_Officejet_J6400_series.print_paper_data: 9
print.printer_HP_Officejet_J6400_series.print_paper_height: 11,00
print.printer_HP_Officejet_J6400_series.print_paper_name:
print.printer_HP_Officejet_J6400_series.print_paper_size_type: 0
print.printer_HP_Officejet_J6400_series.print_paper_size_unit: 1
print.printer_HP_Officejet_J6400_series.print_paper_width: 8,50
print.printer_HP_Officejet_J6400_series.print_plex_name:
print.printer_HP_Officejet_J6400_series.print_resolution: 0
print.printer_HP_Officejet_J6400_series.print_resolution_name:
print.printer_HP_Officejet_J6400_series.print_reversed: false
print.printer_HP_Officejet_J6400_series.print_scaling: 1,00
print.printer_HP_Officejet_J6400_series.print_shrink_to_fit: true
print.printer_HP_Officejet_J6400_series.print_to_file: false
print.printer_HP_Officejet_J6400_series.print_unwriteable_margin_bottom: 0
print.printer_HP_Officejet_J6400_series.print_unwriteable_margin_left: 0
print.printer_HP_Officejet_J6400_series.print_unwriteable_margin_right: 0
print.printer_HP_Officejet_J6400_series.print_unwriteable_margin_top: 0
privacy.clearOnShutdown.downloads: false
privacy.clearOnShutdown.formdata: false
privacy.clearOnShutdown.history: false
privacy.clearOnShutdown.sessions: false
privacy.cpd.downloads: false
privacy.cpd.formdata: false
privacy.cpd.history: false
privacy.cpd.sessions: false
privacy.donottrackheader.enabled: true
privacy.item.cookies: true
privacy.item.formdata: false
privacy.item.history: false
privacy.item.sessions: false
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.promptOnSanitize: false
privacy.sanitize.sanitizeOnShutdown: true
security.disable_button.openCertManager: false
security.warn_entering_secure: true
security.warn_leaving_secure: true
security.warn_viewing_mixed: false
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1450552839

Preferenze importanti bloccate
------------------------------

JavaScript
----------

GC incrementale: true

Accessibilità
-------------

Attivato: false
Impedisci accessibilità: 0

Versioni librerie
-----------------

NSPR
Versione minima prevista: 4.10.10
Versione in uso: 4.10.10

NSS
Versione minima prevista: 3.20.1 Basic ECC
Versione in uso: 3.20.1 Basic ECC

NSSSMIME
Versione minima prevista: 3.20.1 Basic ECC
Versione in uso: 3.20.1 Basic ECC

NSSSSL
Versione minima prevista: 3.20.1 Basic ECC
Versione in uso: 3.20.1 Basic ECC

NSSUTIL
Versione minima prevista: 3.20.1
Versione in uso: 3.20.1

Caratteristiche sperimentali
----------------------------
[\code]
What happens if you disabled the "YouTube Flash Video Player" add-on?

> Supporto hardware per decodifica H264: No; Unsupported layers backend

This is interesting. Do you see the "Unsupported layers backend" message in about:support when running Firefox 42?

The "layers.offmainthreadcomposition.enabled" pref should definitely be "true" on Windows.
(Reporter)

Comment 22

3 years ago
Hi, 

1) 
if I disable the addon, then all YT videos have to run via html5 (default), and therefore I become exactly the same behaviour as they were FB videos: 
i.e. no acceleration active, and *therefore* high CPU and ram usage, stuttering, jumpiness in video, unwanted "slow motion" effect, a lot of frames dropped, 4 seconds for switching to full screen mode and return...some parts of FF interface become black
http://postimg.org/image/x5zlwubdb/
http://postimg.org/image/9ga685czz/
when this issue arises, photos cannot be loaded 
http://postimg.org/image/l04znav57/
(I have to restart FF, then ok!),
....in other words without the addon my FF is fully destroyed: hang, another hang, then permanent hang, but always ZERO crashes. 
Summary: if I watch youtube without the addon (i.e. youtube via html5 default), I simply cannot use FF because this issue let arise all the other effects (my screenshots above). Instead if I use a lot a lot of youtube videos via flash 1080p or above (and I do NOT use FB videos!), then all is good here.

Another example of FB video (a simply 360p or 480p):
http://postimg.org/image/kp5s0p5zx/
when I have this issue, then in the "Graphics" I see other unusual strings like:

> (#413) Assert	Attempt to create DrawTarget for invalid surface. Size(1090,1134) Cairo Status: 1 <

I said "acceleration" because all is fine with YT (forced via flash player, thanks the above mentioned addon: seldom, when and if the line is ok, I can 4K too like http://postimg.org/image/9ock6hhal/full/ without issues), and the same good behaviour with Silverlight H264 via GPU.

I guess that the problem is html5 (its "compulsory" usage in FB) and the H264 icon red.

If a solution is hard to find (i.e. the H264 icon *again* blue coloured, as in the past), a "workaround" were ok for me: an addon that forces FB videos via flash too, as in the past months (because in the past FB on FF worked with flash by default).

2)
I see
"Unsupported layers backend"
in FF43 only;

while in FF42 I see a simply word: "False".

(In a Nightly - I dont remember the number - I saw and saved a more detailed report: 
"Supports Hardware H264 Decoding No; MFT_MESSAGE_SET_D3D_MANAGER failed with code C00D6D60" )

I was sure an issue with newer FF builds (starting from FF39? I dont remember) on Vista, therefore I am so much wondering today and so much surprising in finding, by a coincidence, the other user (forum mozilla linked above) with "H264 red" on Seven too.

3) ok, now I restored it on True.
(In reply to Yorgos from comment #22)
> I see
> "Unsupported layers backend"
> in FF43 only;
> 
> while in FF42 I see a simply word: "False".
> 
> (In a Nightly - I dont remember the number - I saw and saved a more detailed
> report: 
> "Supports Hardware H264 Decoding No; MFT_MESSAGE_SET_D3D_MANAGER failed with
> code C00D6D60" )

@ Mason, do you know why the "Supports Hardware H264 Decoding" test would hit error code 0xC00D6D60 (MF_E_TRANSFORM_TYPE_NOT_SET)? MSDN says MF_E_TRANSFORM_TYPE_NOT_SET means: "A valid type has not been set for this stream or a stream that it depends on."


> if I disable the addon, then all YT videos have to run via html5 (default),
> and therefore I become exactly the same behaviour as they were FB videos: 
> i.e. no acceleration active, and *therefore* high CPU and ram usage,
> stuttering, jumpiness in video, unwanted "slow motion" effect, a lot of
> frames dropped, 4 seconds for switching to full screen mode and
> return...some parts of FF interface become black
> http://postimg.org/image/x5zlwubdb/
> http://postimg.org/image/9ga685czz/
> when this issue arises, photos cannot be loaded 
> http://postimg.org/image/l04znav57/
> ....in other words without the addon my FF is fully destroyed: hang, another
> hang, then permanent hang, but always ZERO crashes. 

@ Mason, do you know what might cause these graphics problems when playing HTML5 video?


> If a solution is hard to find (i.e. the H264 icon *again* blue coloured, as
> in the past), a "workaround" were ok for me: an addon that forces FB videos
> via flash too, as in the past months (because in the past FB on FF worked
> with flash by default).

I think Facebook has moved from Flash to all HTML5 video:

https://code.facebook.com/posts/159906447698921
Flags: needinfo?(mchang)
Summary: Request: Re-enable H264 → HTML5 video on YouTube and Facebook is unplayable, with high CPU usage and black rectangles
(Reporter)

Comment 24

3 years ago
[OT ? :
layers.offmainthreadcomposition.enabled to True:
when I move FF window bottom "reduce it to icon"
http://postimg.org/image/vidgpjmjd/
during this moving process I see that it happens in 2 steps, not a lag, but I see Firefox' movement, as I would have recorded my desktop with VLC. All is smooth by setting the key to False. You know, if all is smooth on your destop but you record it with VLC, then watching the recorded video you see that the window opens and closes with a little jump: at a first time you see the window (firefox or anything you want) fading out just a bit, and only after this fade out the window reaches the bottom of the desktop. With False = no fade out effect. No idea if this may be related with this thread.  /OT ? ]
(Reporter)

Comment 25

3 years ago
I add another example:
https://www.facebook.com/events/1654183461511909/

with all my tabs opened at this point I had 700MB ram FF; 
I clicked on this video Zorba http://postimg.org/image/vb5ti5sch/
the video started; after 0.5 seconds the ram arised up to 1200MB, then hang; I closed the tab, after 10 seconds hang, the tab cloased, while the audio still continued running, then after 5 seconds, the ram decreased and ok.
(Reporter)

Comment 27

3 years ago
layers.offmainthreadcomposition.enabled
again to False.
(Reporter)

Comment 28

3 years ago
https://www.facebook.com/video.php?v=1074130749284241&theater

this unplayable video requires 460MB ram FF.
its normal?
(Reporter)

Comment 29

3 years ago
(In reply to Gingerbread Man from comment #1)
> Do you have the Platform Update Supplement installed? 

I just find this:
If Platform Update Supplement for Windows Vista is installed, the H.264 video decoder is available on Windows Vista, but is accessible on Windows Vista only by using the https://msdn.microsoft.com/en-us/library/windows/desktop/dd940436%28v=vs.85%29.aspx
(In reply to Chris Peterson [:cpeterson] from comment #23)
> (In reply to Yorgos from comment #22)
> > I see
> > "Unsupported layers backend"
> > in FF43 only;
> > 
> > while in FF42 I see a simply word: "False".
> > 
> > (In a Nightly - I dont remember the number - I saw and saved a more detailed
> > report: 
> > "Supports Hardware H264 Decoding No; MFT_MESSAGE_SET_D3D_MANAGER failed with
> > code C00D6D60" )
> 
> @ Mason, do you know why the "Supports Hardware H264 Decoding" test would
> hit error code 0xC00D6D60 (MF_E_TRANSFORM_TYPE_NOT_SET)? MSDN says
> MF_E_TRANSFORM_TYPE_NOT_SET means: "A valid type has not been set for this
> stream or a stream that it depends on."

Redirecting to Matt.

> 
> 
> > if I disable the addon, then all YT videos have to run via html5 (default),
> > and therefore I become exactly the same behaviour as they were FB videos: 
> > i.e. no acceleration active, and *therefore* high CPU and ram usage,
> > stuttering, jumpiness in video, unwanted "slow motion" effect, a lot of
> > frames dropped, 4 seconds for switching to full screen mode and
> > return...some parts of FF interface become black
> > http://postimg.org/image/x5zlwubdb/
> > http://postimg.org/image/9ga685czz/
> > when this issue arises, photos cannot be loaded 
> > http://postimg.org/image/l04znav57/
> > ....in other words without the addon my FF is fully destroyed: hang, another
> > hang, then permanent hang, but always ZERO crashes. 
> 
> @ Mason, do you know what might cause these graphics problems when playing
> HTML5 video?

If he has hardware acceleration disabled and has to use basic layers, everything is happening on the CPU. I'm not surprised we're using all the CPU and barely keeping up :(.
Flags: needinfo?(mchang) → needinfo?(matt.woodrow)
Priority: -- → P2
There seem to be multiple issues in this bug and it's very hard to follow them.

* YouTube reports MSE/H264 not supported
* Accelerated layers disabled (which also disables hardware video decoding)
* "Supports Hardware H264 Decoding" error message
* Asserts in the Graphics log

(In reply to Mason Chang [:mchang] from comment #30)
> (In reply to Chris Peterson [:cpeterson] from comment #23)
> > (In reply to Yorgos from comment #22)
> > > I see
> > > "Unsupported layers backend"
> > > in FF43 only;
> > > 
> > > while in FF42 I see a simply word: "False".
> > > 
> > > (In a Nightly - I dont remember the number - I saw and saved a more detailed
> > > report: 
> > > "Supports Hardware H264 Decoding No; MFT_MESSAGE_SET_D3D_MANAGER failed with
> > > code C00D6D60" )
> > 
> > @ Mason, do you know why the "Supports Hardware H264 Decoding" test would
> > hit error code 0xC00D6D60 (MF_E_TRANSFORM_TYPE_NOT_SET)? MSDN says
> > MF_E_TRANSFORM_TYPE_NOT_SET means: "A valid type has not been set for this
> > stream or a stream that it depends on."

We've seen this on Vista before. I believe it's something to do with the MediaFoundation Transform for H264 decoding [1] we use, and has been fixed for Windows 7.

The other error message (No; Unsupported layers backend) is because of the layers backend not being accelerated (see the 0/1 Basic a few lines up), as we don't support hardware decoding in this configuration.


> 
> Another example of FB video (a simply 360p or 480p):
> http://postimg.org/image/kp5s0p5zx/
> when I have this issue, then in the "Graphics" I see other unusual strings
> like:
> 
> > (#413) Assert	Attempt to create DrawTarget for invalid surface. Size(1090,1134) Cairo Status: 1 <
> 

This is worrying. If we're getting cairo errors, then it could easily cause drawing to temporarily stop and cause things like black rectangles, or the screen failing to update.

Do you have steps to reproduce this in a clean profile?


[1] https://msdn.microsoft.com/en-us/library/windows/desktop/dd797815%28v=vs.85%29.aspx
Flags: needinfo?(matt.woodrow)
(Reporter)

Comment 32

3 years ago
the same steps in a clean profile. exactly the same: use facebook, watch FB video....

(The strange "YouTube reports MSE/H264 not supported", but in the past FF releases [until FF39?] "YouTube reported MSE/H264 was supported")

(It is still valid the request for a workaround, like some addon... that could force FB videos' playback via flash player, that supports well acceleration).
(Reporter)

Comment 33

3 years ago
Maybe that all 4 problems you quoted with *
are "the same", i.e. I only see the string "(#413) Assert	Attempt " when the problem arises, if I dont use FB I never become this string or any issue.
(Reporter)

Comment 35

3 years ago
I noticed a BIG ameliorament (NO more black rectangles and hang, even after 18 hours!) 
by changing:

layers.offmainthreadcomposition.enabled to false
media.fragmented-mp4.enabled to false.
Yorgos, do you need to set *both* "media.fragmented-mp4.enabled" and "layers.offmainthreadcomposition.enabled" to false? Or setting "media.fragmented-mp4.enabled" to false adequate to fix the YouTube and Facebook video problems?
(Reporter)

Comment 37

3 years ago
Hi,

media.fragmented-mp4.enabled to false fix my problems described in this topic and here too https://bugzilla.mozilla.org/show_bug.cgi?id=1222272.

(Obviously with "false" Vimeo videos dont start at all, so I have to re-set to "true" for Vimeo videos, but...I never had problems with Vimeo, regardless the key settings).

So I would say that media.fragmented-mp4.enabled to false is a very good workaround, while it forces FB videos via Flash Player, even if without acceleration, while the addon for youtube enables the acceleration for flash so I can watch 1080 (or higher) with 1-3% CPU; instead with flash on FB i have 30% CPU but zero black rectangles and zero hangs.

(PS: layers.offmainthreadcomposition.enabled to false. Perhaps this has nothing to do with my issue presented in this topic, but I *prefer* having it to False too, because with True there are microlags, but only when I reduce FF window to the bottom of the screen, while with False all is smooth as it should be).
A much better option so you don't have to disable MP4 is to set media.mediasource.webm.enabled to true

YouTube will serve webm/vp9 then.

When you disable MP4, this is what will happen automatically.

Won't fix Facebook however..
(Reporter)

Comment 39

3 years ago
Interesting.
Doing so I see "H264 blue" as in the past!
YT is isung html5 now.
We will see the behaviour after a day usage, and what happens with the main problem (FB).
(Reporter)

Comment 40

3 years ago
No, I cannot accept this suggestion.
Even if I see
http://postimg.org/image/ssvp8s54t/
and was happy, I just opened a FB video and I become a total hang.

I have to re-set to false MP4.
(In reply to Yorgos from comment #40)
> No, I cannot accept this suggestion.
> Even if I see
> http://postimg.org/image/ssvp8s54t/

If you see this, then you haven't enabled MSE/webm
(Reporter)

Comment 42

3 years ago
Anyway your and mine are workaround. How about my issue?
why after upgradig from ff39 to ff40 I dont have hw acceleration for mp4?
(Reporter)

Comment 43

3 years ago
(today even with media.fragmented-mp4.enabled to False I am able to watch VimeoHD without problems, but this is not important; the main problem is FB; at the moment I watch FB videos via flash player, this helps a lot).
(Reporter)

Comment 44

3 years ago
I tried a lot FB and I am fine with my workaround described above, that solves bug#1222272 too.
Anyway I wait to verify what will happen in FF44
with this special changelog:
http://postimg.org/image/766t0xvg3/


[[ If it may help I add a PDF regarding dxva published by microsoft on 1/14/2016 related to Vista:
https://download.microsoft.com/download/5/f/c/5fc4ec5c-bd8c-4624-8034-319c1bab7671/DXVA_H264.pdf

]]
(Reporter)

Comment 45

3 years ago
ehmmm Sorry what are you doing?
FF44:
1) the key media.fragmented-mp4.enabled has been fully removed, so I cannot use facebook; i.e. you removed my workaround; so I definitely can not use FF for FB, while until today I was able;
2) after installing FF44 the addon "youtube flash video player 43" disappeared;
3) now YT can run only with html5 (see Fb problems at #1 )
4) reply to #38 Avenard:
http://postimg.org/image/7x35d8511/
I go
http://postimg.org/image/4rijn0met/
Is this a different issue?

5) as Summary:
does Firefox still support Vista: yes/no  ?
(Reporter)

Comment 47

3 years ago
In meantime the issue with the addon has been fixed.
Now I see:
http://postimg.org/image/rn789mroj/


so I delete question #2, #3, while I confirm the other questions. thanks
(In reply to Yorgos from comment #45)
> ehmmm Sorry what are you doing?
> FF44:
> 1) the key media.fragmented-mp4.enabled has been fully removed, so I cannot
> use facebook; i.e. you removed my workaround; so I definitely can not use FF
> for FB, while until today I was able;

we haven't removed anything.
The key was renamed to media.mp4.enabled
(Reporter)

Comment 49

3 years ago
good to hear ;)
(In reply to Yorgos from comment #45)
> 2) after installing FF44 the addon "youtube flash video player 43"
> disappeared;
we don't make that extension.
it appears to have been updated to support 44
https://addons.mozilla.org/en-us/firefox/addon/youtube-flash-video-player/

> 3) now YT can run only with html5 (see Fb problems at #1 )

All facebook videos should now be html5 mp4/h264

> 4) reply to #38 Avenard:
> http://postimg.org/image/7x35d8511/
> I go
> http://postimg.org/image/4rijn0met/
> Is this a different issue?
> 

the only way to get this result is if you have disabled webm by setting media.webm.enabled to false.


> 5) as Summary:
> does Firefox still support Vista: yes/no  ?

of course we support it.

Though it's pretty clear that all your issue are related to buggy graphic drivers. You would be much better of upgrading to a better supported OS. Upgrade to windows 10 which is free.
While we try to get around graphic/driver bugs, there's so much we can do and so much resources and effort we can dedicate on supporting an obsolete OS. Vista is old and MS stopped mainstream support 4 years ago.
(Reporter)

Comment 51

3 years ago
1) Buggy graphic drivers? only for Mozilla browser?

2) thanks God now Fb videos playback via flash player, therefor I can use them again.
3) it seems that yoy dont trust me or that I am too much wrong in english; I repeat:
I have
http://postimg.org/image/7x35d8511/
and I see this
http://postimg.org/image/4rijn0met/
stop.

(Vista will die on 11th April 2017 but as I said thank a lot for you help and support, I repeat you can closed this bug).

>>Though it's pretty clear that all your issue are related to buggy graphic drivers. You would be much better of upgrading to a better supported OS. Upgrade to windows 10 which is free.<<

In other word you are saying somwthing different than
"of course we support it."
you say that Vista is not supported and I have to switch wo w10 to get Firefox working.

I warmly thank you, I can close this topic.
(In reply to Yorgos from comment #51)
> 1) Buggy graphic drivers? only for Mozilla browser?
> 
> 2) thanks God now Fb videos playback via flash player, therefor I can use
> them again.
> 3) it seems that yoy dont trust me or that I am too much wrong in english; I
> repeat:
> I have
> http://postimg.org/image/7x35d8511/
> and I see this
> http://postimg.org/image/4rijn0met/
> stop.

Yes, and I wrote:

"the only way to get this result is if you have disabled webm by setting media.webm.enabled to false."

"media.webm.enabled" is different to "media.mediasource.webm.enabled"

media.webm.enabled will control the VP8 result you're seeing on your screenshot.
media.mediasource.webm.enabled will control the use of webm with MediaSourceExtension (as shown as "MSE & WebM VP9)
But having media.webm.enabled will disable MSE/WEBM too

so *both* must be set to true.
(Reporter)

Comment 53

3 years ago
but what you wrote here?
https://bugzilla.mozilla.org/show_bug.cgi?id=1230785#c38

;)
(Reporter)

Comment 54

3 years ago
you said "Yes", thereofore if I upgrade to driver 361.43 I finally go the hw acceleration and all the problems go away?
that is interesting.
(In reply to Yorgos from comment #53)
> but what you wrote here?
> https://bugzilla.mozilla.org/show_bug.cgi?id=1230785#c38

i write information about the data at hand.

you do need to set media.mediasource.webm.enabled to true to enable MSE/WEBM

media.webm.enabled is true by default, so it's not something you normally have to change.

But you obviously did.

I'm only trying to help, but you're making it very difficult to help you

That you jump at conclusions without reading what people are posting makes it even harder.
fixed by upgrading drivers.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 57

3 years ago
http://postimg.org/image/ucp9na4br/
http://postimg.org/image/qud9qw3fr/
http://postimg.org/image/95liz9ron/

also you established that the issues has been resolved by upgrading the driver to the latest available and doing this task the Graphic does not show ever:
http://postimg.org/image/9cvfe3azh/ but I will find a wonderful "yes". I trust to your statement.

You helped a lot, so to get FF working I simply need to upgrade to w10 and to buy another scanner and printer w10 compatible and other hardware. ok.
I wasted enough time here (finding from myself the workaround about MP4, the main theme of this topic).
(In reply to Yorgos from comment #45)
> 2) after installing FF44 the addon "youtube flash video player 43"
> disappeared;

"YouTube Flash Video Player" addon version 44.0 added support for Firefox 44. You can force Firefox to check for updated addons in the Add-on Manager's button with the "gear" icon.

https://addons.mozilla.org/en-US/firefox/addon/youtube-flash-video-player/versions/
(Reporter)

Comment 59

3 years ago
Yes Chris, much appreciated, now it works, at least YT videos work well after upgrading the addon to 44, thanks.
Jean-Yves - do we have something to blacklist here?
Flags: needinfo?(jyavenard)
(Reporter)

Comment 61

3 years ago
Now I installed driver 361.91, the latest available.
http://postimg.org/image/b1j0mo6if/

I have big difficulties in understanding why in the past I always saw 1/1Direcit11 OMTC, now - after ff44- I see 0/1 Basic.

My GTX650 and 361.91 has been blacklisted (!).

Comment 62

3 years ago
I have a similar problem on YT (high CPU usage and video as well as audio stuttering) caused by the lack of H.264 HW acceleration on Vista with an NVidia 105M mobile graphics card and the newest drivers available – which aren’t exactly new, but sufficient for VLC to do the job. ;)

I pasted the data from about:support and a trace log made with DXVA Checker when I had it play back a few seconds of a video I downloaded from YouTube to https://pastebin.mozilla.org/8871899 .

Comment 63

3 years ago
Dammit, forgot the last line, sorry about the double-post: I’ll open a new bug report referencing this one as soon as I think I’ll be able to properly participate in resolving this issue.
(Reporter)

Comment 64

3 years ago
what I dont understand is:
I can run 4K up to 120Mbps very fine via dxva2 (i.e. 5% CPU in full screen), therefore I will never understand why Mozilla blacklisted my GPU, so I cannot run a simply 240p in facebook.
(Reporter)

Comment 65

3 years ago
(In reply to chrcnt7 from comment #63)
perhaps you can post here, better than to open a new bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=1222272
wfm
Flags: needinfo?(jyavenard)
You need to log in before you can comment on or make changes to this bug.