[Add-ons] Add-ons for Homescreen are not running after reboot

RESOLVED DUPLICATE of bug 1223054

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 1223054
3 years ago
3 years ago

People

(Reporter: Carl Brown, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

467 bytes, application/x-zip-compressed
Details
(Reporter)

Description

3 years ago
Created attachment 8696335 [details]
homescreenTest.zip

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

Create an Add-on for Homescreen (see manifest.json and test.js)

matches: app://homescreen.gaiamobile.org/index.*
test.js contains alert('Homescreen Add-on test running');

Deploy from WebIDE.

Runtime Info:
apptype	b2g
vendor	Mozilla
name 	B2G
version	2.5.0.0-prerelease
appbuildid	20151023030241
changeset	0625c68c0abcfe4d10880d15d8fe7d06df3369c9
platformbuildid	20151023030241
geckobuildid	20151023030241
platformversion	44.0a1
geckoversion	44.0a1
locale	en-US
endianness	LE
hostname	localhost
os	B2G
platform	B2G
hardware	qcom
arch	arm
processor	arm
compiler	eabi
profile	default
channel	 nightly


Actual results:

The alert runs after enabling the Add-on and pressing the home-button. Also, it runs when restarting the Homescreen from WebIDE.
But the alert is missing after booting (which starts the Homescreen)


Expected results:

The alert should also run after booting (which starts the Homescreen)
This has been fixed in bug 1223054
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1223054
You need to log in before you can comment on or make changes to this bug.