The "Authorized Numbers" view can't display completely.

VERIFIED FIXED

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: wenqiuhong, Assigned: kgrandon)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.5 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-aries-test-run-4])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8696404 [details]
logcat_1034.txt

[1.Description]: 
[Aries KK master][Flame KK master] The "Authorized Numbers" view can't display completely after user taps the phone number.
See attachments: Aries_KK_master.3gp&logcat_1034.txt
Found time: 10:34

[2.Testing Steps]: 
1. Launch Settings---> Call settings----->Fixed Dialing Numbers
2. Enable Fixed Dialing Numbers
3. Add a phone number
4. Tap the phone number

[3.Expected Result]: 
4. The "Authorized Numbers" view should display correctly.

[4.Actual Result]: 
4. The "Authorized Numbers" view can't display completely.

[5.Reproduction build]: 
Device: Aries KK master(Affected)
Build ID               20151206002630
Gaia Revision          b930e25e9f2e5ec2106dd31005468575cdf87d50
Gaia Date              2015-12-05 03:41:55
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc9c6cd756cb744596ba039dcc5ad3065a7cc3ea
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151205.234548
Firmware Date          Sat Dec  5 23:45:56 UTC 2015
Bootloader             s1

Device: Flame KK master 512mb(Affected)
Build ID               20151206150208
Gaia Revision          b930e25e9f2e5ec2106dd31005468575cdf87d50
Gaia Date              2015-12-05 03:41:55
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc9c6cd756cb744596ba039dcc5ad3065a7cc3ea
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151206.184313
Firmware Date          Sun Dec  6 18:43:25 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
status-b2g-master: --- → affected
(Reporter)

Comment 1

3 years ago
Created attachment 8696406 [details]
Aries_KK_master.3gp
(Reporter)

Comment 2

3 years ago
Note:  
  I can't check v2.5 because there is another bug to block my checking: bug 1230874 - The FDN numbers "Cancel" button will show as a rectangular button.
    This bug doesn't occur on latest Flame v2.5 and Aries KK v2.5, the "Call/Edit contact/Delete contact/Cancel" dialog remains normally after step 4 (though another bug 1230874 occurs as mentioned in comment 2). Then I try to find the regressionwindow on Flame master as below.


Device: Flame KK 2.5_512mb user (unaffected)
Build ID               20151207121611
Gaia Revision          2d54c29f429bed790b5d8284633812dc2b782518
Gaia Date              2015-12-02 14:41:15
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/c491dedc389de5c4686543b990c92d4f47715ee8
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151207.112748
Firmware Date          Mon Dec  7 11:27:57 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 dogfood (unaffected)
Build ID               20151207121707
Gaia Revision          2d54c29f429bed790b5d8284633812dc2b782518
Gaia Date              2015-12-02 14:41:15
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/c491dedc389de5c4686543b990c92d4f47715ee8
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151207.112548
Firmware Date          Mon Dec  7 11:25:56 UTC 2015
Bootloader             s1


-------------------------------------------------------------------------------------
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame master (512mb)
Build ID               20151128141732
Gaia Revision          6d66a9eff9fd33fafc97bc75753558969de48cc3
Gaia Date              2015-11-28 21:33:58
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/2ffd52cd41cc9847fa418d224e0507436f0f8869
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151126.182758
Firmware Date          Thu Nov 26 18:28:10 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame master(512mb)
Build ID               20151128150533
Gaia Revision          fa9b88501c84cbb171db9d778cca74b70d80f433
Gaia Date              2015-11-28 22:07:10
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/ed3c9fc97142e4fcf6215db0b9ed80d09ec72db0
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151126.182758
Firmware Date          Thu Nov 26 18:28:10 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia Revision          fa9b88501c84cbb171db9d778cca74b70d80f433
Gecko Revision         2ffd52cd41cc9847fa418d224e0507436f0f8869

First Broken Gecko & Last Working Gaia - issue DOES NOT repro
Gaia Revision          6d66a9eff9fd33fafc97bc75753558969de48cc3
Gecko Revision         ed3c9fc97142e4fcf6215db0b9ed80d09ec72db0


Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/6d66a9eff9fd33fafc97bc75753558969de48cc3...fa9b88501c84cbb171db9d778cca74b70d80f433
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.5: --- → unaffected
Keywords: regression
Hi Kevin,

    According to the comment 3, this bug is possibly caused by Bug 1225418. Could you please help to take a look? 

Thank you very much.
Flags: needinfo?(kevin+bugzilla)
(Assignee)

Comment 5

3 years ago
This is possibly fixed by bug 1230874. Still need to confirm that, so leaving the NI.
(Assignee)

Comment 6

3 years ago
Hi Shally - can we try to verify this bug now that bug 1230874 is fixed?
Assignee: nobody → kevin+bugzilla
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Depends on: 1230874
Flags: needinfo?(kevin+bugzilla) → needinfo?(lixia)
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame master and Aries KK master by the STR in comment 0.

Actual results: After you tap a contact in "Authorized Numbers" view, the "Call/Edit contact/Delete contact/Cancel" dialog displays correctly. 
See attachment: verified_Flame_master.3gp
Reproduce rate: 0/10


Device: Flame master_512mb eng (Pass)
Build ID               20151210150222
Gaia Revision          7e962276913bd4da7ce5fa7540767107ce322c78
Gaia Date              2015-12-09 21:27:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/412e4d7ce98ca4dbc37de133d0f26d7e1a59946f
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151210.183953
Firmware Date          Thu Dec 10 18:40:06 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK master eng (Pass)
Build ID               20151210120926
Gaia Revision          7e962276913bd4da7ce5fa7540767107ce322c78
Gaia Date              2015-12-09 21:27:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/412e4d7ce98ca4dbc37de133d0f26d7e1a59946f
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151210.112747
Firmware Date          Thu Dec 10 11:27:55 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
status-b2g-master: affected → verified
Flags: needinfo?(lixia)
Created attachment 8697449 [details]
verified_Flame_master.3gp
You need to log in before you can comment on or make changes to this bug.