Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: bomt, Assigned: Antonio Ladeia, Mentored)

Tracking

2016-3.3

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

1. input: a new post to search input.
2. Tap btn [Search].



Actual results:

=> Actual Reuslt: slow and hang Firefox, message response: "Request too large"!


Expected results:

limit the search length.
Version: 2014-01.1 → other
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mentor: jgiannelos
Let's limit this one to 140 chars.
In order to tackle this one we just need to change the `max_length` validator to 140 of `q` field in `mozillians.phonebook.forms.Searchform`

https://docs.djangoproject.com/en/1.8/ref/forms/fields/#charfield
Assignee: nobody → contato
(Assignee)

Comment 2

2 years ago
I think finish this bug, I send one pull request in github https://github.com/mozilla/mozillians/pull/1350.
Flags: needinfo?(jgiannelos)

Comment 3

2 years ago
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/e679a790f1ed30c449eb45e740a7b6903be0b8dc
[Fix bug 1230887] Add max character limit in search form fields

https://github.com/mozilla/mozillians/commit/15cf97dc1cf77ac540004411341e6adb629487a0
Merge pull request #1359 from Ladeia/bug1230887

[Fix bug 1230887] Add max character limit in search form fields

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Flags: needinfo?(jgiannelos)
Version: other → next
Verified on stage:

* Large search string raises an error in prod
* The same strings gets restricted because of max length in stage
* Search is not raising an error because of the large string in stage
Status: RESOLVED → VERIFIED
Version: next → 2016-3.3
You need to log in before you can comment on or make changes to this bug.