[L10n][Settings]Ukrainian:The text "Tap & hold Delay" is displayed with truncation in Accessibility.

RESOLVED FIXED

Status

Mozilla Localizations
uk / Ukrainian
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Alissa(leave from Mozilla), Assigned: Artem Polivanchuk)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-v2.5 affected, b2g-master verified)

Details

(Whiteboard: LocRun2.5)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8696428 [details]
Ukrainian_Tap & hold Delay_flamekk2.5.png

[1.Description]:
[L10n][FlameKK v2.5&master][Settings]]Ukrainian:The text "Tap & hold Delay" is displayed with truncation in Accessibility.
See attachment:Ukrainian_Tap & hold Delay_flamekk2.5.png

[2.Testing Steps]: 
1.Set your phone language as Amharic.
2. Launch Settings app. 
3. Tap Accessibility to enter it. 
4. Observe string "Input". 

[3.Expected Result]: 
4.The hint text"Tap & hold Delay" should not be displayed with truncation.

[4.Actual Result]: 
4.The hint text"Tap & hold Delay" is displayed with truncation.

[5.Reproduction build]: 
FlameKK Master 512mb build (Affected):
Build ID               20151206150208
Gaia Revision          b930e25e9f2e5ec2106dd31005468575cdf87d50
Gaia Date              2015-12-05 03:41:55
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc9c6cd756cb744596ba039dcc5ad3065a7cc3ea
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151206.182655
Firmware Date          Sun Dec  6 18:27:07 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

FlameKK v2.5 512mb build (Affected):
Build ID               20151205004159
Gaia Revision          2d54c29f429bed790b5d8284633812dc2b782518
Gaia Date              2015-12-02 14:41:15
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/462016c61fe624c8ac3ff7d55c10754ce38dfa99
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151204.235304
Firmware Date          Fri Dec  4 23:53:14 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
17551

[8.NOTE]
On Flame 2.2, there is no "Input" in Accessibility.
(Reporter)

Updated

2 years ago
QA Whiteboard: [MGSEI-l10n-2F]
status-b2g-v2.2: --- → affected
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
(Assignee)

Updated

2 years ago
Assignee: nobody → a.polivanchuk
(Assignee)

Comment 1

2 years ago
Fixed in master for testing:
https://hg.mozilla.org/gaia-l10n/uk/rev/bcf039203282
(Assignee)

Comment 2

2 years ago
Just checked this string on my Sony Xperia Z3C (2.6) and it doesn't looks truncated.
As I see, string truncation depends on display pixel ratio.
So, the question is should it be fixed in this case?
(Assignee)

Updated

2 years ago
Flags: needinfo?(lebedel.delphine)
Hey Artem - thanks for asking. I think since Flame is our reference device, and it looks cut-off on Flame, that's what we should be targeting. However, if you think the string is still understandable as is, then no need to find a workaround :) thanks!
Flags: needinfo?(lebedel.delphine)
(Reporter)

Comment 4

2 years ago
This issue has been verified as pass on flame master.
Rate:0/5

Device: Flame master user[pass]
Build ID               20151215150203
Gaia Revision          ee43a95f2bbe39c5ac8c9fcdec76749a56c02f2e
Gaia Date              2015-12-15 04:30:46
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cb66ffeb6725e8344818e8e2f707ae2eaeb953b4
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151215.185707
Firmware Date          Tue Dec 15 18:57:19 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-b2g-master: affected → verified
Resolution: --- → FIXED
(Reporter)

Comment 5

2 years ago
Created attachment 8698772 [details]
Verify1_pass_flamekk master.png
You need to log in before you can comment on or make changes to this bug.