Message lost if failed to send and Cancel option chosen

UNCONFIRMED
Unassigned

Status

Thunderbird
Message Compose Window
UNCONFIRMED
2 years ago
a year ago

People

(Reporter: studersi, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupme])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151105173914

Steps to reproduce:

Send a message in Thunderbird 38.4.0.


Actual results:

The message failed to send (probably because attachment was too large). A pop opened asking whether to retry or cancel. Retrying didn't work, so I clicked cancel to remove attachment and send a modified version of the mail without attachmant.


Expected results:

The window for composing the mail disappeared, discarding the whole message instead of leaving it open or saving it as draft.

Comment 1

2 years ago
Does it still happen in version 45?
If so, can you restate the problem - actual and expected results - there seems to me some conflict in what you wrote.
Flags: needinfo?(bugzilla)
Whiteboard: [closeme 2016-06-05]
(Reporter)

Comment 2

2 years ago
I'm using the version in the Linux mint repository. I'll upgrade as soon as the website is working again:
https://download.mozilla.org/?product=thunderbird-45.1.1-SSL&os=linux64&lang=en-US (link on Thunderbird front page) is returning me a 404 Not Found.

It seems I mixed up the Actual Result and Expected Result, my bad.

-----------------------------------------------
Actual results:

The message failed to send (probably because attachment was too large). A pop opened asking whether to retry or cancel. Retrying didn't work, so I clicked cancel because I wanted to remove the attachment and send a modified version of the mail without attachment. However, the window for composing the mail disappeared, discarding the whole message.


Expected results:

When I clicked cancel, I expected to go back to the window for composing the message or at least save the current message as draft before closing.
-----------------------------------------------

I hope it's more clear now.

Comment 3

a year ago
Resolved per whiteboard, feel free to reopen if you still have the issue
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(bugzilla)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2016-06-05]

Updated

a year ago
Status: RESOLVED → UNCONFIRMED
Component: Untriaged → Message Compose Window
Resolution: INCOMPLETE → ---
Summary: Message lost if failed to send → Message lost if failed to send and Cancel option chosen
Whiteboard: [dupme]
You need to log in before you can comment on or make changes to this bug.