Closed Bug 1231004 Opened 6 years ago Closed 6 years ago

DuckDuckGo's hamburger menu-items (e.g. themes) do not receive clicks

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1226904

People

(Reporter: mhoye, Unassigned)

Details

(Keywords: regression, site-compat)

Arenlor reports that at some point DuckDuckGo themes - available through the pancake menu - have stopped working in Nightly. They work correctly in current Beta.

You can reproduce the bug by clicking the pancake menu in the upper corner and picking any theme; works in Beta, not Nightly.
Indeed, the DIV that slides in has a z-index:200 applied, but the mouse acts on the BODY element as if the DIV wasn't there.
This regressed between 2015-11-16 and 2015-11-17.
Keywords: site-compat
Moving to Firefox General for triage, sounds like this isn't a tech evangelism bug (feel free to move this to the correct component if you know what it is).
Component: Desktop → General
Keywords: regression
Product: Tech Evangelism → Firefox
This is not just a problem choosing a theme; nothing in the referred menu receives a click, it behaves as if it is not there at all.  The same goes for the round navigation buttons that show on the zero click (immediate) results (e.g, videos):  If you click on any of the buttons is exactly the same as if you click on a tile that it partially covers.  I hope no other websites are affected but this page being affected is annoying enough.
This bug reminds me of an issue I had in my Simple White X theme (https://github.com/johngraciliano/simplewhite/issues/14) but I have not being able to correlate the cause (an extra css rule setting max-height: 0).
My guess would be bug 1208673. Thinker, can you confirm?

The patch in bug 1230693 does not fix this.
Blocks: 1208673
Flags: needinfo?(tlee)
Component: General → Layout
Product: Firefox → Core
It seems fixed in Nightly 46.0a1 (2015-12-27)
(In reply to Markus Stange [:mstange] from comment #6)
> My guess would be bug 1208673. Thinker, can you confirm?
> 
> The patch in bug 1230693 does not fix this.

Note: If this is a regression from bug 1208673, then I probably would not expect bug 1230693's patch to help. (Bug 1230693 is a regression from a *different* change.)

I would, however, hope that bug 1226904's patch might help. And based on comment 7, maybe it did...?
It appears to be fixed here too. I'm not sure who fixed it when, but hey.
I verified this is not a problem with Nightly 46.0a1 (2015-12-28).  I verified it was not a change in the website by confirming the problem is still present when I run Nightly 46.0a1 (2015-12-24).
I tested this with the x64 version of Firefox on Windows 8 in a low end Samsung laptop with Intel Core I3.
Nightly fix window (obtained using mozregression):
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=35b211eaad1fa828064514c547057e4400e24459&tochange=3c5e7567281ff6d6fe43726bd65923165458abc4

That includes bug 1226904's fix, so based on that fact & the shared regression-bug, I'm calling this a dupe of bug 1226904.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226904
Summary: DuckDuckGo themes have stopped working in Nightly → DuckDuckGo's hamburger menu-items (e.g. themes) do not receive clicks
Flags: needinfo?(tlee)
No longer blocks: 1208673
You need to log in before you can comment on or make changes to this bug.