"Learn More" text in Firefox Account Age Verification pop up is not a functioning web link.

VERIFIED FIXED

Status

Firefox OS
FxA
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Marty, Assigned: gandalf)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.6?, b2g-v2.5 unaffected, b2g-master verified)

Details

(Whiteboard: [2.6-Daily-Testing][Spark])

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8696546 [details]
logcat_FxA-COPPA.txt

Description:
If the user inputs a birthday for a Firefox Account that is not sufficiently old for COPPA guidelines, they are presented with a Pop-Up message that reads:

"Cannot Create Account: You must meet certain age requirements to create a Firefox Account. Learn more"

The "Learn more" text is not colored blue, and does not function as a web link when tapped.

Repro Steps:
1) Update a Aries to 20151207143802
2) Navigate to Settings > Firefox Account.
3) Begin creating a new account
4) At the Age Verification page, input 2013 as the year of birth, and select Next
5) Read the Pop-Up message, and attempt to tap "Learn More"

Actual:
"Learn More" is not a functional web link, and will not take the user to the proper ftc.gov COPPA page.

Expected:
"Learn More" is a working web link that takes you to the correct ftc.gov COPPA page.

Environmental Variables:
Device: Aries 2.6
Build ID: 20151207143802
Gaia: 24ed003a53a81f63367e265fa7117cbe7d23d4c8
Gecko: 59bc3c7a83de7ffb611203912a7da6ad84535a5a
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 10/10
See attached: Screenshot, Logcat
(Reporter)

Comment 1

2 years ago
Created attachment 8696547 [details]
FxA_Learn-More_Screenshot.png
(Reporter)

Comment 2

2 years ago
This issue DOES occur on the latest Flame 2.6 Nightly build.
"Learn More" is not a functional web link, and will not take the user to the proper ftc.gov COPPA page.

Environmental Variables:
Device: FlameKK 2.6 (512MB)
BuildID: 20151207030216
Gaia: 24ed003a53a81f63367e265fa7117cbe7d23d4c8
Gecko: 528ea05671e9bd9ccb33d1558a20691a72c85f98
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

********************************************

This issue does NOT occur on the latest Flame 2.5.
"Learn More" is a working web link that takes you to the correct ftc.gov COPPA page.

Environmental Variables:
Device: FlameKK 2.5 (512MB)
BuildID: 20151207121611
Gaia: 2d54c29f429bed790b5d8284633812dc2b782518
Gecko: c491dedc389de5c4686543b990c92d4f47715ee8
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Blocking requested because this link should work.

Let's get a window here.
blocking-b2g: --- → 2.6?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted

Updated

2 years ago
QA Contact: jthomas

Comment 4

2 years ago
Unable to finish window at this time. Will be finishing ASAP tomorrow morning. Here are my results thus far. 

CentralRegression Window

Last Working
Environmental Variables:
Device: Flame 2.6
BuildID: 20151121035032
Gaia: a8a365704d98788d6842f0d88589fec96beb6e08
Gecko: abbd213422a560f1180c4ec6e3bf4792c2ea81ba
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken
Environmental Variables:
Device: Flame 2.6
BuildID: 20151123025227
Gaia: bae13c9ac6a91beecd7c94384e2aef25ed1a3214
Gecko: db77a24c37698b4e71f8ba0fba170a0c157fc1f9
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Last Working gaia / First Broken gecko -Unaffected
Gaia: a8a365704d98788d6842f0d88589fec96beb6e08
Gecko: db77a24c37698b4e71f8ba0fba170a0c157fc1f9

Last Working gecko / First Broken gaia - Affected
Gecko: abbd213422a560f1180c4ec6e3bf4792c2ea81ba
Gaia: bae13c9ac6a91beecd7c94384e2aef25ed1a3214

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/a8a365704d98788d6842f0d88589fec96beb6e08...bae13c9ac6a91beecd7c94384e2aef25ed1a3214
Flags: needinfo?(jmercado)
Flags: needinfo?(jmercado)

Comment 5

2 years ago
Caused by changes made in Bug 1224065 

B2G Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.6
BuildID: 20151120100237
Gaia: a8a365704d98788d6842f0d88589fec96beb6e08
Gecko: 106bfad77bf44d39fc334b336b037a70c2130d52
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken
Environmental Variables:
Device: Flame 2.6
BuildID: 20151120142231
Gaia: 9676bd7fece5692332bf995e933194fb765ed160
Gecko: e75cf58a362650b61c8b8f73b01ddcf931482cd1
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Last Working gaia / First Broken gecko - This does NOT occur with broken Gecko
Gaia: a8a365704d98788d6842f0d88589fec96beb6e08
Gecko: e75cf58a362650b61c8b8f73b01ddcf931482cd1

Last Working gecko / First Broken gaia - This issue DOES occur with broken Gaia
Gecko: 106bfad77bf44d39fc334b336b037a70c2130d52
Gaia: 9676bd7fece5692332bf995e933194fb765ed160

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/a8a365704d98788d6842f0d88589fec96beb6e08...9676bd7fece5692332bf995e933194fb765ed160
Blocks: 1224065
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
(Assignee)

Comment 6

2 years ago
taking!
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
Created attachment 8696774 [details] [review]
[gaia] zbraniecki:1231022-learn-more-link-fix > mozilla-b2g:master
(Assignee)

Comment 8

2 years ago
Comment on attachment 8696774 [details] [review]
[gaia] zbraniecki:1231022-learn-more-link-fix > mozilla-b2g:master

Ugh, sorry @ferjm! My mistake.

So, basically, we didn't have <a> in the source so DOMOverlay just removed it from localization.

With this change it will use the <a> from the HTML for COPPA error and remove it for other errors which don't use <a>.
Attachment #8696774 - Flags: review?(ferjmoreno)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Attachment #8696774 - Flags: review?(ferjmoreno) → review+
(Assignee)

Comment 9

2 years ago
btw. The fact that we have all those entities sharing a single HTML container and we just assign data-l10n-id to it is not optimal.

Currently, only COPPA link contains a link, but in theory, any of the errors may have its own children HTML elements and should have its own container then. I'll add a comment note in the file
(Assignee)

Comment 10

2 years ago
Comment on attachment 8696774 [details] [review]
[gaia] zbraniecki:1231022-learn-more-link-fix > mozilla-b2g:master

Sorry for bothering you more, but I had to update the patch. I decided to separate the coppa message from others, so that if anyone will need to add HTML to their message they will know how.

Can you review it again pls?
Attachment #8696774 - Flags: review+ → review?(ferjmoreno)
Attachment #8696774 - Flags: review?(ferjmoreno) → review+
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Aries KK master and Flame KK master 512mb by the STR in comment 0 .

Actual result: "Learn More" is a working web link that takes you to the correct ftc.gov COPPA page.
See attachment: verified_Aries_KK_master.3gp
Reproduce rate: 0/10.

Device: Aries KK master(Pass)
Build ID               20151216115605
Gaia Revision          a84c2dbe672583914d04380cd61a56f1c60c3b8e
Gaia Date              2015-12-16 06:59:39
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/0babaa3edcf908c393b68a3dc2d1c2a2450c31ed
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151216.113143
Firmware Date          Wed Dec 16 11:31:51 UTC 2015
Bootloader             s1

Device: Flame KK master 512mb(Pass)
Build ID               20151216150211
Gaia Revision          a84c2dbe672583914d04380cd61a56f1c60c3b8e
Gaia Date              2015-12-16 06:59:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0babaa3edcf908c393b68a3dc2d1c2a2450c31ed
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151216.185725
Firmware Date          Wed Dec 16 18:57:38 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-master: affected → verified
Created attachment 8699312 [details]
verified_Aries_KK_master.3gp
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+],[MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.