Assertion failure: shouldYFlip || srcStride != dstStride (Performance trap -- should handle this case earlier to avoid memcpy), at dom/canvas/WebGLTexelConversions.cpp:381

RESOLVED FIXED in Firefox 46

Status

()

Core
Canvas: WebGL
--
major
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: bc, Assigned: jgilbert)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
mozilla46
Unspecified
Mac OS X
assertion, testcase
Points:
---

Firefox Tracking Flags

(firefox45 affected, firefox46 fixed)

Details

(Whiteboard: [gfx-noted], URL)

Attachments

(3 attachments)

Created attachment 8696565 [details]
minidump crash report

1. http://m.thehindu.com/news/national/latest-updates-on-chennai-floods/article7951783.ece

2. Assertion failure: shouldYFlip || srcStride != dstStride (Performance trap -- should handle this case earlier to avoid memcpy), at /builds/slave/m-cen-m64-d-000000000000000000/build/src/dom/canvas/WebGLTexelConversions.cpp:381

Reproduced Nightly/45 OSX 10.8

build: https://hg.mozilla.org/mozilla-central/rev/cc9c6cd756cb744596ba039dcc5ad3065a7cc3ea

I can reproduce with a saved version. I'll try to reduce.
Summary: ssertion failure: shouldYFlip || srcStride != dstStride (Performance trap -- should handle this case earlier to avoid memcpy), at dom/canvas/WebGLTexelConversions.cpp:381 → Assertion failure: shouldYFlip || srcStride != dstStride (Performance trap -- should handle this case earlier to avoid memcpy), at dom/canvas/WebGLTexelConversions.cpp:381
Created attachment 8697967 [details]
testcase bug-1231040.tar.bz2

untar the file then load ./bug-1231040/m.thehindu.com/news/national/latest-updates-on-chennai-floods/index.html

You may need to create a new profile each time you want to reproduce this. I don't have time to work up a script that will recreate it each time in order to reduce it.
Keywords: testcase
Jeff, what should we do here?
Flags: needinfo?(jgilbert)
Whiteboard: [gfx-noted]
(Assignee)

Comment 3

3 years ago
Historically we hit this because we messed up an earlier branch; we really should be catching this before it gets here.

The profile requirement might be the CrashGuard stuff?
Flags: needinfo?(jgilbert)
(Assignee)

Comment 4

3 years ago
Created attachment 8698293 [details] [diff] [review]
0001-Fast-path-if-not-alpha-premultiplying.patch
Assignee: nobody → jgilbert
Attachment #8698293 - Flags: review?(jmuizelaar)
(Assignee)

Updated

3 years ago
Flags: needinfo?(jgilbert)

Comment 8

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5ab4f7bd7eda
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
You need to log in before you can comment on or make changes to this bug.