Closed Bug 1231098 Opened 4 years ago Closed 4 years ago

attached webpage (url) not displayed in event invitation

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), enhancement)

Lightning 4.0.4.1
x86_64
Linux
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: thomas.winterstein, Assigned: MakeMyDay)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151030083932

Steps to reproduce:

- create an event
  - invite someone to it
  - attach a webpage 
- view the event invitation at the invitee
=> no attached webpage is displayed, although it is in the sourcecode of the event

Tested on Windows and Linux, with local calendars and CalDAV.



Expected results:

Usually I am expecting TB Lightning to display the attached webpage, like other CalDAV-Clients do. Anyone else got this problem?
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
Yes, we should display the URI type attachements in the invitation preview. Additionally, I use this bug to implement displaying of the URI property.
Assignee: nobody → makemyday
Severity: normal → enhancement
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
This patch implements support for displaying a URL and multiple ATTACH (of URI type) links.
Attachment #8758913 - Flags: review?(philipp)
Comment on attachment 8758913 [details] [diff] [review]
ShowUrlAndAttachmentLinksInInvitationPreview-V1.diff

Review of attachment 8758913 [details] [diff] [review]:
-----------------------------------------------------------------

::: calendar/locales/en-US/chrome/lightning/lightning.properties
@@ +25,5 @@
>  imipHtml.organizer=Organizer:
>  imipHtml.description=Description:
> +# LOCALIZATION_NOTE(imipHtml.attachments): This is a label for one or more (additional) links to
> +# documents or websites attached to this event.
> +imipHtml.attachments=Attached Resources:

We've been using the term "Attachment" in other places, I think this should just be "Attachments:".

@@ +30,5 @@
>  imipHtml.comment=Comment:
>  imipHtml.attendees=Attendees:
> +# LOCALIZATION_NOTE(imipHtml.url): This is a label for a reference to an (alternate) online
> +# representation of the event (either directly human readable or not).
> +imipHtml.url=Event Reference:

What about "View Online:" ? I think this makes it more clear that this is a link to the event which will open in the browser, using simple language. In most cases the URL is something to be viewed in a browser. I'm ok with keeping Event Reference if you disagree though.

::: calendar/test/unit/test_ltninvitationutils.js
@@ +51,5 @@
>          "TRANSP:OPAQUE",
>          "LOCATION:Room 1",
>          "DESCRIPTION:Let us get together",
> +        "URL:http://wwww.example.com",
> +        "ATTACH:http://wwww.example.com",

four w's intended?
Attachment #8758913 - Flags: review?(philipp) → review+
Done. I replaced the url label with "Related Link:" as we have it in the dialog and I prefer over view online because not in all cases this is a reference to something you can view directly.

https://hg.mozilla.org/comm-central/rev/a6468040d468e4b88e0f2dbf812a3662014982bf
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 5.2
You need to log in before you can comment on or make changes to this bug.