Disable memory-based displayport size increase

RESOLVED FIXED in Firefox 45

Status

()

Core
Panning and Zooming
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

unspecified
mozilla45
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 fixed)

Details

Attachments

(1 attachment)

In bug 1208636 we added a pref to increase the displayport size on high-memory systems when panning fast. However it seems to cause some jank (see bug 1193969 comment 10, bug 1229929) and bad behaviour, so I think we should disable it for now. Once we have the checkerboarding metrics in place (bug 1226826) and can effectively see how much this helps, we can consider re-enabling it. (Note that this isn't a backout, it'll keep the code, just set the prefs default to zero).
Created attachment 8696721 [details] [diff] [review]
Patch

I also fixed alphabetization in gfxPrefs.h
Attachment #8696721 - Flags: review?(mchang)
Attachment #8696721 - Flags: review?(mchang) → review+

Comment 3

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/cc52b64c6eee
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
Blocks: 1231199
No longer blocks: 1229929
Duplicate of this bug: 1229929
You need to log in before you can comment on or make changes to this bug.