The numbers are displayed in reverse

VERIFIED FIXED in Firefox 45

Status

()

Core
Layout: Text
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: blinky, Assigned: jfkthame)

Tracking

({regression})

45 Branch
mozilla45
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox45 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Steps to reproduce:

The number is displayed 81 instead of 18 in the page https://dl.dropboxusercontent.com/u/95157096/85f61cf7/lj774qbaxg.html.


Actual results:

The number is displayed incorrectly.

Screenshot https://dl.dropboxusercontent.com/u/95157096/85f61cf7/vp7gru0xdy.png
Flags: needinfo?(jfkthame)
(Reporter)

Comment 1

2 years ago
Regression range (mozilla-central):
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c321d84038519dcf1670d59fd2c5c00ad8a85a55&tochange=47b49b0d32360fab04b11ff9120970979c426911


Regression range (mozilla-inbound):
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=18346cf05ada8c9f615c1e874b968a7ce6d9b0b0&tochange=aeafc4cca44784d13cfc2006371848794186dbd8

Triggered by: bug 1157727
(Reporter)

Updated

2 years ago
Blocks: 1157727
(Reporter)

Updated

2 years ago
Keywords: regression
(Assignee)

Comment 2

2 years ago
[Tracking Requested - why for this release]:
This is a regression that results in incorrect (misleading) display; it can actually corrupt the apparent meaning of the text. If we can't fix it reliably, we should back out bug 1157727 rather than risk shipping this.
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
status-firefox45: --- → affected
tracking-firefox45: --- → ?
Ever confirmed: true
Flags: needinfo?(jfkthame)
(Assignee)

Comment 3

2 years ago
Created attachment 8696771 [details]
reduced testcase showing incorrectly reordered digits in bidi text
(Assignee)

Comment 4

2 years ago
Created attachment 8696873 [details] [diff] [review]
Reftest for failure to recognize mixed directionality in RTL para beginning with number within embed/isolate controls

Here's a reftest based on the reduced testcase; currently fails.
Attachment #8696873 - Flags: review?(smontagu)
(Assignee)

Updated

2 years ago
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
(Assignee)

Comment 5

2 years ago
Created attachment 8696874 [details] [diff] [review]
Missed change from Unicode 6.3 bidi algorithm update (ported from ICU's ubidi): include new ENL and ENR bidi pseudo-types in MASK_LTR

The problem turned out to be a change that was missed when porting the updates from ICU (see source/common/ubidiimp.h) in bug 1157727. This resulted in us incorrectly considering the text to be a unidirectional RTL run at the end of ResolveExplicitLevels in this example, because DirectionFromFlags didn't recognize the digits as being LTR.
Attachment #8696874 - Flags: review?(smontagu)
(Assignee)

Comment 6

2 years ago
Try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=cb77f7a29681
Attachment #8696874 - Flags: review?(smontagu) → review+
Attachment #8696873 - Flags: review?(smontagu) → review+
(Assignee)

Comment 7

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c8b058539dfd865df1e6c8b01e94992d96df879e
Bug 1231175 - Reftest for failure to recognize mixed directionality in RTL para beginning with number within embed/isolate controls. r=smontagu

https://hg.mozilla.org/integration/mozilla-inbound/rev/db10960e8ea11debb896e7dcff01d971ef09827f
Bug 1231175 - Missed change from Unicode 6.3 bidi algorithm update (ported from ICU's ubidi): include new ENL and ENR bidi pseudo-types in MASK_LTR. r=smontagu

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c8b058539dfd
https://hg.mozilla.org/mozilla-central/rev/db10960e8ea1
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox45: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
(Reporter)

Updated

2 years ago
tracking-firefox45: ? → ---
QA Whiteboard: [good first verify]

Comment 9

2 years ago
 [testday-20160219]  Visited website https://dl.dropboxusercontent.com/u/95157096/85f61cf7/lj774qbaxg.html . Number displayed as 18. Bug fix verified.
Marking as verified based on comment 9.
Status: RESOLVED → VERIFIED
status-firefox45: fixed → verified
You need to log in before you can comment on or make changes to this bug.